Vai al contenuto
biowep

Problema con rendering

Recommended Posts

Un saluto a tutti, sono nuovo del forum.

Mi sono da poco avvicinato alla grafica 3D e dopo aver imparato un minimo di modellazione sto cercando di fare delle prove di rendering. La mia scena, molto semplice, è formata da 3 oggetti (bicchiere, contenuto ed il plane) e 2 luci (skylight e free spot). Il risultato è questo:

Test%2520rendering2.png

Si vede chiaramente, confrontando l'immagine dell'oggetto a sinistra con quella del rendering che c'è qualcosa che non va. È come se mancasse una parte dell'immagine in corrispondenza del liquido. Inoltre, perché il materiale sotto è di così bassa qualità? Da quel che ho visto in giro con mental ray si creano delle immagini da paura, praticamente uguali alla realtà. Perché il materiale legno del piano sottostante è venuto così male? L'ho scelto tra quelli di default (Autodesk Hardwood).

Ho altre due domande. I meteriali assegnabili agli oggetti dipendono dal motore che eseguirà il rendering? Perché ho visto che quando ho selezionato mental ray avevo dei materiali disponibili in più rispetto a quelli che ho con il Default Scanline Renderer.

L'ultima domanda è: non si possono creare oggetti solidi (massicci)? Ho notato che quando creo un cubo ed elimino ad esempio una faccia, questo diventa una specie di scatola con 5 facce.


Modificato da biowep

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ciao

non sono un professionista o un esperto come tanti che seguono o moderano il forum e quindi non saprei come mai hai questa brutta resa nel rendering finale...a mio avvis potrebbe(dico potrebbe)essere un problema di illuminazione,ma non lo si può dire con certezza senza sapere quante e quali luci(parametri compresi) hai messo e quali materiali hai utlizzato(e anche in questo caso sarebbe utile vedere i parametri e le mappe utilizzate)...

riguardo alle altre domande:

ti confermo che ogni motore di rendering porta con se una propria specifica libreria di materiali e mappe..mental ray ad esempio è un motore che ti permette di utlizzare molti più materiali rispetto al default scanline renderer(di solito questi materiali sono indicati con un pallino giallo mentre quelli dello scnaline con un pallino blu, almeno fino alla versione 3ds max 2010)...

l'ultima domanda sinceramente non l'ho capita...per quel che so io in 3ds max lavori su mesh che altro non sono che involucri , per cui se togli una faccia ti rimane necessariamente un vuoto...cioè non so se si possa abbinare il concetto di "pieno" a questa tipologia di modellazione...

ma come detto io non sono un esperto ma solo un appassionato..forse qualcun altro saprà risponderti meglio

spero cmq di esserti stato utile in qualche modo

Bye

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

controlla il mat del vetro è lui che crea pasticci. purtroppo non ci si puo fermare a mettere 2 mat in croce e dire che non funziona.

è tornato l'alter ego di luchettota...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Resetta tutto!

Imposta il motore di render in nvidia Mental Ray e attiva il Final gather, impostalo su un preset low o medium e cambia il colore del FG da bianco a grigio medio, metti come filtro anti alias un lanczos 1/4 - 16.

Parti creando un set fotografico, posizionare luci (con ombre attive e impostate come ray traced shadow) e camere, applica a tutti gli oggetti un materiale neutro grigio chiaro con poca riflessione e poco glossy, poi fai prove di render.

Trovato le luci giuste applica i materiali, magari parti dai preset che ci sono in un arch e design standard (tipo il vetro), sono buone basi, ma poi sta a te variare leggermente i parametri per ottenere il meglio.

Ciao

Luca

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao, che cosa intendi?

Comunque grazie per le risposte.

che forse dovresti applicare un modificatore UVW map al "tavolo" o lavorare sui parametri(ad esempio il TILE) della bitmap caricata nel canale DIFFUSE del materiale...

questo per far si che si possano,ad esempio, vedere più nitidamente le venature evitando quel senso di "appannamento" e "spixellamento" della texture

non so se mi sono spiegato bene e scusate se mi sono intromesso(in primis a DiegoPennati)

bye

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sinceramente l'unico consiglio che posso darti è: studia.

Riparti dalle basi, segui tutorial con un certo metodo.

Da quel che ho visto in giro con mental ray si creano delle immagini da paura, praticamente uguali alla realtà. Perché il materiale legno del piano sottostante è venuto così male?

Questo è un modo assolutamente sbagliato di porsi nei confronti del programma. Il 90% della resa finale la fa chi usa il software, non esiste il bottoncino magico "make like real" e a risultati fotorealistici ci si arriva dopo parecchio tempo di studio.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

che forse dovresti applicare un modificatore UVW map al "tavolo" o lavorare sui parametri(ad esempio il TILE) della bitmap caricata nel canale DIFFUSE del materiale...

questo per far si che si possano,ad esempio, vedere più nitidamente le venature evitando quel senso di "appannamento" e "spixellamento" della texture

non so se mi sono spiegato bene e scusate se mi sono intromesso(in primis a DiegoPennati)

bye

non preoccuparti, è quello che intendevo io!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Salve a tutti,

ho bisogno di un aiuto/consiglio. Sto utilizzando per la prima volta la modellazione con t-splines in Rhino 4. Tutto ok, se non fosse che quando renderizzo con V-Ray, noto subito un problema non indifferente: in pratica tutte le forme in tsplines risultano come delle sfere, che queste siano solidi primitivi o forme con geometrie più complesse! Probabilmente salto dei parametri nelle varie opzioni dei plugin o qualcos'altro di simile?

Con la modellazione delle Nurbs e le sue renderizzazioni in Vray, non ho mai avuto problemi. Invece ora mi si presenta questo grosso rompicapo.

Purtroppo devo passare assolutamente da T-splines, poichè sto modellando dei cuscini per divano!

Fatemi sapere, aiutatemi!

Vi ringrazio

Steg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Salve a tutti,

ho bisogno di un aiuto/consiglio. Sto utilizzando per la prima volta la modellazione con t-splines in Rhino 4. Tutto ok, se non fosse che quando renderizzo con V-Ray, noto subito un problema non indifferente: in pratica tutte le forme in tsplines risultano come delle sfere, che queste siano solidi primitivi o forme con geometrie più complesse! Probabilmente salto dei parametri nelle varie opzioni dei plugin o qualcos'altro di simile?

Con la modellazione delle Nurbs e le sue renderizzazioni in Vray, non ho mai avuto problemi. Invece ora mi si presenta questo grosso rompicapo.

Purtroppo devo passare assolutamente da T-splines, poichè sto modellando dei cuscini per divano!

Fatemi sapere, aiutatemi!

Vi ringrazio

Steg

Non so aiutarti con Rhino.

Ma algo ha ragione, inoltre perchè spammi i tuoi problemi in discussioni che non centrano assolutamente nulla??

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×