Vai al contenuto
giofrida

Differenza Booleana fallita e semplificazione polisuperficie

Recommended Posts

Salve a tutti!

Inizialmente ho realizzato una polisuperficie un po' complessa, perché ho sottratto (con la differenza booleana) molte parti, creando così moltissimi bordi.

Ora, che devo fare una differenza booleana, non posso, proprio a causa della complessità della polisuperficie (suppongo). Il risultato, quando tento di farla è "Differenza booleana fallita.".

Quindi pensavo di semplificare la polisuperficie unendo i bordi delle superfici (facendo esplodere la polisuperficie) ma non trovo lo strumento adeguato.

Spero di essere stato chiaro sul mio problema.

Grazie in anticipo,

giofrida

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

un immagine esplicativa?

in genere la differenza booleana,va a farsi benedire se le sup hanno i bordi che coincidono

hai già visto tra i dettagli della tua sup.(intendo nelle proprietà della sup.) se è correttamente chiusa?

Cmq,prova ad esploderla \unirla e ritenta la differenza boolena

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ecco qui:

350tl3m.png

E' la parte superiore del notebook HP 6720s. Come puoi vedere ci sono molti "bordi" nella polisuperficie.

Ho visto nei dettagli della polisuperficie e la segna come valida e chiusa.

Ho inoltre provato ad esplodere e riunire (con unione booleana, unisci e crea solido) ma la situazione non cambia.


Modificato da giofrida

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Mi sembra di vedere che i due spigoli sono diversi tra loro.

In uno si nota un piano perpendicolare e nell'altro un piano obliquo che si unisce ad un'altra parte dell'oggetto.

Non è un oggetto complicato quindi la booleana non funziona o perchè ci sono lati, spigoli o superfici in comune (come dice Ages) oppure perchè il solido non è chiuso oppure, e questo credo sia il tuo caso, ci sono superfici anomale create da linee non ricostruite.

Prova ad esplodere, poi a rigenerare entro la tolleranza ed a ricostruire. Se, dopo che hai unito nuovamente tutte e superfici ti ridà solido chiuso e sono spariti quei piani anomali non ti fa ancora la booleana dovrai intervenire sulle linee che hanno generato il solido o parti di esso.

Spero di aver indovinato il rimedio. Metti un'alta immagine con angolatura differente


Modificato da GUESTOLDO

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ho risolto il problema utilizzando il comando "_Split" (o Suddividi) invece della classica differenza Booleana.

Grazie a tutti lo stesso per le risposte.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×