Vai al contenuto
Foscone

Luce che cala nell'animazione

Recommended Posts

Ciao a tutti, ho cercato in giro ma non ho trovato la soluzione al mio problema quindi chiedo:

sono alle prime armi con 3d studio e sto cercando di creare delle piccole animazioni, ho provato a muovere degli oggetti e tenere fissa la camera ed anche il contrario.

In entrambi i casi la luce vray che ho utilizzato dopo qualche fotogramma inizia a calare di intensità ed alla fine tutta la scena è nera.

Mi sapete dire dove sto sbagliando?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

algosuk nel senso che non devo usare le luci vray per le animazioni?

Le uso normalmente per le immagini statiche e non mi ha mai dato problemi.

Fabio, non credo che sia quello. Nell'animazione dove l'oggetto si sposta ce ne sono tanti che cadono "a pioggia" quindi se uno non è più illuminato dovrei vederne un altro illuminato invece non è così. Nel caso dell'oggetto fisso all'inizio si vede tutto bene e dopo diventa scuro ma la camera semplicemente si alza quindi a rigor di logica l'oggetto dovrebbe essere illuminato sempre allo stesso modo

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

bo, senza vedere niente è difficile capire. Facci uno screenshot della scena nella fase intermedia luce / non luce se ti va.Mi viene solo a mente che potresti aver x sbaglio animato il valore dell' intensità della luce (ma è una possibilità veramente remota) o che invece della luce che sparisce sia il riflesso della stessa che sparisce una volta che hai cambiato il punto di vista della camera, facendo riflettere il nero dell' universo.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ecco qui, ho provato con una luce standard omnidirezionale:

faccio partire il render dicendo di fare i primi 50 fotogrammi, questo è il primo image.png

questo sarà il terzo fotogramma image.png

invece questo è un fotogramma qualsiasi a metà animazione preso però con il single frame e senza dirgli di salvare prima di mandare il render image.png

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Pare che con materiale standard, luce standard e mental ray non mi faccia questo problema.

Se non fosse una cosa impossibile però mi piacerebbe capire come mai con vray me lo fa. Lo so che mi mancano le basi ma conosco un po vray e per niente mental ray e quindi mi piacerebbe poter fare questa animazione usando vray

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Non mi viene a mente niente al momento, mi dispiace, non so capire come mai ti faccia cosi. Sai che potresti provare? A mettere dietro alle palline un piano grosso o una box, qualcosa di grosso, che ti faccia capire cosa succede alla luce durante l' animazione. Magari vedi che la luce si sposta o simile.

Fab

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ho messo il piano. Mi sembra che la luce sul piano sia sempre uguale.

Primo fotogramma image.png

Secondo:image.pngQuarto: image.png

E la cosa che proprio non capisco è come mai il quarto fotogramma se lo renderizzo singolarmente mi viene abbastanza più chiaro (è così con tutti i fotogrammi perchè ho fatto varie prove): 4sing.png

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ok, non è che per caso le palle che cadono un po' random, iniziano cadendo + vicine al plane e poi continuano cadendo invece + verso di noi non rientrando + nel raggio di azione della luce? Ormai devi anche mostrare come hai piazzato la luce vray mi sa :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ok, non è che per caso le palle che cadono un po' random, iniziano cadendo + vicine al plane e poi continuano cadendo invece + verso di noi non rientrando + nel raggio di azione della luce? Ormai devi anche mostrare come hai piazzato la luce vray mi sa :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sicuramente ci saranno altre palle che fanno ombra su quelle che si vedono ma quello che non mi spiego è come mai cambia la luce dello stesso fotogramma a seconda che gli dica di renderizzare un range di fotogrammi o un single frame (come si vede negli ultimi due screenshot che ho postato prima).

In teoria la luce dovrebbe coprire tutte le palle, comunque ecco gli screenshot del primo e del quarto fotogramma:

image.png

image.png

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Niente, non so proprio capirne il motivo. Fossi io nella tua situazione proverei a spostare la luce. Magari metterla + di lato, o piu in alto in modo che le palle non la attraversino. Non so che altro dirti, mi dispiace.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Adesso faccio una serie di prove e poi vi faccio sapere, sto riprovando con l'altra scena in cui l'oggetto è fisso. Appena ho notizie scrivo, intanto grazie mille!!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sto provando l'altra scena, ero arrivato al trentottesimo fotogramma ed ho interrotto (tanto sono tutti singoli frame (formato .rla) posso ripartire dal 39). Sono ripartito dal 39 senza modificare neanche una virgola ne nelle opzioni ne nella scena ed ecco il risultato (si vede perfettamente il fotogramma 38 scuro ed il 39 chiaro):

sdf.jpg

è assurdo cavolo! non ho cambiato nulla!!!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

La GI è spenta? Non dovrebbe incastrarci niente ma visto che non si capisce che pesci prendere vale la pena di provare. Io la disattiverei per assicurarmi che funzioni solo la luce diretta.

Poi, come ti dicevo prima, proverei a cambiare posizione alla luce. Quando hai voglia prova a metterla frontale anziché dall' alto.

In bocca al lupo !

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

La GI l'ho spenta in partenza per velocizzare i render.

Mi sa che farò varie prove a tempo perso altrimenti non combino più niente nella vita :P

Grazie di nuovo, se riesco a risolvere mi faccio sentire.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×