Vai al contenuto
bomboclat

errore rendering

Recommended Posts

Inviata (modificato)

ciao a tutti!

ho un problema... non riesco a renderizzare!!! (3dSM+Vray)

non so cosa controllare...nè da cosa dipenda...

eppure fino a qualche tempo fa', seguendo lo stesso identico iter, avevo risultati..!

ora niente, appena clicco su render, se va bene inizia a processare qualche buffer poi crasha..dandomi la possibilità di salvare il file di backup (cosa che faccio sempre a priori, prima di cliccare su render, comunque :))

altrimenti, direttamente, si chiude e ciao chi s'è visto s'è visto...spesso senza neanche mostrare messaggi....

che consigli avete per un novellino spaesato e intristito (oltre che con l'acqua alla gola per un lavoro XD)??

guidatemi vi prego, sotto richiesta posso darvi qualsiasi info più precisa, ora come ora da solo non so neanche dove andare a controllare XD


Modificato da bomboclat

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Strano questo crash improvviso...

Io che uso MR, mi succedeva con i proxy, ne avevo alcuni corrotti che in viewport non davano problemi, ma al momento di renderizzare creavano un errore...

Prova a togliere tutti i proxy (se ne hai).

Ciao

Luca

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

puoi provare cosi

apri un nuovo file

file-merge e selezioni il file che non funziona

selezioni metà degli elementi

provi a fare un render

se non funziona selezioni la metà di quelli di prima e provi a fare un render...cosi di seguito fino a quando non trovi l'elemento che crea problemi


Modificato da asalalp

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ciao ragazzi, grazie per l'interessamento!

non credo sia dovuto a un proxy zio..semplicemente perchè non l'ho usato in questa scena :)

appena ho tempo (w il week end :)) proverò il metodo asalalp, andiamo a caccia del baco maledetto :)

intanto se eventuali nuovi lettori hanno idee sono i benvenuti ovviamente, anzi facciamo così, vi metto una pulce nell'orecchio (anzi un paio):

-se pensassi che tutto ciò sia dovuto a un materiale probabilmente corrotto o non compatibile, come potrei verificare? è sufficiente spegnere il relativo layer o contrassegnare l'icona "non renderizzare questo"? o va proprio tolto dalla scena, andando sempre a tentativi come per il metodo asalalp?

-esiste un modo per monitorare in tempo reale (o creare file di log, magari da postarvi, per ragionarci su!) delle prestazioni del pc (notebook) o della scheda video, o della ram, ecc? a sto punto mi viene il dubbio che semplicemente il tutto sia troppo pesante per la mia macchina (anche se..occhio e croce non sembra troppo plausibile come cosa! insomma non è proprio un netbook 12" da 2 euro (con tutto il rispetto), nè sto modellando notre dame :) credo di essere nei limiti della decenza in quanto a "richiesta prestazionale")

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ciao ragazzi, grazie per l'interessamento!

non credo sia dovuto a un proxy zio..semplicemente perchè non l'ho usato in questa scena :)

appena ho tempo (w il week end :)) proverò il metodo asalalp, andiamo a caccia del baco maledetto :)

intanto se eventuali nuovi lettori hanno idee sono i benvenuti ovviamente, anzi facciamo così, vi metto una pulce nell'orecchio (anzi un paio):

-se pensassi che tutto ciò sia dovuto a un materiale probabilmente corrotto o non compatibile, come potrei verificare? è sufficiente spegnere il relativo layer o contrassegnare l'icona "non renderizzare questo"? o va proprio tolto dalla scena, andando sempre a tentativi come per il metodo asalalp?

-esiste un modo per monitorare in tempo reale (o creare file di log, magari da postarvi, per ragionarci su!) delle prestazioni del pc (notebook) o della scheda video, o della ram, ecc? a sto punto mi viene il dubbio che semplicemente il tutto sia troppo pesante per la mia macchina (anche se..occhio e croce non sembra troppo plausibile come cosa! insomma non è proprio un netbook 12" da 2 euro (con tutto il rispetto), nè sto modellando notre dame :) credo di essere nei limiti della decenza in quanto a "richiesta prestazionale")

Beh, partirei proprio da qui: ci servono almeno queste informazioni: Processore, quantità di Ram, Quantità memoria disco fisso libera, Scheda Video con relativa memoria, Sistema operativo attualmente in funzione, versioni dei software in oggetto, e processi attivi (programmini, app antivirus ecc...attivi in background durante l'attività normale del PC). A volte ci sono piccoli programmini apparentemente tranquilli al momento giusto si fanno sentire...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Lo fa solo con un determinato file o con tutti? Se lo fa con tutti, controlla la temperatura del processore quando crasha, per un po' ho avuto questo problema.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

dati tecnici:

notebook HP Pavillon dv9700

intel core duo t9300 2.5 gHz

RAM 4gb sfruttati solo 3gb da winzozz vista home premium 32bit (nonsense :angry: )

ha 2 hdd da 250Gb, di cui uno dedicato a linux, quindi praticamente winzozz usa solo 250 gb di cui una 50 liberi (80% pieno insomma)

3dsmax 2012 32bit(student version) + vray 2.10.01

per quanto riguarda backround ho disattivato tutti i programmi inutili (skype msn ecc) tenendo attivo solo antivirus avast e winzozz firewall oltre che processi di sistema vari (insomma, da gestione attività faccio "termina processo" a tutti i "nomi noti" che non mi servono al momento del render)

per quanto riguarda la scheda video:

geforce 8600M GS, processi sequenziali 16, clock core 600Mhz, clock shader 1200MHz, clock memoria 700MHz, memoria massima 1Gb condivisa (di cui 512 dedicata), interfaccia memoria 128bit

---

lo fa solo con questo file (non ho avuto tempo di provare con altri, ma in passato non me l'ha mai fatto), per quanto riguarda la temperatura, mi pare nella norma (a tatto, non ho misurato, ma insomma quelle due o tre volte che ho giocato a need for speed dopo non potevo usare la tastiera per due giorni e non crashava XD)

(mi scuso per il ritardo ma ho avuto un week end un po' complesso...)


Modificato da bomboclat

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

FAIL...mi vergogno un po'....ma DEVO chiedervelo :)

qual'è l'operazione inversa ad "assign material to selected object"?

volevo fare le prove consigliate sopra, cioè provare a renderizzare con metà materiali, poi con l'altra metà, e andare a renderizzare finchè si capisce-eventualmente-se c'è un materiale che crea conflitto...

in passato mi è capitato solo di "sostituire" un materiale ad un materiale già applicato, e mi bastava cancellare uvw map, assegnare nuovo materiale e creare nuova mappatura

ma se per esempio ho un "box" a cui ho applicato "mattoni", per togliere mattoni dalla scena che devo fà? basta cancellare la relativa mappa o ci sono altre operazioni? graziee

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

dati tecnici:

notebook HP Pavillon dv9700

intel core duo t9300 2.5 gHz

RAM 4gb sfruttati solo 3gb da winzozz vista home premium 32bit (nonsense :angry: )

ha 2 hdd da 250Gb, di cui uno dedicato a linux, quindi praticamente winzozz usa solo 250 gb di cui una 50 liberi (80% pieno insomma)

3dsmax 2012 32bit(student version) + vray 2.10.01

per quanto riguarda backround ho disattivato tutti i programmi inutili (skype msn ecc) tenendo attivo solo antivirus avast e winzozz firewall oltre che processi di sistema vari (insomma, da gestione attività faccio "termina processo" a tutti i "nomi noti" che non mi servono al momento del render)

per quanto riguarda la scheda video:

geforce 8600M GS, processi sequenziali 16, clock core 600Mhz, clock shader 1200MHz, clock memoria 700MHz, memoria massima 1Gb condivisa (di cui 512 dedicata), interfaccia memoria 128bit

---

lo fa solo con questo file (non ho avuto tempo di provare con altri, ma in passato non me l'ha mai fatto), per quanto riguarda la temperatura, mi pare nella norma (a tatto, non ho misurato, ma insomma quelle due o tre volte che ho giocato a need for speed dopo non potevo usare la tastiera per due giorni e non crashava XD)

(mi scuso per il ritardo ma ho avuto un week end un po' complesso...)

Come ti hanno suggerito, il file contiene quache cosa di corrotto, oppure la scena è troppo complessa per l'hardware, a volte ci si aspetta che vada solo più lento e invece crasha. Ti conviene aprire la scena originale, e selezionare priccoli gruppi di oggetti e fare "save selected" creando così una serie di files, in pratica spezzetti la scena su più file. Dividila secondo dei criteri, tipo arredamento o vegetazione gli salvi da soli. Poi salvi le strutture principali, poi le secondarie. Per ciascuna scena imposti i parametri di rendering e fai delle prove per i singoli gruppi. Mano a mano che trovi gruppi di oggetti che vengono renderizzati fai l merge in una scena vergine. Sostanzialmete fai una sorta di debug della scena fino a trovare l'errore che sarà sicuramente legato a qualche oggetto o relativo materiale.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

FAIL...mi vergogno un po'....ma DEVO chiedervelo :)

qual'è l'operazione inversa ad "assign material to selected object"?

volevo fare le prove consigliate sopra, cioè provare a renderizzare con metà materiali, poi con l'altra metà, e andare a renderizzare finchè si capisce-eventualmente-se c'è un materiale che crea conflitto...

in passato mi è capitato solo di "sostituire" un materiale ad un materiale già applicato, e mi bastava cancellare uvw map, assegnare nuovo materiale e creare nuova mappatura

ma se per esempio ho un "box" a cui ho applicato "mattoni", per togliere mattoni dalla scena che devo fà? basta cancellare la relativa mappa o ci sono altre operazioni? graziee

Non ho capito bene cosa intendi, comunque se non erro vuoi catturare un materiale da un oggetto per averlo nel material editor? Basta che usi il contagocce presente nel material editor e tocchi l'oggetto che ti interessa, e il suo materiale apparirà nell'editor dei materiali nella cella corrente.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grazie per la spiegazione dettagliata del procedimento, illuminante, proverò a fare così!

per quanto riguarda questo

Non ho capito bene cosa intendi, comunque se non erro vuoi catturare un materiale da un oggetto per averlo nel material editor? Basta che usi il contagocce presente nel material editor e tocchi l'oggetto che ti interessa, e il suo materiale apparirà nell'editor dei materiali nella cella corrente.

intendevo semplicemente togliere l'assegnazione di un materiale ai relativi oggetti nella scena, per farli tornare semplici oggetti tridimensionali, come appena creati

nel senso che prima di immergermi in mille lunghe prove, vorrei provare a togliere un paio di materiali sia dallo slate material che dai relativi oggetti a cui li avevo assegnati, dato che ho sospetti su due file .mat specifici

(se li rimuovo solo dallo slate material editor, permangono sugli oggetti in scena a cui li avevo assegnati in precedenza)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grazie per la spiegazione dettagliata del procedimento, illuminante, proverò a fare così!

per quanto riguarda questo

intendevo semplicemente togliere l'assegnazione di un materiale ai relativi oggetti nella scena, per farli tornare semplici oggetti tridimensionali, come appena creati

nel senso che prima di immergermi in mille lunghe prove, vorrei provare a togliere un paio di materiali sia dallo slate material che dai relativi oggetti a cui li avevo assegnati, dato che ho sospetti su due file .mat specifici

(se li rimuovo solo dallo slate material editor, permangono sugli oggetti in scena a cui li avevo assegnati in precedenza)

Di solito risolvo assegnando a tutti gli oggetti sospetti o che voglio resettare, il materiale standard di 3ds max o un nuovo Arc&Design Matte se uso mental Ray, o una materiale base di Vray lasciando i parametri di base. Infine cancello con X dalla Slate materiale i materiali.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grande, il pc che ho io!!!

In effetti è un peccato che su un pc del genere non puoi montare 8 gb di ram!!!

come portatile va bene, ma io ho messo win 7 64 bit e ho sostituito i 2 hdd con un ssd per il s.o. e un 500gb partizionato per i dati (irriconoscibile dopo questo mood).

La versione a 32 bit è molto limitata, controlla nel task manager se vai fuori ram quando lanci il render.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Il problema è proprio qui:

RAM 4gb sfruttati solo 3gb da winzozz vista home premium 32bit (nonsense :angry: )

4 gb di ram sono veramente pochi, prova ad aumentare la memory dinamic, nei settaggi di vray per sfruttare maggiormente la ram.

Però la vedo dura, se ti crascia è perchè sei limitato col 32 bit ho avuto lo stesso problema quando avevo win 7 64bit e 3dsmax a 32 bit, alzando la risoluzione mi facevo il tuo identico scherzetto, si chiudeva all'inizio del render...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×