Vai al contenuto
vlccl

problema render con mental ray: aree bianche su materiale raytrace

Recommended Posts

Ciao a tutti,

come spiegato nel titolo, il mio problema consiste nella comparsa di aree bianche nei render degli oggetti sui quali ho applicato materiali riflettenti raytrace.

E' una cosa che mi è capitata sia in scene illuminate col sistema daylight, che in altre illuminate con le fotometriche.

Il render pare comporsi correttamente, quando verso la fine compaiono queste patacche tinta unita. Come specular, solo molto più nitide.

Qualcuno sa aiutarmi?

Grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ci sono delle restrizioni nell'utilizzo di mappe e materiali raytrace con mental ray (la guida in linea è molto chiara).

Probabilmente ti scontri con una di queste restrizioni.

Prova a convertire i materiali riflettenti in arch & design

PS

cambio sezione al thread

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Magari posta un'immagine ed i settaggi di mr e delle luci.

Grazie

Luca

Intanto grazie a te!

Allora, ecco l'immagine.

In questo caso ci sono dei rettangolini bianchi e blu piuttosto piccoli, in cima e alla base della lattina.

mr:

mr photographic exp control

preset physically based lighting, indoor daylight

exposure value 5,5

ho attivato il final gather (fg precision su medium) e impostato 2 su diffuse bounces

la gi disattivata

sampling quality minimum:1 maximum:16 e filter mitchell

le fotometriche sono 2 target light ai lati, una di fronte all'altra

shadows on, ray traced shadows uniform spherical

emit light from shape: rectangle

questi i parametri che ho toccato

post-82478-0-73960000-1339424461_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Primo passo da fare è, come dice philix, convertire i materiali in arch&design.

Poi attiva la GI a valori di default moltiplicati x10 e poi metti la spunta su tutti gli oggetti generano e ricevono GI e caustic.

Vedi se così va meglio

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Primo passo da fare è, come dice philix, convertire i materiali in arch&design.

Poi attiva la GI a valori di default moltiplicati x10 e poi metti la spunta su tutti gli oggetti generano e ricevono GI e caustic.

Vedi se così va meglio

mm.. ho attivato la gi e moltiplicato, ora però mi da questi errori: a ray encountered an invalid color (nan), using black instead

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

si!

ora sto smanettando con i paramentri GI, e l'errore non compare più.. non noto grandi differenze rispetto a i render con gi disattivata, però.

Io sono un principiante.. La gi dovrebbe dare una prima "mano" di luce, giusto? un "fondo"?

Ad ogni modo grazie dei consigli, non abuso della disponibilità, ora è il caso che ci metta del mio ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×