Jump to content
roberto2004

consumare meno ram mental ray

Recommended Posts

salve a tutti.avrei due domandine da principiantissimo...stò facendo un render e credo che il mio pc abbia swappato in quanto son 3 giorni che che rendera e stà ancora al 30%...

le domande son queste:

come faccio a sapere se ha effettivamente swappato?

c'è un modo in mental per consumare meno ram anche a discapito dei tempi di render?mi hanno consigliato di diminuire la grandezza dei bucket ma non sembra funzionare..

il tutto mi suona cmq strano perchè di solito se non gli basta la ram và in crash...bò...

saluti a tutti.

Share this post


Link to post
Share on other sites

Swappa eccome, basta che controlli la cartella tmp di 3DS max durante il rendering. Io ho predisposto un partizione dedicata allo swap con dischi SAS da 10.000 rpm e controller dei dischi e processore risk dedicato. Comunque pur avendo 24 GB di Ram, ho notato che swappa lo stesso su disco lasciando libera parecchia ram. Questo dimostra che conviene ottimizzare il settore dischi e controller. Diventa lentissimo quando lo spazio libero su disco è ridotto a pochi GB.

Share this post


Link to post
Share on other sites

Sinceramente io che ho 32gb di ram, lanciando dei render grossi in mental (5000x3750), mi andava ad occupare 30gb durante l'elaborazione ma il disco non swappava per niente!

Secondo me è meglio che roberto2004 ci dica la configurazione del suo pc e i settaggi di mental ray sopratutto per quello che riguarda il displace e la gi.

Il consiglio che posso darti adesso, ignorando la configurazione del pc, è di precalcolare la gi a risoluzione più bassa, poi lanciare il render.

Spero di esserti stato di aiuto!

Ciao

Luca

Share this post


Link to post
Share on other sites

leggo per caso e mi accorgo di essere un ignorante totale...

cosa vuol dire che "swappa"? è una cosa grave (in termini di resa del computer) o è "qualcosa" che può succedere ma è meglio se non avviene?

chi mi aiuta a capirci di più?

Share this post


Link to post
Share on other sites

non posso ancora dirlo con certezza, ma credo che il problema fosse il filtro..era l'unico parametro diverso dal solito che avevo introdotto..solitamente uso gauss..anche con i sample elevati me la cavo con 20-25ore al max (intel q6600)...stavolta dopo 5 giorni ero ancora la 40%(avevo impostato mitchel).ora ho annullato e riavviato il render con gauss e sembra vada meglio...grazie a tutti.

Share this post


Link to post
Share on other sites

Sinceramente io che ho 32gb di ram, lanciando dei render grossi in mental (5000x3750), mi andava ad occupare 30gb durante l'elaborazione ma il disco non swappava per niente!

Secondo me è meglio che roberto2004 ci dica la configurazione del suo pc e i settaggi di mental ray sopratutto per quello che riguarda il displace e la gi.

Il consiglio che posso darti adesso, ignorando la configurazione del pc, è di precalcolare la gi a risoluzione più bassa, poi lanciare il render.

Spero di esserti stato di aiuto!

Ciao

Luca

guarda, aspetto domani e controllo con gauss come se la cava..se non dovesse andare posto i settaggi.ciao

Share this post


Link to post
Share on other sites

Ciao robi, ma per vedere se ti swappa usa l'avvio gestione attività e vedi se la cpu lavora al 100%.

Ho notato che con vray non è proprio proprio così in quanto anche se si visualizza il grafico cpu al 100% di fatto non lo proprio costantemente nel tempo e quindi leggermente swappa, ma questa è solo una peculariatà.

altrimenti vedi che ti salta dal 25/30% ai 60/70/8090/% e ti ritorna giu di brutto.

Povero pc, stai attento che non è abituato a tutto questo, lo fai esaurireeeeeee.

anzi forse, mi sa che esaurisci prima tu!!!!!!!!!!!!!

:TeapotBlinkRed: :TeapotBlinkRed: :TeapotBlinkRed: :TeapotBlinkRed: :TeapotBlinkRed: :TeapotBlinkRed: :TeapotBlinkRed: :TeapotBlinkRed:

Share this post


Link to post
Share on other sites

ho controllato la cartella dei file temp e sembra che ora non stia swappando mentre ieri, col filtro mitchell, sì.

solo che ora ha finito il calcolo del final gater ma è fermo al 100% e non và oltre...bo..mi sà che stò giro mi tocca mollare il mio preistorico pc...

x la cronaca la gi è disattiva.

Share this post


Link to post
Share on other sites

ho controllato la cartella dei file temp e sembra che ora non stia swappando mentre ieri, col filtro mitchell, sì.

solo che ora ha finito il calcolo del final gater ma è fermo al 100% e non và oltre...bo..mi sà che stò giro mi tocca mollare il mio preistorico pc...

x la cronaca la gi è disattiva.

Io penso che il filtro Mitchel non sia del tutto responsabile del problema, mentre più probabilmente il responsabile è il suo vicino [sample per pixel] che secondo me hai alzato troppo per le possibilità del tuo hardware. Potresti indicare gentilmente che valori di minimum e maximun hai usato? Perchè è vero che più alti sono, più precisa e dettagliata sarà l'immagine, ma bisogna valutare se i valori messi sono adeguati per la risoluzione di output (anche questo dato ci sarebbe molto utile). Inoltre anche il numero totale di sorgenti luminose nella scena.

P.S. in effetti stiamo parlando di aria fritta, sarebbe utile uno screen shot della scena + risoluzione del rendering, impostazioni del final gather (numero rimbalzi e raggi ecc..) G.I.:si/no, caustiche: si/no + i parametri suddetti. Quando abbiamo un quadro completo possiamo vedere se si può limare e ottimizzare il tutto per arrivare un risultato. ciao


Edited by Salz

Share this post


Link to post
Share on other sites

allora...si, il motore è mental

dunque, credo che salz abbia ragione su mitchel, nel senso che la colpa non è tutta sua...togliendolo il render si velocizza un poco ma resta cmq impantanato.

attuamente staà renderizzando(ho dimezzato la risoluzione)

riporto (a memoria)alcuni valori che ho usato

samples 4-64

rays x fg point 300

diffuse bounce 2

in scena c'è la day light,ci sono due mental ray sky portal che però sono divenuti inutili visto che ho disattivato la gi.

i poligoni sono circa due milioni, ma ho anche dei proxy quindi non lo sò di preciso.

cmq se stanotte riesce a finere posto(sempre in questo trehad)sia l'immagine che i settaggi corretti..x ora ringrazio tutti dell'aiuto.

l'iunica precisazione che mi sento di fare riguardo i settaggi è che sono gli stessi che uso di solito nelle scene d'interno e che non mi hanno mai dato problemi..le sole variabili sono mitchel al posto di gauss,la risoluzione più alta e i render elements.

Share this post


Link to post
Share on other sites

allora...si, il motore è mental

dunque, credo che salz abbia ragione su mitchel, nel senso che la colpa non è tutta sua...togliendolo il render si velocizza un poco ma resta cmq impantanato.

attuamente staà renderizzando(ho dimezzato la risoluzione)

riporto (a memoria)alcuni valori che ho usato

samples 4-64

rays x fg point 300

diffuse bounce 2

in scena c'è la day light,ci sono due mental ray sky portal che però sono divenuti inutili visto che ho disattivato la gi.

i poligoni sono circa due milioni, ma ho anche dei proxy quindi non lo sò di preciso.

cmq se stanotte riesce a finere posto(sempre in questo trehad)sia l'immagine che i settaggi corretti..x ora ringrazio tutti dell'aiuto.

l'iunica precisazione che mi sento di fare riguardo i settaggi è che sono gli stessi che uso di solito nelle scene d'interno e che non mi hanno mai dato problemi..le sole variabili sono mitchel al posto di gauss,la risoluzione più alta e i render elements.

Grazie, ora abbiamo qualche elemento in più, manca ancora la risoluzione, comunque inizierei a portare i sample max da 64 a 4 e i sample min da 4 a 1 per poi rialzarli a 16-4. Così vedrai che la inizia a essere ragionevole. Se stai facendo un interno, diffuse bounce = 2 è veramente troppo basso, per gli esterni in genere si usa 6-7, in interno metterei 8-10. Rays x fg point=300 dipende, bisgna valutare la scena, diciamo che corrisponde a una via di mezzo tra medium e high del preset. Il filtro Mitchel non toglierlo, lascialo per il momento impostato a 4x4, Vedrai che abbassando i sample x pixel andrà meglio. Purtroppo è difficile che i settaggi usati per un interno funzinino per tutte le scene possibili, dipende da molte variabili che vanno ottimizzate ad hoc. Forse per questa scena hai un numero di poligoni, dimensioni e complessità di geometrie, riflessioni, oggetti metallici o trasparenti che solitamente non avevi. La luce non dovrebbe essere un problema visto che è una e le portal sono disabilitate. Sarebbe da verificare anche il parametro che regola le soft shadow in global tuning.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...