Vai al contenuto
R3D

Vray errori di render con oggetti non "Visible to cam"....

Recommended Posts

Inviata (modificato)

Ciao a tutti, ho cercato ma non trovo molto se non nulla a proposito.

Dunque stiamo parlando di 3DS-Max 2010 + Vray 2.020 o giù di li.

Sto facendo degli interni dove per motivi di spazio, sono costretto a rendere invisibili alla camera alcue pareti e porte per poter inquadrare qualcosa.

Il problema è che gli oggetti non visibili alla camera....in realtà si vedono....nel senso, si vede appena appena delle righe in corrispondenza dell'effettiva geometria nascosta...un pò come se applicassi agli oggetti nascosti il "toons" in un canale trasparente al 90%, in caso di oggetti con una geometria complessa....questi alla fine sporcano il render.

E' un pò che provo, ma ancora non ho trovato soluzione.

Non ho provato, ma secondo me utilizzando la camera standard di Max, la cosa non succede.....comunque è fuori discussione, la scena è tarata per la Physical cam di Vray.

Spero che qualcuno di voi abbia capito il mio problema e soprattutto abbia dei suggerimenti in proposito.....

grazie mille!!!

R3D


Modificato da R3D

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

si che l'avrei....ma non me la fa postare....

No niente....non so con cosa postare le immagini....ogni volta qui cambiano le regole!!!

Con cosa uploadate adesso?

Fino ad 1 mese fa usavo Imageshack .... ora non è permesso!!

EDIT:

visiblecam.jpg

Se si guarda bene a SX dell'immagine si intravvede la geometria della parete nascosta alla camera.

Questo effetto lo fa con tutte le geometrie nascoste alla camera e non so come fare!!!!


Modificato da R3D

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

chi non te la fa postare?

puoi riprovare per favore? perché prima c'era un problema sul server ...

Ciao Dave...non volevo accusare nessuno scusa per il tono....hai ragione come vedi ci sono riuscito un attimino prima del tuo intervento!

Grazie comunque!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

prego :)

PS: tu hai un account premium quindi non ti serve fare l'upload su server esterni ... puoi usare l'uploader interno di treddi :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao r3d,

io te la butto li:

se le pareti sono edipolyaltrimenti le fai diventare, ti suddividi la parete che devi spegnere quanto basta, usi la selection POLIGON, quando hai selezionato ciò che vuoi spegnere sempre in editpoly fai HIDE SELECTION. ho sfornato render in questo modo col tuo stesso problema proprio qualche giorno fa.

Se hai problemi o non ti è chiaro fammi sapere.

Ciao Carlo

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Dimenticavo,

Occhio a ciò a hai davanti,se è riflettente hai dei problemi e se spegnendo quelle porzioni di parete ti trovi in altro ambiente con illuminazione diversa, devi creare uno scatolotto di contenimento per la cinepresa in modo da non essere influenzata da nulla. Io la chiamo parete di scena, ma non so se è un termine corretto, cmq per me lo è.

;) ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

uhm...si ho capito chiaramente....però ci sono novità in merito.

Credo che sia un vero Bug di Vray....

ora provo a fartelo fare sul campo.

nel renderer menu di vray in global switches sotto geometry, metti la spunta a force back face culling...in questo modo si dovrebbe ovviare al problema per cui ho aperto questo 3D.

Infatti facendo un render le geometrie nascoste alla camera, non creano più quel fastidioso problema, ma............attenzione che il bug di Vray è in agguato.....non pensando al problema del thread per un attimo, crea una teiera, duplicala istanziandola ed esegui un mirror in quella nuova, a questo punto sempre con la spunta in back face culling, esegui un render....e bene...in render la teiera mirrorata, viene con le normali rovesciate!!!

L'unica è flippare nuovamente la geometria, aggiungendo un modificaore "normal".....la conseguenza sarà che su editor, avremo la visualizzazione "giusta" e cioè, una teiera colorata ed una nera, perchè con le normali girate....ma il render in realtà, con il normal ora viene bene.....

Non so se mi sono capito...(mi gira la testa....) però in parole povere ho risolto un problema, ma ne ho creato un altro!!!

Qualcuno sa se sto sbagliando io qualcosa o è veramente un bug di Vray?

Ciao.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao r3d,

io te la butto li:

se le pareti sono edipolyaltrimenti le fai diventare, ti suddividi la parete che devi spegnere quanto basta, usi la selection POLIGON, quando hai selezionato ciò che vuoi spegnere sempre in editpoly fai HIDE SELECTION. ho sfornato render in questo modo col tuo stesso problema proprio qualche giorno fa.

Se hai problemi o non ti è chiaro fammi sapere.

Ciao Carlo

Se fai così però elimini l'oggetto dalla scena... il Visible To Camera invece serve a mantenere l'oggetto (molto importante per i muri in fase di calcolo della GI) senza farlo vedere.

Strano sto problema, appena riesco faccio un po' di prove e vedo cosa mi esce... Nel frattempo mi faccio coraggio e rileggo il post...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Se fai così però elimini l'oggetto dalla scena... il Visible To Camera invece serve a mantenere l'oggetto (molto importante per i muri in fase di calcolo della GI) senza farlo vedere.

Strano sto problema, appena riesco faccio un po' di prove e vedo cosa mi esce... Nel frattempo mi faccio coraggio e rileggo il post...

Si questo è vero, ma dovendo improvvisare per la realizzazione di render da consegnare è stato l'unico modo.

Ora andrò di test per il Visible To Camera

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×