Vai al contenuto
monicasole

3d studio max! Problemi render luci-ombre

Recommended Posts

Ciao a tutti! Sono nuova di queste parti, e mi sono rivolta a voi per un problema con 3ds.

Impostando nella scena tre target light che dovrebbero illuminare in maniera omogenea l'oggetto, quando faccio partire il render la scena è illuminatissima, il piano del fondale è bianco e dell'oggetto si vedono poche parti, iper illuminate.

Non so più che fare! Ho provato a cambiare un sacco di opzioni, ma nulla.

Help me please :(

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao e benvenuta sul forum!

Che motore di render usi? Usi una camera o fai il render dalla viewport?

Prova a postare uno screen delle impostazioni delle luci, probabilmente hai il multiplier troppo alto e le 3 luci assieme ti bruciano la scena!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Finalmente una voce amica! Innanzitutto, grazie mille per la celere risposta!

Proprio ora stavo controllando il "Render preset".

Tra i miei appunti avevo segnato "mental ray", li ho provati tutti ma la scena adesso è completamente buia :(

Ho fatto lo screenshot con tutti i preset che ho a disposizione. Che dovrei mettere?

post-83878-0-49335100-1338135384_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Hai dato un'ochiata all'esposizione delle luci?

Vedi qui nell'help di Max: Effects and Environments > Environment and Atmosphere Effects >Exposure Controls

Dato che stai usando MentaRay, hai provato qualche consiglio sempre sull'help di Max?

Comunque, maggiori info sono ben accette ;)

Comunque qui su Treddi, ci sono molti Tutorial nell'apposita sezione:

http://www.treddi.com/forum/forum/54-tutorial-rendering-ed-illuminazione/


Modificato da Michele71

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite

Finalmente una voce amica! Innanzitutto, grazie mille per la celere risposta!

Proprio ora stavo controllando il "Render preset".

Tra i miei appunti avevo segnato "mental ray", li ho provati tutti ma la scena adesso è completamente buia :(

Ho fatto lo screenshot con tutti i preset che ho a disposizione. Che dovrei mettere?

Non devi usare i preset ti portano furori strada.

devi suare il controllo di esposizione come ti ha suggerito Michele 71

La cosa migliore è usare delle luci fotometriche, target nel tuo caso e quando le inseirsci lui ti chiede di attivare il

controllo di esposizione, che puoi regolare a piacere con gli ev per aumentare o diminuire l'illuminazione della scena.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

dal tuo screen sembra abbia "Disabilitato" il Gamma, è cosi??

Se sapessi cosa sia... Te lo direi più che volentieri :\

Spiego meglio la situazione. Sto studiando industrial design all'Istituto Europeo di Design di Milano.

Abbiamo finito il corso da poco e sino ad allora 3ds andava alla grande.

Sicuramente avrò cambiato qualche impostazione (dato che io sono sempre quella che vuole provare perchè non le basta sapere quello che le hanno fatto studiare)... e adesso non ho idea di che cos'è che fa capitare questo disastro!

Insomma, appurato che è colpa mia.. Chiedo aiuto :-)

Cosa sarebbe questo "gamma"?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Se sapessi cosa sia... Te lo direi più che volentieri :\

Cosa sarebbe questo "gamma"?

:o :o :o

perdonami ma è piuttosto grave se allo IED non ti hanno spiegato cos'è, come si attiva o come si imposta il Gamma in MR!!!!!!

..poi perchè usi materiali "Standard"??

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Se consideri grave il non averci spiegato i gamma.... Come definiresti il fatto che i materiali standard sono gli unici che abbiamo fatto?

:eek:

:o:eek::wacko::unsure::blink::crying::(:angry::huh:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao,

no ho capito se poi hai risolto, in caso contrario controlla le unità di misura sotto "customize" - "Unit setup". Le luci fotometriche richiedono modelli reali per una resa corretta. Per le luci potrebbe esserci qualche problema con il "multiplier", inizia da un valore uguale a 1.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ma è uno scempio, ti consiglio di cercare un corso fatto come si deve!!!

se interessati a corsi su 3ds max e MR in Brianza contattatemi in pvt..

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

[OT] ... e poi dicono che un nick femminile è ininfluente :)

[OT anche io] cavolo se si chiamava "Goku92", aveva un'altro avatar (maschile) e faceva una domanda del genere il thread si sarebbe riempito di insulti, flame e prese in giro...

comunque: da che cosa hai ripreso la scena? dalla vista perspective o hai creato una camera? nel caso posta i settaggi...


Modificato da DiegoPennati

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

[OT anche io] cavolo se si chiamava "Goku92", aveva un'altro avatar (maschile) e faceva una domanda del genere il thread si sarebbe riempito di insulti, flame e prese in giro...

Ancora una volta fiera di essere donna, vista la vostra considerazione per la mia domanda ed, ovviamente, data la superiorità insita nel genere.

However, scherzi a parte, grazie davvero a tutti! Siete stati gentilissimi.

Non ho idea di cosa sia cambiato, ma oggi ha deciso di andare.

Tutto nella norma, luci regolari, ombre pure.

Non ho modificato parametro alcuno, eppure oggi, stesso file, stesse luci, stessi posizionamenti... Andava!

I misteri di 3ds.

Ciao,

no ho capito se poi hai risolto, in caso contrario controlla le unità di misura sotto "customize" - "Unit setup". Le luci fotometriche richiedono modelli reali per una resa corretta. Per le luci potrebbe esserci qualche problema con il "multiplier", inizia da un valore uguale a 1.

In unit setup quindi cosa dovrei settare? L'unità di misura corretta per il modello?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ancora una volta fiera di essere donna, vista la vostra considerazione per la mia domanda ed, ovviamente, data la superiorità insita nel genere.

However, scherzi a parte, grazie davvero a tutti! Siete stati gentilissimi.

Non ho idea di cosa sia cambiato, ma oggi ha deciso di andare.

Tutto nella norma, luci regolari, ombre pure.

Non ho modificato parametro alcuno, eppure oggi, stesso file, stesse luci, stessi posizionamenti... Andava!

I misteri di 3ds.

In unit setup quindi cosa dovrei settare? L'unità di misura corretta per il modello?

In genere, prima di modellare un soggetto imposto l'unità di misura, che dipende dalla scala su cui lavoriamo. Mi spiego meglio: se la scena 3D è concentrata su un oggetto piccolo tipo un vaso lavorerò in mm o cm, se la scena 3D inizia ad essere più ampia, tipo una casa in esterna probabilmente lavorerò in metri e così via. Il modello sarà modellato in unità che dovranno corrsondere all'unità di misura prescelta. Se osservi anche l'illuminazione ha delle unità di misura (internazionale). Quando impieghi le luci fotometriche (quindi con parametri fisici) vedrai valori espressi in lux o cd/mq. Qui entra anche in gioco un discordo di progettazione della luce perchè per esempio se illumini una stanza con una sole luce fotometrica di ridotta capacità noterai che la stanza rimane buia. Si possono scaricare dai siti dei produttori i files IES con i parametri illuminotecnici di modelli reali con rispettivi diagrammi di diffusione della luce. Spero di non divagaree troppo, nel forum troverai dettagli più specifici su questo argomento. Volevo solo evidenziare che a volte l'illuminazione che il programma ci restituisce non corrisponde alle aspettative, perchè si è impostata un'unità di misura scorretta e non compatibile con la luce.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sistemata l'unità di misura.

Ragazzi non ne posso più. Oggi un altro problema. Anzi, due!

Nella perspective non si vede un materiale (che risulta infatti nero sugli oggetti), ovvero l'acciaio.

Inoltre, sempre nella scena il piano creato sotto l'oggetto è completamente bianco, anche se in realtà il colore settato è grigio.

Ho impostato "illuminate with scene light" eppure guardate che schifezza!

E come se non bastasse lancio il render e mi viene un alone chiaro che... DA DOVE VIENE FUORI?????

post-83878-0-44416200-1338635442_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sistemata l'unità di misura.

Ragazzi non ne posso più. Oggi un altro problema. Anzi, due!

Nella perspective non si vede un materiale (che risulta infatti nero sugli oggetti), ovvero l'acciaio.

Inoltre, sempre nella scena il piano creato sotto l'oggetto è completamente bianco, anche se in realtà il colore settato è grigio.

Ho impostato "illuminate with scene light" eppure guardate che schifezza!

E come se non bastasse lancio il render e mi viene un alone chiaro che... DA DOVE VIENE FUORI?????

Come spesso accade si risolve un problema e ne sbucano 2. Partirei dall'alone bianco vista rendering: probabilmente ha i attivato lo shader glare nella finestra Rendering setup - scheda renderer - camera shaders. E' sufficiente togliere la spunta da output nel settore camera shaders. La cosa più importante per ottenere un risultato corretto, o quello sperato, è di utilizzare i materiali di Mental Ray se utilizzi mental Ray come motore di renderig. Prova ad assegnare al piano il material Arc & Design, e parti con un preset "matte finish" (senza riflessione). Sul canale diffuse imposta un grigio scuro; fai delle prove e regola l'intensità di grigio fino a ottenre il risultato desiderato. L'oggetto nero non lo capisco sinceramente. Prova ad assegnarli un altro materiale. Hai verificato che le normali delle facce siano rivolte all'esterno. Se non è così devi rovesciarle entrando nel livello suboggetto. Prima di questo prova a renderizzare la scena impostando nel pannello Render setup - scheda common - force 2-sides. Spero di aver inteso il problema. Mi sarebbe di aiuto capire oltre al piano che cosa c'è intorno all'ambiente, perchè ciò che è intorno inluenza molto le riflessioni (tipo sfondo bianco o nero o uno shader con gradiente ecc...

in bocca al lupo per il momento.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Se sei alle prime armi evita luci fotometriche che presuppongono la conoscenza approfondita delle impostazioni di potenza e colore nonchè del controllo delll'esposizione...

Ti invito inoltre a non usare i Materiali Standard perchè non si comportano correttamente con l'illuminazione indiretta..

Per questo tipo di scena è sufficiente usare una semplice Skylight come luce Diffusa e una o più MR Area Omni per l'illuminazione degli oggetti e proiezione Ombre..


Modificato da Lele

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×