Vai al contenuto
Francesco Costa

Problema color bleeding e ambient occlusion mental ray

Recommended Posts

Salve a tutti..

Ultimamente ho lasciato un po da parte il vray per tornare al mentalray, i risultati non sono affatto male però ho un paio di problemi:

Ad esempio in una stanza bianca appena inserisco un mobile bordeaux tutta la stanza assume un colore rosato..

In vray mi è stato detto di utilizzare il VrayOverrideMtl, su mentalray come posso risolvere il problema?

Secondo: come posso ottenere un ambient occlusion realistico con mentalray? Non c'è un comando predefinito per farlo?


Modificato da Fracos

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao, dovresti fornire più dettagli.

Mental ray per Maya? 3d studio max?

Che tipo di materiali stai usando? Che impostazioni nell'illuminazione?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Si scusate, allora:

Uso 3d studio max;

Il materiale è un ''bordeaug high glossy'' già presente nella libreria;

La scena è illuminata con 4 "PhotometricLight" , GI attiva.

Final gather a medium

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

1) Penso che sia normale... La luce che viene riflessa dal mobile di colore bordeaux, "colora" la parete bianca per il fatto stesso che viene riflessa la luce per tutta la stanza. E' un problema di riflessione dei fotoni. Puoi ovviare a questo problema diminuendo la "forza" di riflessione del mobile o agendo sulla riflessione di FinalGather e GI.

MR ha un OverrideMtl (Autodesk 3ds Max Help > Rendering > Renderers > mental ray Renderer > mental ray Renderer Interface > Processing Panel > Translator Options Rollout (mental ray Renderer) Material Override), ma come in VRay, esso serve a usare un materiale/texture/colore "master" per tutti gli oggetti presenti nella scena. Esso non ti risolve il problema sopraesposto...

2) Per ottenere un Ambient Occlusion in MR:

Scegli uno slot vuoto e in "Material/Map Browser" scegli lo shader "MentalRay"

In "Material Shader" (della mappa "MentalRay") pick lo slot "Surface" e scegli lo shader "Ambient/Reflective Occlusion (3dsMax)

Sistema i parametri come desideri. In generale:

Un valore di "sample" sui 50/60

Per avere un controllo sullo "spessore" usa "Spread"

Per avere un controllo sulla larghezza dell'ombra usa "Max distance"

Vai in "Environment" (tab Rendering > Environment) e in "Background" metti un colore bianco. Ricordati di non spuntare "Use Map".

Se stai usando "Exposure Control", disabilita esso

Disabilita FinalGather e GI

Renderizza.


Modificato da Michele71

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×