Vai al contenuto
danispider

problema con ncloth

Recommended Posts

ciao ragazzzi ho un problemino. ho una superficie formata da mesh triangolari che ho creato con rhinoceros e poi ho esportato su maya salvando il file con l'estensione .obj. Ho assegnato alla superficie un ncloth. ma durante l'animazione i triangoli che compongono la superficie stessa si "slegano" andando ognuno per i cavoli loro. come devo fare per non far "sfaldare" la superficie, in modo tale da creare l'effetto "cloth"? grazie mille....

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

non ho capito, la tua superficie è formata da più mesh(più oggetti)? prova a mergiare i vertici che compongono la tua superficie, ovviamente prima di fare il cloth.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ho semplicemente una superficie formata da triangoli anzichè da quadrilateri... come faccio a "mergiare" i vertici come mi hai detto? basta selezionare tutti i vertici e pigiare merge? io inizialmente pensavo che bastasse andare su mesh-combine per far si che la mesh si "unisse"... non è così? thanks...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

con il combine fai si che maya veda tutti gli oggetti come un unico oggetto ma se i vertici non sono saldati quando fai l'ncloth o magari applichi lo smooth, il programma li vede comunque come oggetti separati. si basta selezionare tutti i vertici e fare merge.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ho provato proprio ora a selezionare tutti i vertici e pigiare merge. però, per verificare se si erano veramente uniti, sono andato a spostare un qualsiasi vertice della superficie, e questa mi si è aperta in corrispondenza di quel vertice. ciò vuol dire che la superficie è restata disunita.. come mai?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

è molto "sporca" ci sono degli edge che si fermano e non seguono sugli altri poligoni, lì, anche se mergi ovviamente maya non esegue l'operazione perchè non ha 2 vertici da collassare ma ce n'è solo 1. Devi per prima cosa toglierli e cancellare i relativi vertici che rimangono. Comunque, se il merge non funziona puoi alzare la tolleranza andando sul quadratino che sta a destra del comando(sempre che i vertici siano sovrapposti), altrimenti c'è il "merge to center" o il "merge vertex tool", che sono dei metodi molto manuali.

Stavo pensando, non potresti esportare in fbx cosi che la mesh è tutta a poligoni quadrati e non con i triangoli?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×