Vai al contenuto
zoc

Loft in maya

Recommended Posts

Prendo alla lettera D@ve (al quale vanno tutti i miei complimenti per il bellissimo sito!) e riporto qui un dilemma che non sono ancora riuscito a risolvere.

loft.jpg

la sequenza dei cerchi selezionati è giusta, e i vari cerchi sono stati creati con Duplica dal primo cerchio...

aiutoooooooo

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Lo so' che si puo' fare con revolve, ma era un esempio per farvi vedere il mal funzionamento del loft....nei setting dello strumento loft, prima di applicarlo ho fatto un bel Reset... non so' proprio...

ciaoooo

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

La cosa fondamentale se vuoi fare dei loft è sapere che le curve, le nurbs, hanno un verso e una direzione.

Credo che tu abbia una o più curve con la direzione opposta alla maggior parte delle altre. In questi casi si fa così:

1) Trova e seleziona la nurbs con la direzione sbagliata

2) Menu Edit Curves-->Revers Curve Direction

Puoi fare tutto anche dopo il loft se hai mantenuto l'history.

Ah se non sai come vedere la direzione di una nurbs fai così:

1) Cambia modalità di selezione da Object a Component (tasto F8 sulla tastiera)

2) Osserva le curve e vedrai che hanno tutte un punto di partenza e (un piccolo quadratino) e una direzione (una piccola U )

curva_nurbs.jpg

3) Trova quella che ha la direzione opposta alle altre e hai risolto, è quella che devi invertire col comando che ti ho detto.

a presto

Mauro B)


Modificato da MannaTheBerserk

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grazie mille per la spiegazione!!! il problema e' che ho controllato le curve e hanno tutte la stessa direzione...infatti le avevo create con duplica...che faccio??

grazie ancora!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
grazie mille per la spiegazione!!! il problema e' che ho controllato le curve e hanno tutte la stessa direzione...infatti le avevo create con duplica...che faccio??

grazie ancora!

Che fai?

...disinstalla Maya, pulisci il file di registro di windows da tutte le voci che richiamano Maya o Alias (usa un programma apposito magari, tipo RegSupreme), cancella a mano la cartella dell'Alias nelle applicazioni (visto che l'uninstaller non lo fa), cancella la cartella delle preferenze di Maya dalla cartella "Documents and Settings" (cioè Documenti che sta sulla scrivania).

Reinstalla Maya.

Il fatto è che con il duplicate a me funziona alla grande. Prima di fare tutto sto bordello però prova solo a cancellare il file di preferenze di Maya cercandolo nella cartella che ti ho detto prima (qualcosa come C:\Documents and Settings\Maya\6.0\ ).

Poi riapri Maya (creerà da solo un file di preferenze pulito pulito come se lo avessi appena installato).

Prova di nuovo l'esercizio e dimmi se va. Altrimenti ti tocca la prima soluzione.

Spero che risolverai presto

Mauro :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

anche a me da lo stesso risultato... nel tool setting metti sirface degree a linear al posto di cubic e ottieni una cosa più umana oppure prova a ivertire le curve e a metterle con direzioni opposte magari ottieni qualcosa di utile...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

anche a me da lo stesso risultato... nel tool setting metti sirface degree a linear al posto di cubic e ottieni una cosa più umana oppure prova a ivertire le curve e a metterle con direzioni opposte magari ottieni qualcosa di utile...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
anche a me da lo stesso risultato... nel tool setting metti sirface degree a linear al posto  di cubic

ma se metti linear come grado della curva otterrai superfici di secondo grado e quindi a spigoli non liscie come le cubiche ;)

Mauro

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Si infatti con linear non otteniamo una superfice smooth....

io uso mac....cerchero' il file preference, cancello e faccio sapere...

grazie!!!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Si infatti con linear non otteniamo una superfice smooth....

io uso mac....cerchero' il file preference, cancello e faccio sapere...

grazie!!!

Anche io uso Mac tutto il giorno :)

Mauro

P.S. a casa ho il pc

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Posso chiederti un favorone???

ho reinstallato tutto, cancellando ogni preferenza ecc..., ma nulla e' cambiato.

Potresti farmi un loft come nella prima immagine che ho uplodato? quella all'inizio del post...usando lo stesso numero di curve e cercando di farle analoghe alle mie.

Cosi vedo come ti viene e magari ci capisco di piu'...

Poi giuro che non ti scoccio piu'.

Grazie mille!!! Siete gentilissimi!!!

Ps: secondo te maya dove gira meglio? su pc o mac?


Modificato da zoc

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Posso chiederti un favorone???

Potresti farmi un loft come nella prima immagine che ho uplodato?[cut]

Cosi vedo come ti viene e magari ci capisco di piu'...

Ok, appena mi libero te lo faccio :wink:

Poi giuro che non ti scoccio piu'.

Grazie mille!!! Siete gentilissimi!!!

Ma mica scocci, mi spiace solo di non poterti aiutare in tempo reale visto che sto al lavoro :)

Ps: secondo te maya dove gira meglio? su pc o mac?

A mio parere è decisamente migliore su PC. Ma devo dire che con Maya 6, la versione Unlimited però, l'hanno quasi raggiunto. A carcarsi è più veloce su Mac comunque.

Mauro

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ok ho provato su Mac e a quanto pare c'è questa stranezza. La buona notizia è che ciò avviene solo in previsualizzazione.

Prova a renderizzare e vedrai che il loft è perfetto :)

Mauro

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

il problema e' che ho dato le curve su cui fare il loft, ma maya me le costruisce non correttamente, e come se aggiungesse delle curve facendo andare la superfice a forma di esse...

ciaooooo


Modificato da zoc

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

nulla da fare....mi da' un tubo

....mi sono giocato la possibilita' di usare lo strumento loft....

ma misa' che avro' cambiato qualche impostazione e anche reinstallandolo non mi e' ambiato nulla... sono spacciaotooooooo!!!


Modificato da zoc

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
nulla da fare....mi da' un tubo

....mi sono giocato la possibilita' di usare lo strumento loft....

ma misa' che avro' cambiato qualche impostazione e anche reinstallandolo non mi e' ambiato nulla... sono spacciaotooooooo!!!

Ma è per lavoro?

...dimmi quello che devi fare e vediamo se riesco a darti una zampa ;)

Mauro


Modificato da MannaTheBerserk

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

magari per lavoro...pultroppo sono una sega e non posso propormi ancora per fare lavori 3d...

sto studiando e spero di farcela il prima possibile...

sei gentilissimo...grazie mille....

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

non ho bisogno dell oggetto....ho fatto questo per farvi capire qual era il problema con i loft...

la cosa e' grave se tutti gli utenti mac hanno lo stesso problema, vorrebbe dire che dovremmo attaccarci al tram... :(

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

tutti gli utenti maya e non mac...io uso un pc ed ho lo stesso identico problema! ma probabilmente è solo il modo in cui maya gestisce i loft perche e magari usando 4 linee al posto di 4 cerchi hai lostesso risultato...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ciao zoc, Mannathebersek dice: perche non fai un revolve? cioè, ti metti il profilo nella view front, gli tiri il profilo con delle curve e poi fai revolve appunto: Surfaces --> revolve

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×