Vai al contenuto
Alessandro84

Prime Prove Rayfire

Recommended Posts

Ciao a tutti, sto iniziando a usare il plug in rayfire.

Mi sono creato una semplice scena:

http://imageshack.us/photo/my-images/651/rayfiretest.jpg/

dove vorrei far cadere i tronchi all' interno del contenitore.

setto static obj il contenitore e Dynamic i ceppi di legno, guardando il making of di evermotion relativo a sanjuan con le impostazioni di default gli oggetti dovrebbero cadere e riempire il contenitore.

Quello che succede a me invece è che in pratica esplodono:

http://imageshack.us/photo/my-images/718/rayfireprova002.jpg/

ho guardato diversi tutorial online ma nessuno che spieghi le basi su come far collidere gli oggetti correttamente ( o almeno io non ne ho ancora trovati ) mentre un sacco che spiegano come " rompere gli oggetti "

seguendo i vari tutorial ho anche installato il plug in per 3dsmax physx.

qualcuno di voi ha provato rayfire e sa darmi qualche consiglio ?

intanto grazie a tutti

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Mi correggo la prima volta che faccio la simulazione funziona tutto bene, poi....se provo a rifarla sia con gli stessi parametri che con parametri differenti "impazzisce" e schizzano via tutti gli oggeti

questa è la prima simulazione:

http://imageshack.us/photo/my-images/196/rayfireprova003.jpg/

è strano, anche facendo reset all object, rimuovendo il modificatore dallo stack...la seconda volta che faccio la simulazione fa tutta una cosa diversa.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

prima di fare la simulazione definitiva fai la preview. Primo tasto.

Per i tutorial vai su quelli di Mirvadim. li trovi anche nel sito ufficiale di rayfire

ti ringrazio, quelli li ho visti, ma parte direttamente distruggendo gli oggetti.

Per lapreview ho provato ma non mi cambia, faccio la simulazione la prima volta poi quando la faccio la seconda i ceppi di legna partono in direzioni casuali.

come posso fare per ripristinare la simulazione in modo che me la faccia corretta?

Per adesso devo togliere tutti i modificatori toglieri gli oggetti dalle liste e poi rimetterli e rifarla....mi sembra un pò strano

Vedrò comunque di riguardarmi meglio i tutorial, forse mi è sfuggito dove parla dei settaggi proprio base.

intanto grazie

al momento sono riuscito a fare questo:

http://imageshack.us/photo/my-images/32/legni.jpg/

prima di passare a distruggere oggetti volevo capire dove sbaglio perchè non ha senso che impazzisca la seconda volta che provo a simulare. Ci deve essere qualcosa che non faccio


Modificato da Alessandro84

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Comunque deve essere un bug, Rayfire funziona abbastanza bene. Prova a controllare che non ci siano interpenetrazioni (si dice così??? boh) tra gli oggetti e alza il Collision Tollerance.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao, ho fatto una prova con geometrie più semplici e sorgono problemi diversi rispetto al precedente, ora le geometrie che devono cadere non impazziscono da una prova all' altra ma, come puoi vedere non cadono dentro il recipiente ma ci si fermano sopra come se fosse un box chiuso...

ho lasciato di default le impostazioni delle liste di oggetti quindi sono convex entrambi solo ho provato a giocare con il parametro collision tollerance ma non mi cambia il risultato.

http://imageshack.us/g/5/step002.jpg/

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ok, con max 2012 da problemi.

infatti avevo letto.Poi avevo una demo vecchia, installando la 1.56 ho risolto avevo la demo 1.55 non sapevo ne fosse uscita un' altra.

Ancora grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao, ora ho una ltro problema, non trovo sull' help come si fa a togliere le ckiavi di animazione lasciadno però l' oggetto dov' è .

Mi spiego meglio al termine dell' animazione ho tutte le chiavi io vorrei rimuoverle e mantenere la posizione degli oggetti come a fine timeline...se faccio delete key però gli oggetti mi tornano al punto di partenza...

grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×