Vai al contenuto
billyacaro

superficie da due curve. Rhino

Recommended Posts

salve a tutti,

sto diventando matta con questa cosa, devo fare uyn superficie facile e non riesco...

Lavoro con rhino, in pratica si tratta di una forma ellittica alla base (linea azzurra)con due sezioni a parabola (quelle rosse)...mi scuso per la descrizione pessima.

Ho provato a fare sweep1rail usando come rail la linea azzurra e come cross le altre curve (che ho diviso in 4 parti..). ma non viene.

cosi' per la disperazione ho creato 4 superfici con il comando surface from curves, ma si vedono i giunti a spigolo (v.img allegata).

qualcuno sa dirmi come devo procedere??? con altre forme simili con lo sweep1 rail sono riuscita, ma con questa proprio no...

grazie mille

Sil

post-134-0-23200200-1309862831_thumb.jpg

post-134-0-03268600-1309862843_thumb.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Fai un ellissoide e dividilo a metà.

Ciao

Per fare Sup. da rete di curve devi dividere in due parti ciascun arco e lasciare chiusa la linea ellittica.


Modificato da GUESTOLDO

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

ciao!

grazie per la risposta, il problema e' che non e' un ellissoide, ho provato anche facendo cosi,

allego un'img per far capire, in pratica facendo l'ellissoide, sembra esserep iu' preciso, ma la base,(nel img allegata la linea rosa) non coincide con la forma dell'ellissoide (linea nera). forse e' un'approssimazione minima che potrei trascurare...in ogni caso, forse e' il metodo piu' semplice...

post-134-0-36599700-1309866838_thumb.jpg


Modificato da billyacaro

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

O non è in asse la tua superficie oppure non è in quad la linea azzurra...

Per ottenere un risultato corretto e veloce devi essere più precisa nella costruzione del modello. Stai attenta agli assi di costruzione e centra il lavoro sullo zero.

La linea azzurra, se ruotata intorno all'asse non ti da la superficie della foto ma una uguale e spostata.

Non so cosa devi fare ma se la tua linea, quella che non coincide col bordo dell'elissoide, è tassativa il metodo non cambia. Prima ricostruisci e rigenera la curva ellittica e poi procedi come ti ho detto. Verrà.

Ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

O non è in asse la tua superficie oppure non è in quad la linea azzurra...

Per ottenere un risultato corretto e veloce devi essere più precisa nella costruzione del modello. Stai attenta agli assi di costruzione e centra il lavoro sullo zero.

La linea azzurra, se ruotata intorno all'asse non ti da la superficie della foto ma una uguale e spostata.

Non so cosa devi fare ma se la tua linea, quella che non coincide col bordo dell'elissoide, è tassativa il metodo non cambia. Prima ricostruisci e rigenera la curva ellittica e poi procedi come ti ho detto. Verrà.

Ciao

il problema e' che la linea azzurra non e' un ellisse. e' una curva forvata da piu' archi, quindi nel momento in cui faccio un ellissoide e lo sezione non coincide con la mia curva azzurra....:-( non ho idea di come fare ad ottenerlo....c'e' uan differenza di circa 1cm...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Rieccomi.

Io parlavo di linea azzurra non viola.

Nel riquadro right non è al centro della superficie, non è sul quad.

Le linee sarebbe meglio non ottenerle unendo vari spezzoni. Rhino si ricorda gli elementi di cui era composta anche se li hai uniti fra loro.

Se devi fare un'ellisse come la tua (viola) ne tracci una più simile possibile e poi muovi i punti di controllo finchè non si sovrappone alla tua. Ma che sia n'unica linea.

Ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Se fai l'ellissi poi potresti modificarla con un cage edit portatola alla forma che vuoi tu . Metodo poco preciso ma risolveresti . In alternativa se gia conosci bene il tuo disegno potresti farti delle sezioni e dopo fare un loft . Quando lavori con archi non hai una continuita' quindi G2 ma stai in G0 ed e' facile che la superficie ti esca inpuntata, quindi meglio che lavori con una spline o fai un match curv o blend curv tra gli archi . Potresti anche valutare il network surf ma sempre dopo che ti ricostruisci le dorsali

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

ehm...grazie per le risposte...

@GUESTOLDO ho capito a cosa ti riferisci, in pratica le due sezioni di riferimento non sono in asse....ed hai ragione, ma se porto la seconda sezione sull'asse non si incrocia piu' con l'altra sezione. Mi rendo conto che evidentemente i disegni delle sezioni che mi hanno passato sono molto imprecisi. Purtroppo pero' sono le uniche basi che ho e non so bene come e se posso modificare tali curve o crearne di nuove.

@KLESH: avevo pensato di creare varie curve, ma purtroppo non avendo molte basi su cui lavorare (i disegni che mi hanno fornito prevedono solo pianta e sue sezioni tipo) non saprei come costruire le sezioni intermedie.

Cosa significa G2 - G0 ?? intendi i gradi delle curve? (perdona la mia ignoranza...)

Vi mostro il risultato ottenuto ieri sera, in pratica ho provato a fare due sweep2 rails dividendo la forma in due parti....sembra quasi decente che ne dite?

grazie ancora per l'aiuto!

sil

post-134-0-85430300-1309942124_thumb.jpg


Modificato da billyacaro

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×