Vai al contenuto
md1979

Mental Ray su 3DS: impostazione materiali

Recommended Posts

Buonasera a tutti!

Vi chiedo aiuto per l'impostazione dei materiali su 3DS. Premettendo che uso questo programma da poco e che finora ho utilizzato il motore di rendering di default (a proposito, uso la versione 9), vorrei ora imparare ad utilizzare Mental Ray.

In particolare sto realizzando una scena d'interni già creata in precendenza con materiali architectural che vengono discretamente bene anche utilizzando mantal ray. Il problema sta nelle texture: non vengono in nessun modo! Nel render in pratica mi viene tutto grigio e nessuna traccia della texture utilizzata.

Seguendo guide e tutorial ho provato ad utilizzare materiali Arch&design, mental ray o DGG ma nulla.... la texture me la fa vedere ma nel render proprio non esce :wallbash:

Sapete indicarmi la strada giusta da seguire? Ho cercato guide e tutorial ma su come creare texture proprio non ho trovato nulla.

Confido nei vostri suggerimenti!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Conosco già l'UVW Mapping e lo uso sempre!!! Il problema e che renderizzando con Mental Ray la mappa nel render proprio non mi esce. Me la fa vedere a video ed è scalata correttamente ma nel render al posto della texture viene tutto grigio. in pratica al posto delle piastrelle precelte e visualizzate viene una parete tutta grigia nel render!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Provo ad allegare file jpg con le impostazioni utilizzate... le prime 2 sono riferite allo stesso materiale Arch&Design (che è lo stesso che si vede sullo sfondo: le pistrelle bianche) la terza immagine è riferita alla precedente impostazione con materiale architectural.

In tutti i casi il materiale viene visualizzato ma non renderizzato!

post-62709-0-89217000-1300734775_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite
Inviata (modificato)

ultima immagine

questi tipi di materiali architettonici è meglio che non li usi in mr.

ma il render come viene posta una immagine.


Modificato da Mak21

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

in effetti avevo già letto da qualche parte che i materiali architectural con mental ray non vanno bene.

posto un'immagine del risultato con le impostazioni del materiale arch&design:

quello nero sarebbero in realtà piastrelle in marmo con i settaggi che ho fatto vedere prima.

Le due fasce grigie sarebbe un mosaico....

Mi interessa capire come impostare almeno un materiale per poi andare a modificare anche gli altri sbagliati

post-62709-0-78655500-1300738947_thumb.j

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite

non è che l'oggetto ha le cordinate Use_Real_World_Scale

e il materiale no.?

oppure anche il contrario ?

il materiale le ha nelle impostazioni di tile e l'oggetto no?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

non è che l'oggetto ha le cordinate Use_Real_World_Scale

e il materiale no.?

oppure anche il contrario ?

il materiale le ha nelle impostazioni di tile e l'oggetto no?

no, nessuna delle 2. sia materiale che oggetto non hanno il real world scale


Modificato da md1979

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao.

Il problema sussiste solo su quelle geometrie? (penso di sì visto che altri elementi come lo specchio ed i sanitari sono ok, come il pavimento che dà riflessioni dello zoccolo...).

Se noti, parte il muro a destra lo vedi "diverso" rispetto allo spigolo anche nel viewport (quantomeno la fascia superiore sotto la finestra):

Provato a controllare che non ci siano doppie geometrie che si sovrappongono (ad esempio un doppione del muro) o che le normali delle superfici siano rivolte correttamente verso la camera (soprattutto per la parete di piastrelle, che risulta nera)?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao Multimano

il problema credo risieda proprio nelle texture perchè ho riscontrato problemi nel renderizzare tutte le texture.

Considera che il nero sarebbero delle piastrelle in marmo ( controllato: nessuna doppia geometria e facce girate correttamente) le due strisce grigie a parete sarebbero 2 file di mosaico, il pavimento sarebbe sempre una texture di una piastrella. Le uniche cose che non mi danno problemi sono i materiale senza texture, come lo specchio, la ceramica dei sanitari e il metallo dei rubinetti.

Può essere un problema di impostazioni errate?

Questo modello l'avevo creato per il Default Scanline, poi l'ho convertito in Mental Ray per vedere le differenze e ho convertito il materiale marmo in Arch&Design (ma anche con i materiali mental ray o dgs mi da lo stesso risultato)

è il primo esperimento con mental ray quindi pensavo di aver impostato male qualcosa nelle texture....

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Convertito manualmente o tramite script presi da internet?

i materiali erano inizialmente tutti architectural (per default scanline) e io li ho convertiti manualmente in arch&design (selezionando architectural e assegnando arch&design) ma visto che la cosa non funzionava ne ho creato uno nuovo di pacca e l'ho riassegnato ma anche in questo caso nulla. cmq i materiali li ho sempre creati io nuovi perchè avendo una versione vecchia di 3DS la maggior parte di quelli già pronti su internet a me non funzionano

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

in effetti stavo valutando di provare a rifare il tutto su un nuovo file. Proverò a rifare solo i muri applicando un nuovo materiale per vedere che succede.

Solo un consiglio: visto che devo rifare tutto, che tipo di materiale mi conviene usare per fare diciamo una ceramica lucida? è la prima prova con mental ray e sto andando per tentativi (oltre che con le guide e i tutorial, ma sulle texture in mr non ho trovato molto)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Prova a resettare i parametri di mental ray

Cambia motore di rendering impostando lo scanline e subito dopo reimposta mental ray

In questo modo dovresti resettare tutti i settaggi di mental ray e puoi verificare se è qualche spunta che ti si è attivata per sbaglio a crearti il problema.

Inoltre vai nei parametri di rendering, tab "common" e metti la spunta a force 2-sided

Altra cosa visto che ci sono.

Seleziona l'oggetto che ti dà problemi clicka con il destro sull'icona "Select and Move" e verifica che le coordinate assolute non siano dei numeri enormi.

In caso affermativo stai lavorando molto lontano dall'origine e puoi aspettarti di tutto dal modello.


Modificato da philix

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Aggiungo che se vuoi ripartire da un file nuovo con nuovi materiali, prova prima ad usare un materiale Arch&Design, con preset di default (ad esempio il Glazed Ceramic Tiles dovrebbe essere un buon punto di partenza per quello che vuoi ottenere).

Buon lavoro.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Grazie mille finalmente il problema pare risolto!

Cambiando motore di rendering e poi ripristinando mental ray si è sistemato tutto, ora mi fa vedere tutte le texture correttamente. Evidentemente a furia di andar per tentativi avevo selezionato qualche opzione che era meglio lasciar stare.

Quindi grazie a philix che mi ha trovato la soluzione e anche a multimano per i consigli che seguirò sicuramente.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite   
Ospite

in effetti stavo valutando di provare a rifare il tutto su un nuovo file. Proverò a rifare solo i muri applicando un nuovo materiale per vedere che succede.

Solo un consiglio: visto che devo rifare tutto, che tipo di materiale mi conviene usare per fare diciamo una ceramica lucida? è la prima prova con mental ray e sto andando per tentativi (oltre che con le guide e i tutorial, ma sulle texture in mr non ho trovato molto)

materiale arch e design o i pro material se hai la versione 2009 - 2010

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

grazie anche a te mark.

ho resettato i materiali rifacendoli del tipo arch&design (ho la versione 9: vecchiotta vero? :lol: )

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×