Vai al contenuto
Ospite

Mental Ray Help Please

Recommended Posts

Ospite

:( Scusate ragazzi ma visto che stò errore si presenta un pochino frequentemente,

mi date una mano a capire?

Dall'errore che mi da mental ray alla fine del final ghater sembra che il mio ciclo di

calcoli aveva bisogno di 60 giga di memoria o sbaglio?

Ho visto che quando il render va in crash la cpu passa dall 100% a 0% e poi max

da un errore e va in crash.

Ho gia postato questo problema ma non ho avuto suggerimenti.

Solitamente le scene in questione sono molto pesanti come risoluzione finale o

come affollamento di materiali.

mental ray 3.4 max 7.5 ram 1.5 giga 30 giga di spazio su hd da 60 gb.

Bo.

Mi manca della ram o dello spazio di swap.

non capisco.

Grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

stai usando anche molti fotoni nella scena? hai provato a ridurli?

cmq intanto prova col "trucco" dello switch a 3gb (se stai usando win xp)

http://www.microsoft.com/whdc/system/platf...PAE/PAEmem.mspx

poi nel pannello render di 3d max (f10) trovi la memoria massima che max alloca per mental ray, prova ad aumentarla, anche se mi sembra che su max sia già impostata di default a 1,5 gb

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite

:( nella scena ho abilitato solo il final ghater con 100 sample e lasciando il resto

invariato, non ho abilitato i photon map per la global il. o le caustiche.

uso win 2000 e nelle ipostazioni di mental ray sono gia a 1.5 gb, che poi è la ram

installata nel mio computer.

In un altra scena ho abilitato la photon map e li posso provare a ridurre il numero,

poi ti dico,

Ma la cosa che non capisco è che veramente mental ray avrebbe bisogno di

60 gb. per concludere il calcolo, come dalla finestra che ti ho postato sopra?

Non è una cifra esagerata?

che ci vuole una workstation della pixar per fare sto render? :eek:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

60278360 bytes non sarebbero una sessantina di mega? comunque dovresti dirci quanti poligoni ci sono in scena..sono quelli a pesare molto sulla memoria quando il motore è mental ray, che luci stai usando e che processore hai.

Se ci sono molti oggetti in scena e sono magari non visibili nel render si deve attivare il placeholder, e si può continuare disabilitando il multithreading nel pannello delle opzioni dei render...sono tutti espedienti che alla fine rallentano il processo di calcolo ed evitano l'intasamento della ram (che si può prevenire anche con la modifica a 3gb del windows e con qualche programmino tipo freeram )

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite

:crying: si mi sa che sono 60 mega e giga.

la scena è molto pesante perchè ci sono tanti poligoni.

il render viene eseguito correttamente a 640 * 480 oppure 1000 * 800 circa.

il crash si è verificato quando volevo fare un render a 3500 * 2500 circa per poi fare una stampa.

Il mio povero pc è un pentium IV 2,66 533 con 1,5 gb di ram.

Forse ci vorrebbero almeno 2 processori e 2 gb di ram che dici?

Soldi? bo.....

Comunque il crash si è verificato anche con altre scene a 640*480.

Grazie per le risposte.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

io ho un 2500+@2400 e 1gb di ram e riesco tranquillamente ad andare sui 5k x 5k con scene complesse

possibile che ci sia una qualche instabilità sul sistema?

io cmq uso win xp

se l'errore si verifica anche a risoluzione bassa la cosa è davvero strana...

provato a contattare la discreet?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

si ma bisogna vedere il numero effettivo dei poligoni e quante luci ci sono in scena.

Il numero effettivo lo trovi scorrendo sotto "file" dovresti aprire le proprietà del modello..nella lista ci sono scritti anche i poligoni e vertici del modello, se sei attorno al milione è molto probabile il crash. la situazione poi degenera per ogni luce che c'è in scena.

oppure hai un materiale un po' troppo complesso..prova a dare a tutto il modello un normale bianco standars..e vedi cosa succede.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

sono arrivato a renderizzare oltre 2 milioni di poligoni a 5k x 5k senza problemi (con raytrace, gi e fg attivi), questo almeno su maya, su max no ho mai fatto caso, ma ho renderizzato modelli anche più complessi, per cui è probabile che ci sia qualche problema sotto...

certo è anche vero che materiali complessi e molte luci potrebbero giocare un ruolo fondamentale in queste cose...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ospite
io ho un 2500+@2400 e 1gb di ram e riesco tranquillamente ad andare sui 5k x 5k con scene complesse

possibile che ci sia una qualche instabilità sul sistema?

io cmq uso win xp

se l'errore si verifica anche a risoluzione bassa la cosa è davvero strana...

provato a contattare la discreet?

Non farti molte illusioni sul supporto della discreet.

molte volte ho rivolto quesiti al mio rivenditore o al forum discreet sena avere

risposte.

meglio il nostro forum è più professionale sicuramente.

Vi faccio poi sapere quanti poligoni ci sono nella mia scena

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ah dimenticavo! fai una prova così... vai nella sezione inerente all'accelerazione raytrace e prova a usare "grid" al posto di "bsp", vedi se così il rendering funziona, dovrebbe essere parecchio lento però

altra possibilità è quella di ottimizzare il "bsp" (se il problema è del raytracing, se invece il problema è altrove non serve a molto)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×