Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
focscs

3Ds + Vray 2.0 - Cpu non al 100%

Recommended Posts

Ciao a tutti,

ho il problema che molti di voi hanno avuto ossia quello della cpu non usata al 100%.Ho provato tutte le soluzioni lette sul forum,dalla memoria a 6000-12000 mb al cambiare i jpeg,al task manager con relative affinità e priorità ma nada nessun risultato.

Nelle mie varie prove di debugging,siccome la scena a scendere ci mette una vita,ho pensato:

1.è il displace = l'ho cancellato e il problema persiste.

2.sono i samples dei materiali = da 16 li ha abbassati ad 8 e il problema persiste.

3.mergiato la scena in un file nuovo e il problema persiste.

4.cancellato tutta la geometria e inserito un semplice cubo all'interno della scena e il problema persiste.

5.Messo tutto in override (vraymtl - grigio) resettando il material editor e il problema persiste.

6.Lanciato in rete (netrender) in distribuito su una workstation e in locale su un server e la percentuale rimane sempre dal 50 al 70 %.

EDIT: ho provato a fare una scena nuova e usare il preset di quella non funzionante e quella nuova che funzionava a 100% e scesa a 50-70%


Edited by focscs

Share this post


Link to post
Share on other sites

Risolto chiedendo aiuto sul forum della chaosgroup e udite udite mi ha risposto vlado in persona O.O

Comunque il problema è stato eliminato mediante una riga di comando,disattivando il bitmap pager.

Questa operazione è un operazione che andrebbe fatta su tutti i file però vi è la possibilità di modificare un file .ini di 3ds in modo da disattivare il pager automaticamente.

Questa riga di comando per disattivare il bitmap pager va scritta all'interno del listener (f11):

ibitmpapager.enabled=false
Se non inserite la funzione =false verrà visualizzato lo stato del bitmap pager.Se impostato su false non c'è bisogno di questo comando,e il problema sarà altrove,invece se il valore TRUE il comando andrà a buon fine. Inoltre vi è la possibilità di impostare questo valore come FALSE in partenza,ossia andando a modificare il file 3dsmax.iniche trovate in %localappdata%\autodesk\3dsMax\2010 - 64bit\enu e in particolar modo la voce del file che recita [iBitmapPager] in questo modo:
[IBitmapPager]

EnabledByDefault=0 <-- [i][b]Settare a 1[/b][/i]

TileSizeAutoMode=1

TileWidth=512

TileHeight=512

AutoModeIdlePercent=0.500000

AutoModeRenderMinPercent=0.100000

AutoModeRenderMaxPercent=0.500000

AutoModeRenderGreedyCutoffPercent=0.250000

spero di esservi stato d'aiuto :)

ciao e buona giornata

Share this post


Link to post
Share on other sites

Scusate se scrivo in questo post ma in sostanza è lo stesso problema che sto riscontrando anche io :wallbash:

In pratica durante tutte le varie operazione, come irradiance map, light cache e render il processore lavora al 50%, facendo di conseguenza allungare drasticamente i tempi di render.

Questo problema si è manifestato in due scene fino adesso, molto diverse fra loro, ma non sono ancora riuscito a sistemarlo.

Ho provato anche quello che c'è scritto in questo topic, senza successo...

Cosa potrebbe essere?

Avendo un dua core già di base non è così performante, se poi va a metà...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x