Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Gatone

Materiale per una tastiera da pc. Come realizzare i caratteri?

Recommended Posts

Cercando per il forum o per il web non sono riuscito a trovare nulla in proposito.

Ho modellato una tastiera da pc, ed è praticamente completa, materiali plastici compresi. Solo che è del tutto spoglia. Mancano i caratteri in bianco stampati su ogni singolo tasto (la tastiera è nera).

Mi potreste dare qualche suggerimento? I tasti sono solidi singoli e indipendenti.

Share this post


Link to post
Share on other sites

certo che farlo singolarmente per ogni tasto diventa cosa lunga. se non hai necessità di avere i singoli tasti ti consiglierei di unirli in una singola mesh (poly), impostare le facce laterali con un id e quelle superiori (dove andranno le lettere) con un altro. con l'unwrap ti prendi il riferimento e te lo porti in photoshop (o chi per lui) così da avere, alla fine, una singola immagine e un materiale solo.

che ne pensi? :)

Share this post


Link to post
Share on other sites

Ho seguito con attenzione il tutorial, che peraltro avevo già visto, ma che superficialmente non pensavo rispondesse a quello che chiedevo io, soprattutto per l'alto numero di decalcomanie che devo inserire.

Ho impostato un multi-sub object con due materiali identici (raytrace) inserendo nel secondo 2 immagini bitmap (per iniziare) su due layer diversi e impostando due canali diversi.

Dopodichè ho selezionato due tasti della mia tastiera e in entrambi ho attivato uvw map assegnando ad un tasto valore 1 e all'altro valore 2 nel map channel.

Ho trascinato il multi-subobject sui due tasti, per assegnare il materiale, che è cambiato, effettivamente, ma sul modello non viene visualizzato altro. Ho provato ad attivare lo show in wiewport, ma non cambia nulla. Ho anche controllato le dimensioni della texture, che sono giuste, e per non sbagliare ho attivato il tile, in modo da avere una distribuzione uniforme, se ci fosse stata l'avrei vista di sicuro, ma il risultato è lo stesso.

Qualche parere?

@HiRes: è una soluzione che ho intenzione di provare. Magari mi spieghi nello specifico come importare in photoshop il riferimento da unwrap.

Vorrei comunque finire questo tipo di lavoro, che sto facendo esclusivamente come esercizio, quindi estremizzo un pò tutto quanto apposta, in modo da crearmi molti problemi.

E proprio per questo una volta ultimato proverò con il metodo che hai consigliato tu, così da provare tutte le strade. Spero mi chiarirai quel punto.

Grazie mille. :)


Edited by Gatone

Share this post


Link to post
Share on other sites

Ho seguito con attenzione il tutorial, che peraltro avevo già visto, ma che superficialmente non pensavo rispondesse a quello che chiedevo io, soprattutto per l'alto numero di decalcomanie che devo inserire.

Ho impostato un multi-sub object con due materiali identici (raytrace) inserendo nel secondo 2 immagini bitmap (per iniziare) su due layer diversi e impostando due canali diversi.

Dopodichè ho selezionato due tasti della mia tastiera e in entrambi ho attivato uvw map assegnando ad un tasto valore 1 e all'altro valore 2 nel map channel.

Ho trascinato il multi-subobject sui due tasti, per assegnare il materiale, che è cambiato, effettivamente, ma sul modello non viene visualizzato altro. Ho provato ad attivare lo show in wiewport, ma non cambia nulla. Ho anche controllato le dimensioni della texture, che sono giuste, e per non sbagliare ho attivato il tile, in modo da avere una distribuzione uniforme, se ci fosse stata l'avrei vista di sicuro, ma il risultato è lo stesso.

Qualche parere?

così su due piedi e senza il programma tra le mani non saprei che dirti...

@HiRes: è una soluzione che ho intenzione di provare. Magari mi spieghi nello specifico come importare in photoshop il riferimento da unwrap.

Vorrei comunque finire questo tipo di lavoro, che sto facendo esclusivamente come esercizio, quindi estremizzo un pò tutto quanto apposta, in modo da crearmi molti problemi.

E proprio per questo una volta ultimato proverò con il metodo che hai consigliato tu, così da provare tutte le strade. Spero mi chiarirai quel punto.

Grazie mille. :)

te lo spiegherò...soprattutto dopo aver rivisto il comando che mi sono scordato... :D

Share this post


Link to post
Share on other sites

Ti ringrazio molto.

Nel frattempo ho risolto il problema che avevo descritto sopra. Ho modificato un pò la procedura, ma adesso sono in grado di assegnare una texture diversa ad ogni tasto usando un solo materiale.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x