Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
frenk83

Abbassamento Di Luce

Recommended Posts

Ciao a tutti,

sto facendo un'animazione di un esterno con 3ds Max e motore MR.

Ho un problema ho notato che tra un fotogramma e l'altro c'è un leggero abbassamento di luce,quindi quando si guarda il video si vede un leggero sfarfallio, qualcuno sa dirmi come lo posso migliorare?

Vi allego alcuni dei miei parametri:

Di qua due fotogrammi di esempio:

Share this post


Link to post
Share on other sites

è possibile che nei parametri delle luci, hai attivato delle key sull'intensita della luce non volendo, è quindi nell'animazione, si vedono questi sfarfallii, se non è questo non so che altro potrebbe causare questo problema, controlla e fammi sapere :)

Ciaoo !

Share this post


Link to post
Share on other sites

Ciao a tutti,

sto facendo un'animazione di un esterno con 3ds Max e motore MR.

Ho un problema ho notato che tra un fotogramma e l'altro c'è un leggero abbassamento di luce,quindi quando si guarda il video si vede un leggero sfarfallio, qualcuno sa dirmi come lo posso migliorare?

Vi allego alcuni dei miei parametri:

Di qua due fotogrammi di esempio:

Io consiglierei il mr Photographic Exposure Control, ma forse è opinabile.

Inoltre prova a cercare, anche sul forum, gli argomenti sul salvataggio della mappa FG: anche il software te lo suggerisce ("Best for Still").

;)

Share this post


Link to post
Share on other sites

Io consiglierei il mr Photographic Exposure Control, ma forse è opinabile.

Inoltre prova a cercare, anche sul forum, gli argomenti sul salvataggio della mappa FG: anche il software te lo suggerisce ("Best for Still").

;)

quoto, il mr Photographic Exposure Control ti darebbe un controllo migliore e comunque il salvataggio della mappa del FG devi impostarlo in base all'animazione: se si muove solo la camera ma le luci e sopratutto gli oggetti rimangono fermi usa il metodo di salvataggio incrementale che va ad aggiungere informazioni alla mappa man mano che la camera inquadra diverse angolazioni della scena

Share this post


Link to post
Share on other sites

è possibile che nei parametri delle luci, hai attivato delle key sull'intensita della luce non volendo, è quindi nell'animazione, si vedono questi sfarfallii, se non è questo non so che altro potrebbe causare questo problema, controlla e fammi sapere :)

Ciaoo !

no, non è quello.

Share this post


Link to post
Share on other sites

Io consiglierei il mr Photographic Exposure Control, ma forse è opinabile.

Inoltre prova a cercare, anche sul forum, gli argomenti sul salvataggio della mappa FG: anche il software te lo suggerisce ("Best for Still").

;)

ma io lo uso già :blink2:

Che intendi Non capisco :blink2:

Share this post


Link to post
Share on other sites

quoto, il mr Photographic Exposure Control ti darebbe un controllo migliore e comunque il salvataggio della mappa del FG devi impostarlo in base all'animazione: se si muove solo la camera ma le luci e sopratutto gli oggetti rimangono fermi usa il metodo di salvataggio incrementale che va ad aggiungere informazioni alla mappa man mano che la camera inquadra diverse angolazioni della scena

io mi trovo nella condizione dove si muovono oggetti ma anche la camera poi ci sono scene dove si muove solo la camera quindi è fritto un misto! :lol:

Share this post


Link to post
Share on other sites

io mi trovo nella condizione dove si muovono oggetti ma anche la camera poi ci sono scene dove si muove solo la camera quindi è fritto un misto! :lol:

allora devi avere l'accortezza di dividere l'animazione in sequenze con tipo di calcolo ottimale simile, le renderizzi e poi le monti insieme, certo che se in alcune sequenze si mouovono gli oggetti, magari varia la luce e pure si sposta la telecamera mi sa che ti tocca calcolare la mappa di FG x singolo fotogramma senza riutilizzarla...

Share this post


Link to post
Share on other sites

ma io lo uso già :blink2:

Che intendi Non capisco :blink2:

La pria immagine che hai postato mostra le impostazione dell'exposure, settato su Logaritmic, non mr Photographic. Non è quello il problema, però...

Lo sfarfallio è presumibilmente dovuto alla mappa FG: anche f.tavella ti ha suggerito come fare. Prova a cercare nell'help di max [Reuse (FG and GI Caching) Rollout (mental ray Renderer)]...

Oltre a quello, credo incida sul flickering anche l'Anti Aliasing ...

<_<

Share this post


Link to post
Share on other sites

dall'immagine che posti pare che usi il Logarithimic Exposure Control

si uso il Logarithimic Exposure Control,

perchè col mr Photographic Exposure Control

viene cosi:

molto probabilmente sbaglio qualche parametro :blink2:

Share this post


Link to post
Share on other sites

La pria immagine che hai postato mostra le impostazione dell'exposure, settato su Logaritmic, non mr Photographic. Non è quello il problema, però...

Lo sfarfallio è presumibilmente dovuto alla mappa FG: anche f.tavella ti ha suggerito come fare. Prova a cercare nell'help di max [Reuse (FG and GI Caching) Rollout (mental ray Renderer)]...

Oltre a quello, credo incida sul flickering anche l'Anti Aliasing ...

<_<

per quanto riguarda il flickering sembra che con questo parametro abbia risolto, però nello specchio continua.

Come mai :blink2:

per quanto riguarda l'Anti Aliasing sono messo cosi:


Edited by frenk83

Share this post


Link to post
Share on other sites

fatti aiutare dalla preview, comunque all'inizio usa solo il valore EV, prova tra 12 e 14

gli altri valori che hai impostato sono sicuramente migliori, avrai sicuramente un aumento dei tempi di render non indifferente ma è l'unica strada

Share this post


Link to post
Share on other sites

per quanto riguarda il flickering sembra che con questo parametro abbia risolto, però nello specchio continua.

Come mai :blink2:

per quanto riguarda l'Anti Aliasing sono messo cosi:

x lo specchio che parametri del materiale hai usato? nella tendina dei parametri di raytracing di MR che cosa hai messo? Sopratutto per i valori di riflessione

Share this post


Link to post
Share on other sites

x lo specchio che parametri del materiale hai usato? nella tendina dei parametri di raytracing di MR che cosa hai messo? Sopratutto per i valori di riflessione

ma non penso sia dovuto al materiale

Share this post


Link to post
Share on other sites

fatti aiutare dalla preview, comunque all'inizio usa solo il valore EV, prova tra 12 e 14

gli altri valori che hai impostato sono sicuramente migliori, avrai sicuramente un aumento dei tempi di render non indifferente ma è l'unica strada

viene cosi

Share this post


Link to post
Share on other sites

Premesso che le animazioni non le ho mai gestite, procediamo con ordine.

Come già suggerito da f.tavella, separa le sequenze e inizialmente procedi solo su una (come presumo tu stia facendo per le prove).

Per il controllo esposizione, inizia come già detto da valori "standard", usando la spunta su Exposure Value (EV). Anche perchè se modifichi i parametri a mano devi sapere cosa stai cambiando (apertura diaframma, velocità e gli altri parametri di image control).

Di base mi sembrano tutte un pò slavate, desaturate, con un'illuminazione poco credibile.

Settare l'FGmap ogni frame è un pò eccessivo (IMHO); almeno nei test e se proprio non puoi farne a meno. Di solito si usa salvare la mappa ogni tot frame. Dipende dalla complessità dell'animazione, devi trovare il giusto compromesso.

Per quanto riguarda l'AA, essendo prove, abbassa pure a 1 - 4 (anche meno in realtà, ma devi saper "vedere" gli errori rispetto alla risoluzione); poi verifica se il filtro sia quello più corretto per le animazioni (per le still va per la maggiore il Mitchell).

Lo Spatial Contrast mi sembra un pò troppo basso... Io non scendo mai sotto lo 0,01... Ma magari per le animazioni è diverso... Devi informarti...

Per lo specchio non capisco. Se il problema sono gli aloni sul retro dell'espositore, devi affinare la FG map. Altrimenti spiegati meglio.

Solo una considerazione personale: non so se stai provando alcune impostazioni per diletto o per professione, ma anche la modellazione, il texture-mapping e l'inquadratura sarebbero da curare meglio. ;)


Edited by multimano

Share this post


Link to post
Share on other sites

Premesso che le animazioni non le ho mai gestite, procediamo con ordine.

Come già suggerito da f.tavella, separa le sequenze e inizialmente procedi solo su una (come presumo tu stia facendo per le prove).

Per il controllo esposizione, inizia come già detto da valori "standard", usando la spunta su Exposure Value (EV). Anche perchè se modifichi i parametri a mano devi sapere cosa stai cambiando (apertura diaframma, velocità e gli altri parametri di image control).

Di base mi sembrano tutte un pò slavate, desaturate, con un'illuminazione poco credibile.

Settare l'FGmap ogni frame è un pò eccessivo (IMHO); almeno nei test e se proprio non puoi farne a meno. Di solito si usa salvare la mappa ogni tot frame. Dipende dalla complessità dell'animazione, devi trovare il giusto compromesso.

Per quanto riguarda l'AA, essendo prove, abbassa pure a 1 - 4 (anche meno in realtà, ma devi saper "vedere" gli errori rispetto alla risoluzione); poi verifica se il filtro sia quello più corretto per le animazioni (per le still va per la maggiore il Mitchell).

Lo Spatial Contrast mi sembra un pò troppo basso... Io non scendo mai sotto lo 0,01... Ma magari per le animazioni è diverso... Devi informarti...

Per lo specchio non capisco. Se il problema sono gli aloni sul retro dell'espositore, devi affinare la FG map. Altrimenti spiegati meglio.

Solo una considerazione personale: non so se stai provando alcune impostazioni per diletto o per professione, ma anche la modellazione, il texture-mapping e l'inquadratura sarebbero da curare meglio. ;)

ok ora provo

P.S.

sto provando alcune impostazioni per diletto, per migliorarmi

Share this post


Link to post
Share on other sites

ora mi trovo in questa condizione:

Perchè è solo la telecamera a muoversi.

in oltre ho messo il mr Photographic

ottenendo un'immagine nettamente migliore, ma il fastidio, anche se molto meno percettibile, continua!

È possibile che dipenda dalla GI o dalla Gamma del exposure?


Edited by frenk83

Share this post


Link to post
Share on other sites

in più appaiono queste macchie

Per il Gamma ti consiglio di leggerti un pò di discussioni sul forum (cerca anche con "Linear workflow").

Per le macchie, hai provato ad aumentare la frequenza del salvataggio della FG map? Ogni 25 frame mi sembra poco...

P.S. Stai usando solo FG? La tua animazione è solo esterna o anche interna? Forse bisogna vedere cosa succede attivando anche la GI e, di conseguenza, valutare le impostazioni per la Photon map e la distribuzione dei fotoni in scena emessi dalla daylight.

Share this post


Link to post
Share on other sites

Per il Gamma ti consiglio di leggerti un pò di discussioni sul forum (cerca anche con "Linear workflow").

Per le macchie, hai provato ad aumentare la frequenza del salvataggio della FG map? Ogni 25 frame mi sembra poco...

P.S. Stai usando solo FG? La tua animazione è solo esterna o anche interna? Forse bisogna vedere cosa succede attivando anche la GI e, di conseguenza, valutare le impostazioni per la Photon map e la distribuzione dei fotoni in scena emessi dalla daylight.

uso anche la GI

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x