Vai al contenuto
DiegoPennati

Vraydisplacementmod - Scelta Dello Split Method E Presenza Di Artefatti

Recommended Posts

Inviata (modificato)

Buongiorno a tutti ragazzi.

Sto lavorando ad un rendering di un esterno architettonico. Ho letto tutta la parte (tra l'altro molto ben curata) della guida di cecofuli sul modificatore displace di Vray, e sto provando ad utilizzarlo per creare dei mattoni faccia a vista.

Le mappe che ho usato per la creazione del materiale sono queste. Per non appesantire la pagina le ho unite e ridotte di dimensione. Per chi le volesse mi scriva pure in MP e gliele manderò subito.

Il risultato, applicato solo parzialmente e visto da vicino è questo:

E sembra funzionare. Il problema però mi salta fuori nel momento in cui inquadro da lontano l'edificio:

Mi compaiono tutta una serie di segni neri sulla muratura, che da vicino non esistono. Visto che la dimensione della triangolazione del displacement dipende dal punto di vista, ho ridotto la dimensione dell'edge length e riprovato. Sembra funzioni, ma i tempi di rendering si allungano notevolmente.

Poi ho provato questo:

Ho cambiato lo split method (che sicuramente come parametro è stato implementato dopo l'uscita del libro di cecofuli, perchè li non ne parla) in Binary. Stesso tempo di rendering, ma segni neri notevolmente ridotti (sempre presenti però).

Ora mi chiedo, come posso ottimizzare la mia scena secondo voi?

E poi una mia curiosità. Che differenza c'è tra lo split method "Quad" e lo split method "Binary"?

Grazie a tutti, e scusatemi se ho parlato troppo!


Modificato da nicolce

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ai moderatori: scusate, ho sbagliato a digitare il titolo, ho scritto "slit method" al posto di "split method". Se potete, correggetelo, altrimenti se qualcuno dovesse in futuro cercare "split method" non troverebbe niente.

grazie!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

i mattoni a vista vengono bene e piuttosto in fretta usando il 2d mapping invece del 3d. Però vorrei comunque capire che differenza c'è tra il metodo Quad e il metodo Binary...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Domattina provo e ti faccio sapere, nel frattempo ho notato che col 2D il displace crea delle fessure sugli spigoli, quindi se funzia come dici tu è molto meglio!

Grazie, a presto!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Quando lo inquadri da lontano spegni il displa e lasci solo bump, così elimini gli artefatti e riduci i tempi :)

Dovresti mixare le 2 mappe bump e displa che hai per ottenere il bump da usare da lontano...

Ciao


Modificato da nicolce

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

è una buona idea, però devo modificare leggermente la geometria, perchè anche se sono lontano si nota che i mattoni sono sullo stesso piano dell'intonaco.

Provo e posto!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Si comunque di solito per i mattoni facciavista non uso mai il displace a meno che non siano proprio in primo piano.

Oltre a dare la mappa diffuse e bump del mattone dovresti mixarle anche con altre mappe, magari per rendere più rugoso il mattone potresti mixare il bump con un concrete tosto, ti assicuro che funziona, ho appena fatto un lavoro ed ho ottenuto dei mattoni facciavista discreti...

Magari prova ad abbassare anche il blur delle mappe, ma tutto dipende dalla vista che hai, magari posta uno screen della vista definitiva e si vede un pò.

Se il displacement 2D ti fa andare lento il calcolo significa che non hai attivato la memoria dinamica col tuo corrispettivo di ram, prova e vedrai che ti scheggia il render, imposta nel memory limit in system la dynamic memory e se hai 4 Gb di ram metti 4096 come valore, 8 Gb metti 8192 e così via, spero di esserti servito a qualcosa, ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ora sono in università col portatile, quindi non posso provare. Stasera ci provo e ti faccio sapere. Devo impostare anche il "Dynamic" o lascio l'"Auto"?

Nel frattempo ti ho dato un punto, mi hai tolto da un po di casini. Domani torno a metterlo anche a nicolce.

Grazie ad entrambi!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×