Vai al contenuto
cpk

Maya Batchrender Mentalray

Recommended Posts

Ciao a tutti. :D

In una scena, quando faccio partire la batchrender con mentalray questa

si avvia senza dare errori e genera (in pochi secondi) un solo frame incompleto

quando invece dovrebbe impiagare circa 40 min a frame.... allego il rapporto del mayaRenderLog.txt

qualcuno sa cosa può dipendere? :wacko: (il renderdiagnostic non mi da nessun errore)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

i frame di partenza e destinazione sono impostati correttamente.. ho pravato anche con le impoastazioni di default di mentalray... sempre stesso risulto... scrive solo il frame temporaneo e poi si blocca :( .... pensando che potesse dipendere dalle impostazioni della camera le ho eliminate tutte e ne ho creata una nuova l'unica "renderezzabile".... stessa storia :mellow:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Il file di log è corretto,

Ma perchè x generare l'immagine dovrebbe metterci tutto il tempo che dici, la scena è molto complessa?

Dal log risulta che hai impostato una qualita bassa e non usi GI ne FG.

Se magri posti uno scrrenshot delle impostazioni del renderglobal ed una descrizione della scena sarà piu facile capire.

Ma che risoluzione hai usato e sopratutto in traslation hai impostato progress message o qualcosa per geneare un log dettagliato? (anche se mi sembra di si).

:wacko:

Spero di riuscirti a dare una mano. :D

Alessandro

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

sinceramente e' una cosa strana!

cmq... secondo me, semplice opinione, c'è qualcosa che hai inserito nella scena che va in conflitto con mr e lo impalla e non dipende quindi dal settaggio del render global.

magari dacci un po piu di dettagli sulla scena

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ok ragazzi... prima di tutto grazie per la disponibilita... spero in futuro di poter fare altrettanto. La scena rappesenta una visualizzazione architettonica pesantina in termini di poligoni che renderizzo in circa 1 con le

seguenti impostazioni: FG 1000; GI 1500; samples min 2 max 4

nella scena è presente una sola sorgente luminosa spot diretta su di una sfera nurbs (invisibile e con disabilite le opzioni render states "casts shadows", "receive shadows","visible in reflactions", "visible in refractions), di colore celeste, che

simula la luce solare.

Esternamente a questa ne è presente un altra di sfera nurbs, di diamentro maggiore e quindi non colpita dallo spot, sulla quale è applicata semplicemente una texture rappresentante il cielo del canale "incandescienza".... questo tipo di configurazione l'ho usata altre per simulare la luce solare e non ho mai avuto problemi...

Punto1: anche se imposto FG e GI nella batch li trovo disabilitati.... non si capiosce perchè (?)

Punto2:anche se imposto "detailed message" in traslation di render global settigs la batch mi da semprte le stesse informazioni....


Modificato da cpk

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Mi Sembra tutto ok,

Comunque prova a fare delle prove escludendo vari oggetti, magari capisci cosè che fa casino.

Puoi anche provare ad avviare il bathcrender da linea di comando (tipo dos) ed impostare da li i parametri del render global, ora non so dirti bene i comandi ma nella doc di May è spiegato in modo chiaro. Mi sembra che il tuo problema sia proprio questo visto che la scenda l'hai renderizz (quella l'hai rend normalmente in maya?).

Ma se provi con un'altra scena Maya ti da lo stesso questo problema o lo fa solo con questa scena?

Puoi anche provare ad aprire una nuova scena vuota ed importare la precedente (prova a mettere la luce e le sfere in questa nuova scena, la precedente esportala senza le luci).

Una curiosità, ho letto su un tutorial che per velocizzare il rendering tenendo una lata qualità è meglio provare ad aumentare prima il contrast treshold e poi il Sample level, i due parametri influenzano il rendering in modo diverso, ma se provi ad esempi ad usare il contrast a 0.05 anziche a 0.1 e il sampling a 0 2 oppure 1 3 anziche 2 4 dovresti ottenere all'incirca la stessa cosa con tempi molto meno protratti.

Da quando ho adottato questa tecnica vado molto + veloce.

Attenzione, fai comunque delle prove e non scendere mai sotto lo 0.05 per il contrast, ancora non ho fatto prove con valori + bassi ma il tutorial che ho letto diceva chiaramente che con valori + bassi non ci sono miglioramenti. ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

pantich78: il problema è solo in questa scena le altre me le renderizza normalmente... nel fine settimana avevo già provato ad esportare (comprese le texture) tutti i poligoni e ad importarli in una nuova scena ricreando poi l'environment sky... nulla da fare... stesso risultato a questo punto il problema protrebbe essere causato dalle texture (anche se è strano che il render diagnostic non da errori).

La bathcrender dalla linea di comando la utilizzavo con maya4.5 adesso con la 6 funziona un pò diversamente quindi non ho potuto fare ancora questa prova... ci proverò comunque.

sono molto curioso di provare le impostazioni di "contrast treshold" come mi hai suggerito B) grazie per la dritta.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Il giallo si infittisce, sinceramente non mi vengono altre idee,

fammi sapere come va con le impostazioni ;)

Un'altra curiosità, come mai usi una sfera interna per simulare il sole? non ti bastano una luce arancio che spara fotoni ed una sfera esterna x simulare il cielo?

Non ho mai pensato a questa soluzione, ma non ti diventa tutto troppo dominato dal colore della sfera interna?

Alessandro

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

pantich78: ho appreso questa tecnica da un tutorial

.... mi spiego meglio ... la prima sfera quella più piccola simula la luce di colore blu diffusa dal cielo ed illumina solo leggermente gli oggetti presenti nella scena, lo spot (ad esempio colore giallo chiaro per la mattina e giallo scuro per la sera) invece simula i raggi del sole mettendo in evidenza il contrasto tra le zone in luce e quelle in ombra (per schiarire/scurire le zone in obra basta diminure/aumentare il valore di exponent dello spot).

Posto il file .mb che mi sono preparato con le impostazioni di partenza per scene all'aperto :) dagli un occhiata... nota che l'attributo decay rate dello spot è impostato a "NO DECAY" (tipicamente in una scena al chiuso questo deve

essere impostato a quadratic.... come è poi nella realtà).

cristiano

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Perfetto, scusa non avevo capito, quindi la sfera esterna la usi solo per far rimbalzare i fotoni.

Pensavo che la sfare interna la usassi x emettere luce arancio tipo sole, percio non capivo. :P

Io uso una tecnica simile x gli esterni, una grande sfera azzurra x il cielo ed all'interno uno spot color sole con fotoni e final gatering ^_^

Comunque do un'occhiata alla tua scena, grazie,

Alessandro

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×