Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Eidolon64

Problema Con Smooth Preview E Mentalray In Maya 2009

Recommended Posts

Salve a tutti ho un problema molto strano con maya.

Uso la versione 2009, quindi mental ray è in grado di renderizzare la smooth preview di una mesh poligonale (per intenderci dopo aver premuto il tasto 3), senza bisogno di suddividere effettivamente.

Il problema è che con un semplice personaggio riggato a skinnato (smooth binding) capita questo:

La mesh ha la smoothing preview e non ha alcun problema, poi muovo il rig per cambiarle posizione e guardate cosa succede all'articolazione del ginocchio (gamba destra)

schermata20091214a22132.jpg

Visto quell'ombra scura? Prima del movimento non c'era.

Il bello è che se, SENZA MUOVERE ULTERIORMENTE LA MSH, premo 1 e disattivo l'anteprima di smooth..

schermata20091214a22134.jpg

..e poi ripremo 3 per riattivarla..

schermata20091214a22135.jpg

..tutto torna a posto, senza aver toccato nulla!! E questo me lo fa ogni volta che muovo qualcosa del modello..

Ho pensato fosse un problema di openGL o comunque di rendering della viewport, ma anche quando renderizzo con mentalray si comporta alo stesso modo!

In rete non ho trovato nessun cenno a questo problema, qualcuno mi sa dare una spiegazione?

Non voglio essere costretto a suddividere tutti i personaggi, perchè ormai ho una pipeline stabilita..

Per la cronaca, sono su macbook pro con Snow Leopard (so che osx 10.6 ha qualche problema di visualizzazione in viewport, ma mentalray non dovrebbe avere problemi)

Share this post


Link to post
Share on other sites

se mental ray tira fuori il problema può essere un problema di normali che se è vero che in smooth sembra un buon modello, ha in realtà un hard edge troppo forte. Potresti dare un normal angle diverso o un soft edge, ma rivedrei certe parti, che sono evidenti.

Di più, posso solo provare a ricreare la situazione che ha il tuo modello ma ad occhio è un po difficile.


Edited by ytsejam

Share this post


Link to post
Share on other sites
se mental ray tira fuori il problema può essere un problema di normali che se è vero che in smooth sembra un buon modello, ha in realtà un hard edge troppo forte. Potresti dare un normal angle diverso o un soft edge, ma rivedrei certe parti, che sono evidenti.

Di più, posso solo provare a ricreare la situazione che ha il tuo modello ma ad occhio è un po difficile.

Anch'io ho pensato fosse un problema di normali, ma il fatto è che se disattivo e subito dopo riattivo lo smooth torna tutto a posto.. è come se dopo il movimento maya si "dimenticasse" di riaggiustare le normali e avesse bisogno di una sorta di refresh.. Poi il problema si verifica in ogni parte del modello, ovunque ci sia una giuntura...

cosa in intendi per "rivedrei certe parti, che sono evidenti"?

grazie comunque! :D

Share this post


Link to post
Share on other sites
cosa in intendi per "rivedrei certe parti, che sono evidenti"?

grazie comunque! :D

hardedges troppo evidenti.

cmq, posso provare, anche se il mio limite è l'animazione di personaggi. A proposito devo tornare agli studi. :)

Share this post


Link to post
Share on other sites

ciao

se posso darti un consiglio, non c'è bisogno di smuttare la mesh per renderizzarla, puoi andare su menu/window-Rendering Editor-Mental Ray-approximation edit

Subdivision (derive from maya) Create

puoi anche segliere se applicare la suddivisione singola o multipla

questo comando fa in modo che mental ray renderizza direttamente in subdivision, senza bisogno di smuttare.

ciao


Edited by Pizzetto25

Share this post


Link to post
Share on other sites
ciao

se posso darti un consiglio, non c'è bisogno di smuttare la mesh per renderizzarla, puoi andare su menu/window-Rendering Editor-Mental Ray-approximation edit

Subdivision (derive from maya) Create

puoi anche segliere se applicare la suddivisione singola o multipla

questo comando fa in modo che mental ray renderizza direttamente in subdivision, senza bisogno di smuttare.

ciao

In pratica suddivide la mesh al momento del rendering quindi? Appena posso provo, grazie mille del consiglio, mi sto avvicnando a Maya da poco ;)

Share this post


Link to post
Share on other sites
ciao

se posso darti un consiglio, non c'è bisogno di smuttare la mesh per renderizzarla, puoi andare su menu/window-Rendering Editor-Mental Ray-approximation edit

Subdivision (derive from maya) Create

puoi anche segliere se applicare la suddivisione singola o multipla

questo comando fa in modo che mental ray renderizza direttamente in subdivision, senza bisogno di smuttare.

ciao

Problema risolto grazie al tuo consiglio, thanks!

Però lo strano comportamento della smooth preview rimane... boh, misteri di maya! :blink:

Share this post


Link to post
Share on other sites
Problema risolto grazie al tuo consiglio, thanks!

Però lo strano comportamento della smooth preview rimane... boh, misteri di maya! :blink:

se è quello il problema allora è perchè la ccmesh attribuite in smooth preview per il rendering in mental ray, da questi problemi. Cmq hai risolto grazie a pizzetto. Bien

ciao

Share this post


Link to post
Share on other sites
se è quello il problema allora è perchè la ccmesh attribuite in smooth preview per il rendering in mental ray, da questi problemi. Cmq hai risolto grazie a pizzetto. Bien

ciao

Ah, allora è proprio un difetto "ufficiale", pensavo che solo a me capitasse.. In effetti probabilmente si chiama "preview" per un motivo :P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x