Vai al contenuto
HiRes

Mancanza Di Dithering Su Tinte Piatte

Recommended Posts

premetto che mi sono spulciato un po di pagine qui e anche le caratteristiche del mio monitor...

ho notato un problema che si può vedere anche sull'immagine della batteria. praticamente utilizzando solo tinte piatte nel canale diffuse, nella resa finale ci sono delle evidenti bande di colore che non dovrebbero esserci. ora non posso postare nessun esempio ne andare a controllare eventuali settaggi.

flavio masi, sempre nel final della batteria mi aveva suggerito di applicare un noise al diffuse. in parte ha funzionato, ma solo in parte...

voi avete suggerimenti/soluzioni?

tenchiù veri mach :D

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Guest KILLOW   
Guest KILLOW

Ma dipendono dallo schermo o dal software?Le linee sono sempre nello stesso posto o se muovi la finestra prima del render successivo cambiano all'interno dell'immagine?Se stampi il render le linee ci sono?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ma dipendono dallo schermo o dal software?Le linee sono sempre nello stesso posto o se muovi la finestra prima del render successivo cambiano all'interno dell'immagine?Se stampi il render le linee ci sono?

se vai al primo post del mio final c'è la prima immagine che ho postato (non è la stessa che sta in gallery). sopra i piatti puoi tranquillamente vedere di che si tratta. non credo dipenda dal monitor.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
se vai al primo post del mio final c'è la prima immagine che ho postato (non è la stessa che sta in gallery). sopra i piatti puoi tranquillamente vedere di che si tratta. non credo dipenda dal monitor.

Certamente non dipende dal monitor. Personalmente, oltre a introdurre delle microvariazioni di colore o a utilizzare un leggero bump, non ho trovato altre soluzioni, anche perchè i rimedi di cui sopra hanno risolto. Il "problema" comunque si presenta spesso, soprattutto in previsione di compressioni video.

Ciao

Flavio

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Certamente non dipende dal monitor. Personalmente, oltre a introdurre delle microvariazioni di colore o a utilizzare un leggero bump, non ho trovato altre soluzioni, anche perchè i rimedi di cui sopra hanno risolto. Il "problema" comunque si presenta spesso, soprattutto in previsione di compressioni video.

un faro nel mare in tempesta.... ;)

a questo punto ti chiedo come setti il noise. sia come variazione di colore:

tonalità vicine o opposte

che come dimensioni:

size e tiling.

grazie flavio. ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Io giuro che non capisco di quale artefatto stiate parlando. Giuro, non lo vedo. (fai un disegnino?) :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

se vai nel mio final non nella gallery eh!? :D clicca proprio sulla prima immagine che ho postato, ingrandiscila e guarda sopra lo splash (il piatto piccolo) vedrai delle bande nette. devi vederle...per forza... ;)


Modificato da HiRes

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ehehe, si è da quando hai postato questa discussione che cerco l'artefatto. C'è poco da fare non capisco a cosa ti stia riferendo. Io vedo un inscurimento del piatto e dietro la batteria un problema di compressione dell'immagine, ma nient'altro. Scusami, ma veramente, non lo trovo. :(<_<:huh:^_^

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
...e dietro la batteria un problema di compressione dell'immagine...

esattamente quello! che è presente anche nel tiff. e c'è anche nelle rese di test sul vfb, soprattutto se uso una tonalità di grigio scuro con le luci che ci vanno a sfumare sopra. si notano le stesse bande nonostante il dithering sia attivo.

:)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ecco. Ok, mai successo, salvi in tiff compresso? qualche screen del save output? Succede, ma è un problema riferito al gamma e lamberthian Material, ma di solito accade a noi utenti maya che amiamo :( smanettare con i settaggi. Indagherò

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
un faro nel mare in tempesta.... ;)

Notte fonda, altro che faro...

Purtroppo non ci sono parametri buoni per tutti i casi, al contrario. Qui sotto si dovrebbe vedere la posterizzazione. A me sembra evidente, in effetti:

Posterizzazione.png

Qui sotto, invece, il problema dovrebbe essere parzialmente risolto:

dithering.png

In questo caso ho messo nel diffuse una mappa falloff/distance blend con due mappe noise (di colore bianco e grigetto) di dimensioni diverse, ovviamente il noise più piccolo (0.02) è quello vicino alla camera, l'altro è pari a 0.22 - ma sono valori relativi, ovviamente.

Ciao

Flavio

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Guest KILLOW   
Guest KILLOW

Forse dalle due immagini postate da Flavio ho capito il problema (alla buon'ora ).Premesso che con fotoshop si possa correggere con un filtro sfoca,non si puo' far nulla con l'antialising?Se usi MR aumenta i valori di samples per pixel,metti un filtro mitchell e vedi cosa accade (di sicuro l'aumento del tempo di rendering :wallbash: ). :hello:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Premesso che con fotoshop si possa correggere...

Dici? Provaci, l'immagine è una normale raster a 24-bit con compressione senza perdita quindi puoi fare tutte le prove che vuoi. Il motore usato è mental ray con, oltre ad uno skylight che schiarisce uniformemente il piano renderizzato, una omni, con decadimento inverso, che innesca la posterizzazione. Secondo me non è semplice rimediare in post. Comunque l'esempio è estremizzato, in realtà effetti simili non si verificano mai, o quasi. Problemi di posterizzazione più contenuti sono invece frequenti, nella mia modesta esperienza.

Ciao

Flavio

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Forse dalle due immagini postate da Flavio ho capito il problema (alla buon'ora ).Premesso che con fotoshop si possa correggere con un filtro sfoca,non si puo' far nulla con l'antialising?Se usi MR aumenta i valori di samples per pixel,metti un filtro mitchell e vedi cosa accade (di sicuro l'aumento del tempo di rendering :wallbash: ). :hello:

sempre facendo riferimento alla mia immagine, l'antialiasing era a 4-16 mitchell 4-4 con lo spatial contrast a 0,03.

fare le correzioni in PS diverrebbe un lavorone e, come dice Flavio, non è detto che riesci a risolvere.

@ytsejam

il problema in realtà non è tanto il formato in cui salvo perchè il fenomeno si presenta già prima...

@flavio

preso appunto del tuo esperimento.

grazie ancora :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Guest KILLOW   
Guest KILLOW

Strano ma vero,credo di esserci riuscito semplicemente con il filtro sfocatura media,praticamente ha fatto tutto da solo B) .Adesso bisognerebbe provare a fare qualcosa con 3ds max pero' <_< .Ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

guarda, l'unico passaggio che mi viene in mente per farlo in post produzione è quello di salvarsi il canale alfa della scena senza ovviamente lo sfondo in modo che hai la maschera già bella e pronta.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Secondo me non è possibile evitarlo in certe circostanza, è dovuto alla scarsa profondità delle immagini 8 bit.

Se la sfumatura è troppo graduale si vedranno i settori di colore.

Una soluzione può essere salvare formati a 16 o 32bit. però vale solo per la stampa, gli schermi sono tutti 8bit e vedremo lo stesso difetto.

La soluzione del noise funziona, in generale qualsiasi tipo di texture attenua il difetto, volendo si può aggiungere anche del noise in post, insomma, nascondiamo un difetto con un'altro :D

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Strano ma vero,credo di esserci riuscito semplicemente con il filtro sfocatura media,praticamente ha fatto tutto da solo

Compresa la rimozione di quel minimo di informazioni che conteneva l'immagine: già era piatta, dopo il tuo intervento e scomparso quasi tutto.

Secondo me non è possibile evitarlo in certe circostanza, è dovuto alla scarsa profondità delle immagini 8 bit.

Se la sfumatura è troppo graduale si vedranno i settori di colore.

Sono d'accordo. Dubito, invece, che immagini a 16 o 32bit per canale aiutino in stampa. Qual'è quel dispositivo, di comune utilizzo, che si giova anche "solo" dei 16 bit?

Ciao

Flavio

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×