Vai al contenuto
Throughput

Macchie Nere Nel Rendering

Recommended Posts

Ciao a tutti,

Durante il rendering con mental ray, vengono fuori delle macchie che non riesco ad eliminare, qualche idea?

renderingproblema.th.png

Grazie

prova con olio di gomito, se neanche così vengono via le macchie allora ti consiglio di dare più informazioni sulla scena che stai svolgendo


Modificato da Mark83

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Il rendering riguarda un muro in pietra, con all'interno dei piccoli incassi ad arco (navate). Usando l'editor dei materiali ho applicato "ProMaterial: Stone". Poi l'ho tolto. In entrambi i casi il problema è sempre presente.

Per creare il muro ho usato l'oggetto di tipo proboolean.

Quello che mi chiedo è perchè prima il rendering funzionava e adesso non funziona più?

Quello che ho provato a fare è inserire una texture sul muro (quando ho provato con il ProMaterial: stone) che subito dopo ho rimosso, da quel momento è sorto il problema.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Risolto! Ho provato ad impostare un altro materiale, poi l'ho rimosso ed è andato bene. Adesso il rendering non visualizza più quelle macchie che in fin dei conti erano delle ombre. La cosa strana è che avevo già provato ad impostare un altro materiale e ad eliminarlo, per questo pensavo che si trattasse di qualche problema di configurazione del motore di rendering. Per qualche motivo, prima non ha funzionato <_<

Adesso devo cercare di applicare una texture che riproduca un muro di blocchi di tufo. Se avete qualche link sotto mano vi ringrazio.

P.S.: Spero di non essere off-topic con le ultime due righe ^_^

Grazie comunque per essere intervenuti.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Adesso devo cercare di applicare una texture che riproduca un muro di blocchi di tufo. Se avete qualche link sotto mano vi ringrazio

Grazie comunque per essere intervenuti.

ma prima di metterti a maneggiare un software da 5000 euro, hai aperto almeno una volta il manuale? che link ti dovremmo passare per mettere una texture... :blink2:

Vabbè oggi sono buono

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
ma prima di metterti a maneggiare un software da 5000 euro, hai aperto almeno una volta il manuale? che link ti dovremmo passare per mettere una texture... :blink2:

Vabbè oggi sono buono

Mi spiego meglio: il fatto di chiamare texture un'immagine da applicare per fare il muro, è un vizio che ho preso in precedenza, seguendo alcuni tutorial in cui veniva utilizzata una bitmap.

Dal menù Materials, utilizzando "ProMaterial:Stone" riesco a creare un muro. Successivamente, stavo pensando di usare una bitmap dal Material/Map browser per creare "l'effetto tufo", per questo chiedevo qualche link. Ok?

E' impensabile pretendere di utilizzare 3ds Max senza aver letto prima un manuale. Personalmente ho utilizzato il manuale raggiungibile con il tasto F1 + Tutorials. Il link che hai passato l'ho visto però ho preferito il manuale incorporato nel software.


Modificato da Throughput

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

senza entrare in polemiche a me sembra tanto che il problema nel tuo caso fosse dato dal non lavorare in scala o nell'avere le uv del tuo muro sballate...

quelle macchie nere secondo me non sono altro che i rilievi del prometarial fuori scala...

prova assegnando alla geometria un modoficatore uvwmapping, settato su box, assegnado la stessa misura per tutti i lati in modo da ottenere una mappatura uguale su tutti i lati...

oppure clicca direttamente su use real word scale semp're nel modificatore in modo da scalare la texture alle reali dimensioni del tuo oggetto che spero sia stato modellato in scala...

per il resto...

buon lavoro! :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

invece entrando in polemiche direi che sia guardando il manuale di 3ds, sia la guida in linea, sia i tutorial in rete, l'uv map è uno degli argomenti maggiormente trattati su tutti e 3 questi canali...

quindi, o c'è stato uno studio molto sommario (sfogliare il manuale guardando solo le figure), oppure nemmeno quello.

Senza stare ad indagare se il sw sia licenziato o no, direi che in ogni caso, leggere 2 testi sia meglio che intuire da una figura

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
senza entrare in polemiche a me sembra tanto che il problema nel tuo caso fosse dato dal non lavorare in scala o nell'avere le uv del tuo muro sballate...

quelle macchie nere secondo me non sono altro che i rilievi del prometarial fuori scala...

prova assegnando alla geometria un modoficatore uvwmapping, settato su box, assegnado la stessa misura per tutti i lati in modo da ottenere una mappatura uguale su tutti i lati...

oppure clicca direttamente su use real word scale semp're nel modificatore in modo da scalare la texture alle reali dimensioni del tuo oggetto che spero sia stato modellato in scala...

per il resto...

buon lavoro! :)

Tranquillo, non intendo assolutamente fare polemica :)

Ci tenevo a chiarire per evitare di esser preso per uno che viene a chiedere senza aver provato le diverse soluzioni o cercato tra i tutorial/help di 3ds max.

UVW Mapping lo avevo già provato, optando anche per il box e use Real-World Map Size. Ho riprovato in questo momento ed è andato bene. Forse ho sbagliato qualcosa in precedenza.

Grazie mille :)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×