Jump to content
chaosphere

Semplice Foro Su Una Superficie Triangolare

Recommended Posts

Salve a tutti, è da un bel po' che vi seguo in sordina e faccio i miei complimenti ai tanti che si sbattono per condividere quello che col sudore ed una buona dose di bestemmie hanno imparato... da buon nubbioso inauguro questo mio primo post con un quesito su Rhino che definire stupido è già tanto. Ho provato a cercar qualcosa di simile al mio problema sul forum ma senza risultato... anche se a esser sinceri non è che abbia spulciato granchè ed il "Cerca nel forum" non riesco proprio ad usarlo... non vi arrabbiate :crying:

Come da titolo dovrei forare una superficie triangolare con un banalissimo foro... talmente banale come da sottotitolo che non ci riesco affatto. :angry:

Ho disegnato il profilo con una polilinea e un cerchio per il foro ma quando seleziono il tutto e vado ad estrudere, il foro me lo lascia pieno... ho provato in tutti i modi che conosco, e quindi pochi a dir la verità... ed il bello è che se invece parto da un piano in tutte le soluzioni ci riesco, e il foro me lo fa... boh... allego un'immagine per chiarirvi meglio il problema:

rhino_10.gif

Per ora ho risolto scomponendo il triangolo in tre parti: un quadrato che contiene il foro e due triangoli per gli spigoli e ho poi unito il tutto... a mali estremi... ma... c'è qualcosa che ignoro perchè sono ignorante o che imbello perchè sono imbecille??! Ringrazio intanto la buona anima che avrà voglia di spender due parole su sta cacchiata...

Saluti a tutti

Share this post


Link to post
Share on other sites

al momento non saprei darti una spiegazione logica alla diversità di comportamento. ma sappi (se già non lo sai) che puoi anche procedere in modi diversi per ottenere lo stesso risultato:

1) estrudi la superficie senza il foro, crei un cilindro e applichi la sottrazione booleana.

2) estrudi, fai un trim (mi pare sia questo il comando) usando il cerchio come riferimento e poi creerai una superficie di congiunzione tra i due bordi.

3) proietti il cerchio sulla superficie (metodo superfluo su quelle piane) e poi operi come nel punto 2.

4)...non mi viene in mente ma forse sono finite le possibilità...:D :D

Share this post


Link to post
Share on other sites

Ciao, è successa la stessa cosa anche a me l'altro giorno, è solamente un problema di visualizzazione poichè il foro fisicamente c'è ma tu continui a vedere comunque la parte di superficie che non dovrebbe esserci. Io ho risolto cambiando le impostazione delle mesh, ti allego le impostazioni che utilizzo io di solito per i miei "esperimenti", spero possano risolvere il tuo problema...

Share this post


Link to post
Share on other sites

Non si fora il triangolo.

Il quadrato sì,un triangolo con un lato curvo si fora,superfici tonde si forano....tutte tranne il triangolo.

Fai così: costruisci il triangolo con una polilinea chiusa e raccorda uno spigolo con raggio 0.04 (non di meno)..praticamente invisibile.

Dopo puoi fare ciò che vuoi l'importante è che non sia un triangolo con 3 lati..ahahahah

Aggiungo che se pieghi un po' la superficie triangolare il triangolo si fora senza doverlo raccordare.

Se invece non hai tempo per giocarci....ricostruisci la superficie triangolare e poi fai ciò che devi.


Edited by GUESTOLDO

Share this post


Link to post
Share on other sites

Grazie ragazzi, allora...

per HiRes e algosuk:

Si, foro e triangoli sono complanari, e le avevo provate un po' tutte, partendo dalla sola superficie, trimma, splitta, dal solido e via di booleane, con i vari comandi del sottopannello Holes del pannello Solid Editing specifico per i fori... ma niente...

per alx84:

Si, in effetti era questo il problema... :D Options-->Mesh-->Render mesh quality... ci avevo anche fatto un pensierino ma poi nn ho provato visto che di tutte quelle opzioni non ne conosco il significato, però oggi tentando sotto il tuo suggerimento e cambiando solo da "Jagged & faster" che è di default a "Custom", senza toccare nulla delle impostazioni sotto, il foro è magicamente comparso... però sparisce usando le tue di impostazioni, ed in particolare il parametro che lo rifà sparire è "Simple planes" (Semplifica piani).. sarebbero da capire meglio, ma per ora mi accontento :P anche perchè lasciando invariati i valori Custom le superfici curve poi perdono di qualità e precisione, mentre con i tuoi valori riprendono (almeno all'occhio) la qualità di "Jagged & faster"... vabbè... ecco l'immagine (tanto per sfizio :D ):

rhino_11.gif

Grazie di nuovo e saluti a tutti

Share this post


Link to post
Share on other sites

Sono contento che sia riuscito a risolvere, probabilmente le mie impostazioni non vanno bene perchè abbiamo 2 unità di misura e 2 tolleranze diverse nel file, quelle impostazioni vanno bere per file impostati per oggetti piccoli in millimetri con tolleranze di 0.001.

Buon lavoro.

Share this post


Link to post
Share on other sites

GUESTOLDO scusa non avevo visto la tua risposta, però mi sembra strano quello che dici e la tua procedura la trovo un po' troppo macchinosa per una semplice superficie triangolare, poi... dal basso della mia ignoranza mi chiedo... perchè non si può bucare una superficie a triangolo? alla fine sembrava essere solo un problema di impostazioni di visualizzazione delle mesh... anche se potrebbe far pensare il fatto che un'operazione così semplice abbia bisogno di "particolari" accorgimenti... ma visto che non ho particolari conoscenze in materia e molte cose le do per scontate o più frutto di un atteggiamento "plug&play" :P , se mi passate il termine, poi ci rimango un po' male se le cose non vanno come previsto...

alx84 siamo contenti in due allora :D però ho controllato le impostazioni del mio documento e le unità sono in millimetri con "Absolute tolerance" a 0.001 units, quindi le stesse... non saprei che dirti... boh... ah si... di nuovo grazie :D

Saluti

Share this post


Link to post
Share on other sites
GUESTOLDO scusa non avevo visto la tua risposta, però mi sembra strano quello che dici e la tua procedura la trovo un po' troppo macchinosa per una semplice superficie triangolare, poi... dal basso della mia ignoranza mi chiedo... perchè non si può bucare una superficie a triangolo? alla fine sembrava essere solo un problema di impostazioni di visualizzazione delle mesh... anche se potrebbe far pensare il fatto che un'operazione così semplice abbia bisogno di "particolari" accorgimenti... ma visto che non ho particolari conoscenze in materia e molte cose le do per scontate o più frutto di un atteggiamento "plug&play" :P , se mi passate il termine, poi ci rimango un po' male se le cose non vanno come previsto...

alx84 siamo contenti in due allora :D però ho controllato le impostazioni del mio documento e le unità sono in millimetri con "Absolute tolerance" a 0.001 units, quindi le stesse... non saprei che dirti... boh... ah si... di nuovo grazie :D

Saluti

Non è poi così macchinoso. I primi "suggerimenti" sono scherzosi....che senso ha deformare un triangolo per farci un buco?

Ma l'ultimo è una soluzione vera e veloce.

Ricostruire la superficie con numero di punti diverso permette di forarla tranquillamente.

Il motivo per cui non si fora un triangolo è sconosciuto anche a me e mi piacerebbe saperlo.

Ti dirò di più. Dopo un tentativo fallito di trimmata,senza annullare l'operazione,prova a ricostruire la superficie.

Il foro apparirà.

Ciao

'


Edited by GUESTOLDO

Share this post


Link to post
Share on other sites

per farla breve, senza cambiare molti parametri, nelle proprietà dell'oggetto togli la spunta da "semplifica piani".

voilà...(almeno a me funge anche con i settaggi iniziali)

ciao bbelli...:D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...