Jump to content
HiRes

Problema Di Fotoni?

Recommended Posts

set.jpg

ragazzi ho un problema che non riesco a risolvere:

sul lato sinistro dell'immagine si può vedere di cosa sto parlando.

presumo sia un problema di luce riflessa dai piatti anche perchè facendo un test senza questi il problema non si presenta.

ho provato veramente di tutto o quasi senza venirne a capo.

inizialmente ho aumentato i fotoni delle luci portandoli a 2.000.000 a luce (erano 4 in questa scena)

poi ho provato ad aumentare il max sample radius ma ho ottenuto solo un aumento di tempo.

ho combinato la GI con FG. nulla da fare.

ho aumentato la FG Quality del materiale della stanza.

ho aggiunto una luce per illuminare solamente la stanza.

ho anche visto vari tutorial dove, ovviamente, escono fuori risultati eccellenti senza nessun problema (a chi ha fatto il tutotial...)

aggiungo qualche dettaglio:

3ds max 2009

4 luci mrArea Spot poste ai 4 angoli (dall'alto verso il basso puntando verso il centro della batteria) con inverse square

serve altro?

insomma...è chiaro che mi sfugge qualcosa...COSA??? :wallbash:

grazie a tutti


Edited by HiRes

Share this post


Link to post
Share on other sites

L'immagine che hai postato, cosa utilizza, solo i fotoni o è quella con GI+FG?

Prova, con il FG, ad alzare il filter, teoricamente dovrebbe sistemare quel tipo di problemi.

Hai controllato che le non siano le geometrie ad avere qualche problema? Se hai detto che togliendo i piatti le cose funzionano, non è detto che sia un problema di geometria.

Altrimenti, la soluzione più stupida che mi viene in mente, se non devi fare un'animazione, è renderizzare l'immagine senza i piatti in maniera che hai lo sfondo bello pulito e poi compositare sopra le geometrie che danno problemi!

Share this post


Link to post
Share on other sites
L'immagine che hai postato, cosa utilizza, solo i fotoni o è quella con GI+FG?

non mi ricordo sinceramente...ma non fa molta differenza visto che sia combinata che separatamente ottengo sempre lo stesso problema...

Prova, con il FG, ad alzare il filter, teoricamente dovrebbe sistemare quel tipo di problemi.

intendi "interpolate fg point"? (ora non ho max sotto mano)

Hai controllato che le non siano le geometrie ad avere qualche problema? Se hai detto che togliendo i piatti le cose funzionano, non è detto che sia un problema di geometria.

se ti riferisci alla modellazione, non dovrebbero esserci problemi...controllerò per scrupolo...ma ho i miei dubbi...

altri tipi di problemi?

Altrimenti, la soluzione più stupida che mi viene in mente, se non devi fare un'animazione, è renderizzare l'immagine senza i piatti in maniera che hai lo sfondo bello pulito e poi compositare sopra le geometrie che danno problemi!

No! Non voglio!!! :D

Share this post


Link to post
Share on other sites

Ti ho chiesto se è quella con FG attivo proprio perché, utilizzando il Filter Size spesso quei problemi si risolvono!

In max non so come si chiami, in Softimage (e se non sbaglio anche in Maya) è il "Filter Size" attributo che, con la GI attiva cerca di limitare il problema che sembra stia riscontrando tu. Prova a metterlo a 1 o a 2.

Oltre che ai piatti, controlla anche la geometria che fa da sfondo, magari il problema è li. Fossi in te comunque mi concentrerei sui piatti o sullo shader dei piatti, se li togli ed è tutto ok tutto fa pensare che ci sia qualcosa li che non va. Prova a nasconderli uno a uno e vedi cosa succede.

Share this post


Link to post
Share on other sites

Ti sei dimenticato di dirci i settaggi di rays e fg point che stai usando sulla tua scena, come altri settaggi in generale, tipo reflection e refraction e depth del FG. Prova a usare una luce per volta e vedere se si presenta con una luce in particolare, molto probabilmente con quella più vicina. Cmq è inutile tirare a indovinare senza settaggi.

Ciao

Share this post


Link to post
Share on other sites

settings.jpg

questi sono i settaggi utilizzati per il render.

forse non si vede bene ma la freccia indica il problema prima indicato.

ho fatto delle modifiche aumentando i fotoni nelle luci (4.000.000 cad.), ho disattivato l'opzione FG Point Interpolation (vista da un tutorial) e aumentato i Rays per FG Point a 400 e interpolate over num. fg point a 40...

il risultato è stato decisamente miglore a discapito, ovviamente, dei tempi.

servono altre info?

se ci sono accorgimenti migliori non avete che da dirlo. :D


Edited by HiRes

Share this post


Link to post
Share on other sites

Non sono un esperto di Max ma vedendo le impostazioni direi che puoi settare anche due miliardi di fotoni per luce che non cambierà mai nulla, la GI è disattivata... =P

Visto che con quelle impostazioni stai usando il FG con multibounce togli il noise filtering se possibile, in teoria con il MB non devi usarlo...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...