Vai al contenuto

Recommended Posts

Ciao,

ho scaricato le versioni demo di rhino 4 più quella di vray 1.6 per provare a fare dei render, ma quando inizia il building light cache appare la finestra "runtime error! Program: C:/Prog/rhinoceros 4.0/system/rhino 4.exe" etc.

Il tutto è iniziato quando ho inserito e mappato delle texture...

il file pesa circa 130 mb, ho un portatile centrino (1,86) con scheda video nvidia geforce go 6600, ram 1,50gb...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

pardon, questo è il msg completo:

"Microsoft Visual C++ Runtime library

runtime error! Program: C:\Prog\Rhinoceros 4.0\System\Rhino4.exe

This application has requested the runtime to terminate it in an unusual way.

Please contact the application's support team for more information."

Ho contattato il newsgroup di rhino, loro dicono che è un problema di ram..

ma su un'altro pc con 512 di ram riesco a renderizzare file anche più grandi...

ho provato un salva ridotto (suggerimento dal newsgroup) e benchè le dimensioni si riducono un bel pò crasha comunque... anche con file da 30 mb..

ps: sui modelli non ho mesh.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
ho provato un salva ridotto (suggerimento dal newsgroup) e benchè le dimensioni si riducono un bel pò crasha comunque... anche con file da 30 mb..

ps: sui modelli non ho mesh.

ma il salva ridotto comprime solo il file mi pare una sciocchezza.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ma con altri file quindi riesci a renderizzare normalmente? :unsure:

comunque per capire se sia una questione di ram o meno basta che tu spenga i layer e inizi a renderizzare accendendoli uno ad uno progressivamente fino a quando incorri nel crash :D

inoltre per alleggerire il file può risultare utile il comando unisci in quanto il programma più lavora con polisuperfici meno intersezioni si trova a dover calcolare, quindi unire il possibile

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

alla fine ho risolto...

prima ho provato sul pc di un'amica con più ram, risultato: runtime error anche lì ma con la differenza che ora non si avvia più, mi sa che se n'è andata la scheda madre...

quindi mi sono ricontrollata livello per livello, cercando di alleggerire tutto con polyredu, plugin scaricato dal sito rhino3d..

ma siccome nella segnalazione errori mi dava bitmapbuffer.dll, nel dubbio ho resettato tutti i materiali e rimpostati dall'inizio.

poi, seguendo la guida di vray.it ho settato le opzioni delle mesh.

Non so alla fine dove stava l'errore, fatto sta che ora anche con un file da 90 mb riesce a fare i render....

solo che dopo 7 ore ancora stava all'inizio del rendering image...

ora mi cerco una guida su come velocizzare il render...

Grazie per i suggerimenti.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

sera gente !

sto usando la demo di Vray for rhino...per cominciare a renderizzare in modo dignitoso i miei lavori!

l ho studiato,letto la guida in inglese e ho tentato a renedrizzare una scena fatta da due calici e un fondale...e fin qui tutto oK!

Provo a dare in pasto a rhino un mio vecchio lavoro realizzato per l uni. qualche mese fa...

trattasi di una chiesa a tre navate,e un scalinata antistante...insomma un file abbastanza grosso!mando il render senza caricare la cartella dei materiali,e va senza alcun problema!

poco fa,esco dal dvd masterizzato a suo tempo,la cartella materiali,seguo il percorso suggeritomi da rhino e mando il render,per ottenere anche i materiali...

sorpresona!!!

popup alquanto minaccioso...crash di rhino e nessuna opzioni disponibile se non quella di killare dal task manager!

il popup è quello di questa discussione runtime error blablabla...preciso preciso!

mi chiedo:

possibile che Vray sia piu pensato a renderizzare scene non troppo complesse?o è un impostazione ostica del mio file?

o meglio,sembra che sia dovuto piu che altro all inserimento dei Jpeg rappresentanti i materiali per quella scena!


Modificato da AgesAndroS

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Buonasera!Leggendo il topic purtroppo anch'io ho lo stesso problema,cerchero di spiegarmi meglio anche se sono sicura che vi sembrarò confusa o ignorante riguardo alcune cose o definizioni etc...

Dunque io uso rhino SR5 e vray come motore di rendering,il mio pc ha una scheda grafica nvidiagforce gt220- 1024 mb e memoria ram 6gb ddr3,win 7-64bit,cpu intel core i3, spazio di 1 TB su hd

Veniamo al modello: ho modellato un 3d di un complesso di 3 edifici di 6 piani circa e ambientazione(marciapiedi,recinzione[ho messo la texture per evitare di appensatire il file],piante[texture],car)con la conseguenza di avere un file di circa 500 mb ed ovviamente mandando un render e...ta dan!!

"Microsoft Visual C++ Runtime library

runtime error! Program: C:\Prog\Rhinoceros 4.0\System\Rhino4.exe

This application has requested the runtime to terminate it in an unusual way.

Please contact the application's support team for more information."

ora mi è sembrato di capire che questo crash sia dovuto alla memoria della scheda grafica,quindi anche se aggiorno la SR di rhino non ottengo niente?in giro si parlava delle opzioni delle mesh da modificare ma ho trovato impostazioni diverse per ridurre la grandezza del file e fra l'altro ho provato a settare come suggerito qui

http://www.vraywiki.it/index.php/OutofMemory

è aumentato di pochi mb il file...deduco di aver sbagliato qualcosa,non avete voi dei valori esatti?.

Devo cambiarmi la scheda grafica?prendere una piu grande? scusate e grazie in anticipo

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

azz..non ricordavo di aver scritto anche qui di questo simpatico,fantasmagorico nonchè scocciantissimo problema legato a VRAY!e a quanto pare nessuno ha una precisa soluzione del problema,figurati che io ormai ci convivo!

noto con dispiacere che nonostante il Tuo HW sia ben carrozzato,il problema sussiste anche nel tuo caso!

io dalla mia esperienza,ti posso dire che non c ho capito una beneamata motosega di niente...non ho capito,ad oggi il perchè di questo popup,che rende rhino inutilizzabile,al punto che si deve necessariamente riavviarlo, visto il crash importante a cui va in contro!

l unica cosa certa,è che capita in modo randomico indipendentemente dalla grandezza del modello...sembra un problema legato a particolari tipi di texture,intendo l'estensione,ho fatto percio prove incrociate...e non ho visto una causa diretta....ho provato a cambiare dimensione alle texture e sembrava centrare qualcosa...piu piccole sono meglio è!ma anche qui sono stato smentito...perchè vedevo apparire il popop cornuto piu volte nonostante le modifiche e gli aggiustamenti( o presunti tali)alle mie texture!

una cosa è certa!capita caricando texture...

se vai di materiali con estensioni .vismat difficilmente ti verrà restituito quell'errore che ad oggi non ha una causa ben precisa!

cmq,500 MB di modello sono tanti anche per un carro armato...sfoltisci dove possibile,elimina gli elementi obsoleti e fai un bel purge!

PS:il mio rhino è SP8...quindi non centra nulla averlo aggiornato all ultimo SP!


Modificato da AgesAndroS

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

azz..non ricordavo di aver scritto anche qui di questo simpatico,fantasmagorico nonchè scocciantissimo problema legato a VRAY!e a quanto pare nessuno ha una precisa soluzione del problema,figurati che io ormai ci convivo!

noto con dispiacere che nonostante il Tuo HW sia ben carrozzato,il problema sussiste anche nel tuo caso!

io dalla mia esperienza,ti posso dire che non c ho capito una beneamata motosega di niente...non ho capito,ad oggi il perchè di questo popup,che rende rhino inutilizzabile,al punto che si deve necessariamente riavviarlo, visto il crash importante a cui va in contro!

l unica cosa certa,è che capita in modo randomico indipendentemente dalla grandezza del modello...sembra un problema legato a particolari tipi di texture,intendo l'estensione,ho fatto percio prove incrociate...e non ho visto una causa diretta....ho provato a cambiare dimensione alle texture e sembrava centrare qualcosa...piu piccole sono meglio è!ma anche qui sono stato smentito...perchè vedevo apparire il popop cornuto piu volte nonostante le modifiche e gli aggiustamenti( o presunti tali)alle mie texture!

una cosa è certa!capita caricando texture...

se vai di materiali con estensioni .vismat difficilmente ti verrà restituito quell'errore che ad oggi non ha una causa ben precisa!

cmq,500 MB di modello sono tanti anche per un carro armato...sfoltisci dove possibile,elimina gli elementi obsoleti e fai un bel purge!

PS:il mio rhino è SP8...quindi non centra nulla averlo aggiornato all ultimo SP!

Grazie quindi anche la roba delle mesh non centra?cioè i settaggi da opzioni?si le texture mi sn prodigata nel cercare texture di buona risoluzione per il modello ma adesso mi dici che devo ridefinirle...mmmm di eliminare ho eliminato alcune cose ma non ho idea che altro fare...quindi anche se mi comprassi una scheda grafica migliore il problema resterebbe?accidenti

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

il purge elimina tutto cio che è inutilizzato all interno del tuo modello,e quindi alleggerisce la tua scena della roba obsoleta ed inutile!

c è anche in autocad!

puoi raggiungerlo o scrivendo _purge e invio!

oppure dal menu strumenti-->utility per i file-->elimina blocchi e livelli non utilizzati


Modificato da AgesAndroS

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

il purge elimina tutto cio che è inutilizzato all interno del tuo modello,e quindi alleggerisce la tua scena della roba obsoleta ed inutile!

c è anche in autocad!

puoi raggiungerlo o scrivendo _purge e invio!

oppure dal menu strumenti-->utility per i file-->elimina blocchi e livelli non utilizzati

fatto! ma mi ha eliminato poco...comunque grazie ancora:)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

http://www.treddi.com/forum/topic/83868-vray-for-rhinoceros-4/page__p__802172#entry802172

se ti interessa qui c è una discussione aperta da me,in tempi non sospetti che pero non ha portato a nulla!

ho pure fatto un giro sul forum dedicato a Vray for rhinoceros!

e quello che si desume,ma non è affatto la soluzione è di aggiroanre i driver video(i miei sono gli ultimi disponibili) e di aggironare rhino all'ultimo SP...ma anche qui non centra nulla!

cmq,sicuramente centra il fatto che il modello è troppo esageratamente grande...

l unica cosa che ti posso suggerire è che in genere con XP va meglio!

se usi vista\seven,ti posso suggerire di aprire rhino spuntando l opzione compatibilità Xp sp3,tramite tasto DX sull'icona e poi proprieta!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

http://www.treddi.com/forum/topic/83868-vray-for-rhinoceros-4/page__p__802172#entry802172

se ti interessa qui c è una discussione aperta da me,in tempi non sospetti che pero non ha portato a nulla!

ho pure fatto un giro sul forum dedicato a Vray for rhinoceros!

e quello che si desume,ma non è affatto la soluzione è di aggiroanre i driver video(i miei sono gli ultimi disponibili) e di aggironare rhino all'ultimo SP...ma anche qui non centra nulla!

cmq,sicuramente centra il fatto che il modello è troppo esageratamente grande...

l unica cosa che ti posso suggerire è che in genere con XP va meglio!

se usi vista\seven,ti posso suggerire di aprire rhino spuntando l opzione compatibilità Xp sp3,tramite tasto DX sull'icona e poi proprieta!

fatto...è ancora piu instabile,come si ritorna indietro?cioè all'opzione di prima di win xp?

ok sono ritornata alle impostazioni di prima...quelo che non capisco è perchè mettendo i parametri delle mesh piu bassi(seguendo il link di vray wiki o minori poligoni )mi aumenta la dimensione del file!mi sembra di ricordare una idiscussione o proprio su quel link c'era spiegato che si diminuiva la grandezza del file con quel metodo,mah


Modificato da saha

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ok sono ritornata alle impostazioni di prima...quelo che non capisco è perchè mettendo i parametri delle mesh piu bassi(seguendo il link di vray wiki o minori poligoni )mi aumenta la dimensione del file!mi sembra di ricordare una idiscussione o proprio su quel link c'era spiegato che si diminuiva la grandezza del file con quel metodo,mah

in effetti è strano

magari posta uno screen del modello.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

capisco daltronde non credo di poter aiutare colleghi concorrenti....:devil:

ma dai sono una cacchetta rispetto ai lavori che vedo postati su questo forum:P :crying: putroppo è la gavetta infinita(si sa che in italia è cosi)

sto apsettando il tecnico ma penso che anche lui non mi risolverà la questione...quindi anche se chiedo di cambiarmi la scheda video con una piu potente(prezzo permettendo)ci sarà lo stesso intoppo?comunque graize ancora...mi rendo conto che è difficile aiutare con questi mezzi,apprezzo lo sforzo :blush:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

il tecnico di cosa?

informatico?quello non ha cosa consigliare difronte a questo specifico problema!

piu che altro si dovrebbe chiamare l'assistenza tecnica di chi ha creato il programma per rhino!runtimeerror60952_7.jpg

cmq, l errore è questo!!!

c è chi dice che è un problema di ram(insufficiente)chi dice che è colpa della scheda video

l unica certezza è che si deve ottimizzare il modello...

almeno flamingo quando le risorse di esaurivano,faceva apparire un messaggio meno vago di questo ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×