Jump to content
Arcy79

Maledetti Puntini Bianchi!

Recommended Posts

Seguendo il consiglio di molti di voi e cioè quello di smanettare parecchio per capire il funzionamento delle varie opzioni di MR, mi sono ritrovato anche io nelle mie ultime renderizzazioni con la comparsa dei fastidiosissimi puntini bianchi. Ho notao che la loro presenza è molto più cospicua sui materiale con un elevato glossy. Di seguito posto due render 800x600 di cui il secondo lcon FG al doppio. Anche qui mi ritrovo in quello lanciato al doppio un aumento dei puntini bianchi.Avete consigli da fornirmi?

tets15.jpg

con FG al doppio............

test16b.jpg

Share this post


Link to post
Share on other sites

mi intrufolo nella discussione senza avere una risposta...

a me succede la stessa cosa ma senza fare render con gi e fg... io ho aumentato il parametro di area light sampling (parametro proprio delle luci) a 1024 (valore massimo), ma riesco solamente a ridurre l'effetto ,ma non riesco a toglierlo del tutto.

Share this post


Link to post
Share on other sites

se il problema è solo sulle riflessioni dei materiali glossy (che tra l'altro richiedono tempo in render) forse ti converrebbe renderizzare un pass solo x le riflessioni di questi materiali azzerando il valore di glossy e utilizzando una texture di environment appositamente creata in photoshop... un fake x farla breve ^_^

Share this post


Link to post
Share on other sites

Per ridurre il glossy artifacts, dimmi che parametri hai utilizzato per i materiali glossy, posta uno screenshots?

Hai qualche light con visible shape, dietro la camera?

Share this post


Link to post
Share on other sites

buongiorno a tutti.

io quando mi è successo ho notato che i puntini apparivano dove c erano dei materiali A&D, ho tolto quei materiale e i puntini sono scomparsi. Capisco che può essere una soluzione nn prorpio ideale, ma ha funzionato. Qualche volta anche dei Fur possono dare di questi problemi.

:hello:

Share this post


Link to post
Share on other sites

Arcy79:

continuo nella discussione .. nella speranza di poter essere utile anche a te..

ytsejam:

questi sono i settaggi per i miei materiali e di fianco una piccola prova dove si può vedere il problema

gurugugnola:

credo di essermi perso.. tu dici di renderizzare in più colpi e di dare l'effetto di riflessione in photoshop? (scusa ma l'icone sotto il profilo sono per i programmi che mi piacerebbe utilizzare e non per quelli che conosco realmente:rolleyes: ...autocad apparte)

Share this post


Link to post
Share on other sites

Molto tempo fa avevo aperto una discussione a tale proposito e mio erano stati dati consigli di vario genere...

http://www.treddi.com/forum/index.php?show...mp;#entry507304

Premetto che era la versione di max 2008, ove il problema era assai più evidente e riconosciuto.

Sucessivamente ho notato che queste problematiche, come mi suggeriva Dagon nel post linkato, sono spesso caratterizzati da errori di modellazione soprattutto riguardanti i vetri e, aggiungo, in generale su geometrie ove le facce sono complanari.

Aumentare i samples provoca miglioramenti qualche volta ma sono inaccettabili dal punto di vista delle tempistiche e non risolve comunque il problema. Lo stesso vale per l'aumento dell'antialias.

Share this post


Link to post
Share on other sites

non risco a inserire l'immagine.. per cui

i settaggi di questo materiale AD

reflection

reflecty 0.6

glossiness 0.3

glossy samples 200

dici che siano dovuti a errori di modellazione bafio? perchè tutta la modellazione la faccio in autoca e poi importo tutto in 3dsmax...può essere la radice del problema?

adesso mi leggo tutta la discussione nella speranza di risolvere il problema..grazie mille

Share this post


Link to post
Share on other sites

Io ti consiglio di fare una prova senza i vetri che filtrano la luce esterna...cioè, per tentativi cerchiamo di individuare l'origine del problema...

200 glossy samples per me sono da suicidio...quanto sta a renderizzare per curiosità?

Share this post


Link to post
Share on other sites

non ne vengo fuori...ho tolto tutti i vetri dal render e niente..ho tolto le luci linear e niente. L'unica è con i samples a 200,ci impiega una vita, ma fino ad ora e l'unica cosa che aiuta un pelino.

Ho letto l'altra discussione bafio, ma non mi è stata di troppo aiuto, in quando credo di aver seguito tutte le indicazioni senza alcun risultato.

avete altre indicazioni?

Share this post


Link to post
Share on other sites

Allora, come detto da Bafio, 200 sample sono un "suicidio", anche se c'è di peggio nella vita.

Metti a 500 sample, non cambierà nulla, ma il tuo pc fonderà, solo e disperato.

Usa il fast reflection e refraction, metti i sample del reflection a 16 massimo. Invece nei parametri del fast glossy, che trovi qualche tab in sotto, nel material editor, cambierai i meccanismi di resolution, provando a trovare un compromesso.

Share this post


Link to post
Share on other sites

sto cercando di seguire le indicazioni di ytsejam ma probabilmente sono sempre più vicino dal far fondere il mio pc... non riesco a trovare nessun settaggio che migliori la cosa. Le indicazioni mi hanno dato spunto per fare ulteriori ricerche.. e ho trovato questo.. http://www.ramyhanna.com/files/mrGlossySampling.pdf

per Bafio

come luci uso la varie linear sotto il banco e omni sparse qua e la e una mr sun..la versione e 3dmax 9 e di seguito un screen shot della scena.. spero sia sufficiente per farsi un'idea

http://img206.imageshack.us/my.php?image=settaggiddi.jpg

Arcy79

credo sia più un problema di set del materiale e non di fg o gi (chiedo sempre conferma ai più esperti)

Share this post


Link to post
Share on other sites
Provato con il metodo a forza bruta ("brute force" la terminologia anglosassone se posso la evito :D)?

bhè non bisogna tralasciare l'effetto del brute force (molto meglio della semplice forza bruta... non trovi? :D )

cmq grinder spiegami in cosa consiste la forza bruta? se si parla di biscottare il pc...io ci sono vicino

Share this post


Link to post
Share on other sites
Hai provato ad aumentare il numero dei samples?

di cosa in particolare?

cmq ho renderizzato senza i vetri della finestra come consigliato altrove da Dagon ma nulla, i puntini bianchi sono li <_<

Share this post


Link to post
Share on other sites
bhè non bisogna tralasciare l'effetto del brute force (molto meglio della semplice forza bruta... non trovi? :D )

cmq grinder spiegami in cosa consiste la forza bruta? se si parla di biscottare il pc...io ci sono vicino

Prova a dare un'occhiata qui

Impiega un pò di tempo, ma tentar non nuoce! :)

Arcy79:

di cosa in particolare?

Io proverei sia in rifrazione che riflessione, max 32 però, poi mettere a 8 uno dei due e vedere quale è quello che da il problema. Anche a me capita, una volta però per sbaglio ho impostato su brute force (più preset medio) e i puntini son scomparsi...ha impiegato però 25 ore con un 8 core! E continuavo a chiedermi perchè ci mettesse così tanto!!! :D

Share this post


Link to post
Share on other sites
prova a cambiare i materiali o a rifarli. gli A&D a me in alcuni casi hanno dato problemi. come detto prima.

:hello:

ho rifatto i materiali e sono spariti come d'incanto tutti i puntini bianchi........mister di 3d studio max ;)

Share this post


Link to post
Share on other sites

Bene, meno male, i puntini bianchi del genere capitano/o meglio mi sono capitati in alcune situazioni, con light shape attivate come detto da yts o quando dei materiali sono troppo 'incendiati' dalle luci (tipo i rendering notturni di rendershape per esempio) in concomitanza di importazioni di files DWG (praticamente non ho importato altri tipi di files) o presenti in alcune scene che mi sono state date da sistemare, dove erano presenti sia generalmente che su specifici oggetti, quasi sempre trasparenti o con superfici trasparentiadiacenti(a contatto senza compenetrazione) a volte con glossy. A volte basta mergiare la scena in una nuova vergine e tutto sparisce, altre cambiare il materiale, altre non basta nemmeno questo e l'unica soluzione che ho trovato è stata quella di ricreare la geometria.

Share this post


Link to post
Share on other sites

delle volte frizzare il fg e copiare molte volte la mappa sopra puo creare dei problemi......vedi se dipende anche da quello! :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...