Jump to content
Netmanto

Problema Mappatura Con Materiali Complessi

Recommended Posts

Salve, sto cercando di risolvere un problema di mappatura, ci ho smanettato su parecchio ma per ora l'unico risultato che ho ottenuto è un mal di testa :) quindi chiedo consiglio a voi:

Il materiale sarebbe un asfalto, il mio datore di lavoro vuole che sia più "sporco" quindi come fatto a chiazze.

Io ho creato un materiale asfalto con diffuse marroncino e con una mappa cellular abbastanza fitta nel canale bump. Poi ne ho creat un altro uguale ma con un diffuse di colore grigio. Li ho messi in un materiale blend che come mappa mask ha un noise in modo da creare chiazze del materiale marrone e chiazze del materiale grigio, almeno l'intento era questo.

Il problema sorge in fase di mappatura, io ho assegnato un map channel 2 alla mappa noise xke volevo assegnare all'oggetto due modificatori uvw map uno che regolasse il noise e uno che regolasse gli asfalti, solo che l'uwv map con canale 2 non influenza minimamente il noise, lo influenza solo se lo metto su map channel 1 e questo anche se il noise è impostato su object xyz anzichè su explicit map channel.

Forse non si è capito nulla, al massimo proverò a spiegarlo meglio, cmq se qualcuno di voi ha avuto a che fare con problemi simili magari può darmi un suggerimento.

grazie mille


Edited by Netmanto

Share this post


Link to post
Share on other sites

Giusto per sintetizzare il concetto, il problema principale è che non capisco come mai se setto map channel 2 nella mappa noise e map channel 2 nell'uvw map questo non viene applicato alla mappa noise, ma viene invece applicato se nell'uvw setto map channel 1. :huh:

Share this post


Link to post
Share on other sites

Invece di fare tutti codesti passaggi, basterebbe usare un mix di un asfalto pulito con uno sporco(o mappa simil sporca, anche vettoriale tipo noise), fatto questo ti copi il mix sul bump e poi regoli il blur delle mappe, insomma devi trovare il tuo metodo, magari posta uno screen

Share this post


Link to post
Share on other sites
Invece di fare tutti codesti passaggi, basterebbe usare un mix di un asfalto pulito con uno sporco(o mappa simil sporca, anche vettoriale tipo noise), fatto questo ti copi il mix sul bump e poi regoli il blur delle mappe, insomma devi trovare il tuo metodo, magari posta uno screen

Si beh ho pensato anche io ad altri modi per risolvere il problema, cio nonostante non mi capacito del fatto che i canali di mappatura non funzionino su una mappa noise, voi avete idea del perchè? nei prossimi giorni magari cmq posto qualche screenshot, adesso non posso perchè ho le immagini sul computer dell'ufficio...

Share this post


Link to post
Share on other sites

fra le proprietà del noise hai settato "use explicit mapo channel"?

di default il noise viene applicato alla geometria dell'oggetto anche se in viewport viene associato a uvwmap=1

Share this post


Link to post
Share on other sites
fra le proprietà del noise hai settato "use explicit mapo channel"?

di default il noise viene applicato alla geometria dell'oggetto anche se in viewport viene associato a uvwmap=1

si ho settato nella tendina explicit map channel anzichè object xyz, con channel 2, cio nonostante l'uvw map con channel 2 non lo influenza, lo influenza solo con channel 1. A voi è mai capitato?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...