Jump to content
Kenji87

Esportare Normal Map Zbrush-3ds

Recommended Posts

Allora, so che c'è un altro topic in cui si prova a capirne qualcosa, ho provato a seguirlo, ho provato tutti i procedimenti e vi assicuro che sono stato attento ^_^ ma ho qualche problema.

Se dovessi imparare questo cavolo di procedimento giuro che faccio un tutorial perchè non è possibile trovare così poche informazioni per un procedimento così importante.

Passiamo al mio lungo procedimento, prego qualche esperto di darmi qualche dritta e dirmi se almeno il procedimento è giusto; qui spiegherò il tutto in sintesi, in caso il procedimento funzioni partirò col tutorial dettagliato.

1-Creare una mesh Low Poly in 3D studio max, unwrapparla per non avere problemi in seguito.

Essendo molto low poly ci ho già applicato un meshsmooth, i poligoni rimangono sui 700.

Ho unwrappato creando una semplice flattern map in modo che zbrush abbia delle coordinate dove "disegnare".

http://img13.imageshack.us/img13/6907/22068848.jpg

2-Esportare l'OBJ e caricarlo in zbrush:

http://img6.imageshack.us/img6/662/69248274.jpg

3-Andare su Morph Target e cliccare StoreMT; aggiungere suddivisioni alla mesh e scolpire il tutto

http://img530.imageshack.us/img530/7522/30338843.jpg

4-Ritornare alla prima suddivisione, che sarà leggermente diversa da come l'abbiamo importata, andare nel morph target e cliccare su Switch per riportare la nostra mesh come importata.

Aprire Zmapper, caricare il "3DS Max7_TangentSpace_BestQuality" e cliccare "Create normal map"

http://img13.imageshack.us/img13/4998/64377495.jpg

Come vedete la qualità mi sembra già abbastanza bassa.

Da quello che ho capito è meglio evitare forti estrusioni come quei tentacoli/spine, perchè poi sarà un problema per la normal map riprodurle in una maniera decente.

5-Esportare la texture creata in bmp:

http://img6.imageshack.us/img6/3111/normal2w.jpg

Come vedete la texture è scolpita sulla mappatura fatta in 3D studio max, quindi dovrebbe funzionare.

6-Ritornare al nostro primo modello in 3d studio max, nel canale Bump creare una mappa "Normal Bump", in questa mappa abbiamo 2 slot: "Normal", dove andremo a caricare la nostra texture esportata, e "Additional Bump", dove si andrà a caricare un eventuale cavity map.

Applichiamo il materiale al modello e...questo è il risultato abbastanza deludente. :

http://img246.imageshack.us/img246/8659/10065259.jpg

Applicando anche una cavity map il risultato migliora:

http://img10.imageshack.us/img10/6791/21083285.jpg

Sinceramente mi sembra comunque abbastanza basso; per migliorare penso si debbano inserire settaggi particolari in zbrush, perchè modificando i vari settaggi nella bump map di 3Ds non si risolve quasi nulla, gli unici settaggi da aggiustare sono i valori che vedete negli screen.

Il risultato finale non mi sembra mantenere quella qualità che vorrei e che vedo mentre scolpisco in zbrush, e so di non poterla ottenere in maniera identica, ma almeno simile...

Cosa sbaglio nel procedimento? avete consigli?

So che è una tecnica abbastanza utilizzata quella delle normal map da zbrush a 3Ds o Maya...se qualcuno la utilizza e vuole spiegarmi come far ene sarei veramente grato.

Grazie

Share this post


Link to post
Share on other sites

Anchio ho lo stesso problema, ho anche acquistato il video corso in italiano reclamizzato quà sul forum pensando che nei vari tutor in inglese mi fosse sfuggito qualcosa, però non mi ha risolto il problema

Share this post


Link to post
Share on other sites
anche usando la displacement il risultato non è gran chè

il displacement lo fai sempre tramite zmapper o dal tool displacement in zbrush? non ho ancora capito come crearla, anche se clicco non me la crea <_<

Il tutorial italiano di cui parli spiega anche le normal map e l'esportazione?

Share this post


Link to post
Share on other sites
il displacement lo fai sempre tramite zmapper o dal tool displacement in zbrush? non ho ancora capito come crearla, anche se clicco non me la crea <_<

Il tutorial italiano di cui parli spiega anche le normal map e l'esportazione?

Mi rispondo da solo, provata anche la displacement,che appunto non risolve nulla, e mettendola nel materiale "Displacement" di 3ds ingrossa solo la mesh.

Per crearla ho usato 2 modi, da zbrush Creat DispMap, e la salva nelle alpha, anche se sembra grigia cè comunqeu qualcosa.

Se la si esporta direttamente dalla lista delle alpha esce in un modo, se si esporta tramite il DExporter esce in un altro modo...

Share this post


Link to post
Share on other sites

Renato prova a fare così:

Setta come motore di render Mental ray.

Nella bump map assegna una "Normal Bump", in "Normal" metti la tua normal map, in "Additional Bump" applica un altra "Normal Bump".

In questa nuova Normal Bump applica in "Normal" la mappa displacement creata in zbrush SENZA il DExporter, ma semplicemente salvando la mappa in psd, mentre in "Additional bump" metti la mappa Cavity.

Per i valori cerca di arrangiarti te, fai un pò di prove ^_^

Io così ho ottenuto un risultato diciamo...più o meno accettabile, più tardi posto anche qualche screen.

Fammi sapere se ti funziona, almeno possiamo confrotnarci ed arrivare ad una soluzione

Ciao

Share this post


Link to post
Share on other sites

Scusate se continuo a fare post; man mano che imparo cerco di rendere partecipe chi ha gli stessi problemi ^_^

Una cosa importantissima per chi ha 3ds9 è che, per creare la normal map in zbrush, non deve usare in zmapper il config "3DS Max7_TangentSpace_BestQuality" , perchè creerà problemi.

Scaricare invece questo , che è un config per 3ds8 che funziona anche sul 9.

Usando questo, la situazione migliora; imposta automaticamente i settaggi giusti anche per la cavity map.

Poi basta esportare le texture come scritto nei posti precedenti, cioè Bump-Normal bump- in Normal inseriamo la Normal Map creata in zbrush, in additional bump la Cavity map, O un altra Normal bump dove inserire Cavity + Displacement.

Ecco, per il displacement ho ancora qualche problema nell'applicazione, ma dovrei essere vicino ad una soluzione, posterò delle immagini come esempio.

Share this post


Link to post
Share on other sites

Ciao, secondo me ci sei solo che sbagli valori.

Allora, fino a dove creare la mappa e tutto giusto tranne che il file da caricare è quello per 3ds8 come hai scoperto.

Ora in max devi semplicemente inserire il valore di 100 al canale bump, e lasciare a 1 sia il valore di Normal che di Additional.

Altro dubbio che ho sul perchè ti esce male è dentro Z-Mapper; qui devi settare la mappa in uscita come Tangent map. ho visto che la tua normal ha lo sfondo bianco e questo no buono.

Con questi piccoli accorgimenti dovresti trovare la giusta via perchè non vedo grossi errori di procedimento.

Per quanto riguarda la displace; si ottengono buoni risultati solo con mentalray.

Basta che attivi il canale displace che è bloccato sotto mentalconnection, inserisci una mappa 3dDisplacement(3dmax), carichi la mappa in Extrusionmap, e giochi con i valori.

Spero di essere stato d'aiuto.

Share this post


Link to post
Share on other sites
Ciao, secondo me ci sei solo che sbagli valori.

Allora, fino a dove creare la mappa e tutto giusto tranne che il file da caricare è quello per 3ds8 come hai scoperto.

Ora in max devi semplicemente inserire il valore di 100 al canale bump, e lasciare a 1 sia il valore di Normal che di Additional.

Altro dubbio che ho sul perchè ti esce male è dentro Z-Mapper; qui devi settare la mappa in uscita come Tangent map. ho visto che la tua normal ha lo sfondo bianco e questo no buono.

Con questi piccoli accorgimenti dovresti trovare la giusta via perchè non vedo grossi errori di procedimento.

Per quanto riguarda la displace; si ottengono buoni risultati solo con mentalray.

Basta che attivi il canale displace che è bloccato sotto mentalconnection, inserisci una mappa 3dDisplacement(3dmax), carichi la mappa in Extrusionmap, e giochi con i valori.

Spero di essere stato d'aiuto.

E me lo chiedi anche? certo che sei stato di aiuto ;)

Ho attivato il displace in mental ray ma non mi sembra di vedere particolari miglioramenti, probabilmente il problema ora sta nelle altre mappe; infatti riguardo zmapper a me crea sempre una texture con lo sfondo bianco, come posso fare per cambiarlo? e come mai non dovrebbe andar bene? (pura curiosità :D )

Share this post


Link to post
Share on other sites

Ciao Kenji, lo hai gia' visto il video tutorial su 3dtotal.com? nella sessione dedicata ai tutorial in quelli su Z-Brush, ce' ne uno propio specifico sulle normal map e perla proprio dell' interazione tra' 3dStudio e Z-Brush, se non lo hai ancora visto fatti un giro è molto ben fatto! ( www.3dtotal.com ) Spero di averti aiutato ciaaaooo...

Share this post


Link to post
Share on other sites

Si avevo già controlalto quel tutorial, ma non va molto in profondità.

Invece ho seguito questo, purtroppo è su veoh e per guardarlo completamente si deve scaricare il player apposito.

http://www.veoh.com/collection/houseofZbru...6507080KY8nTThA

Sono 45 min e spiega l'intero procdedimento e varie tecniche, che vanno dall'export, alla mappatura, ai settaggi di tutte le varie opzioni per creare una buona Displacement map ed una normal map con zbrush 3.1, e spiega come applicarla sia in Maya, sia in 3ds.

Insomma, il procedimento è abbastanza lungo, ma unendo questo tutorial con altre conoscenze acquisite sono riuscito a creare questo low poly:

http://img10.imageshack.us/img10/7329/alienonormal.jpg

E' "simile" alla creazione di zbrush, ho applicato una Displacement, una Normal ed una Cavity map.

Il risultato mi sembra buono, concordate?

Se avete domande chiedete pure, appena imparerò il procedimento bene penserò al tutorial...per ora è solo una questione di pratica, perchè il procedimento è abbastanza lungo.

Share this post


Link to post
Share on other sites

ciao Kenji87, ieri ti ho promesso che ti postavo quello che dice il video tutor,purtroppo stasera ho ancora del lavoro da finire e non ho tempo, domani con calma leggo gli ultimi post e poi ti scrivo

Share this post


Link to post
Share on other sites
ciao Kenji87, ieri ti ho promesso che ti postavo quello che dice il video tutor,purtroppo stasera ho ancora del lavoro da finire e non ho tempo, domani con calma leggo gli ultimi post e poi ti scrivo

No nti preoccupare, puoi anche limitarti a leggere l'ultimo post che spiega in generale come ho fatto e cosa ho seguito, se ti serviva aiuto per il tuo problema magari posta qualche screen e vediamo che manca; purtroppo la configurazione import-export cambia molto anche in base alla versione di 3ds che hai.

Share this post


Link to post
Share on other sites

ciao Kenji87 solo oggi ho un pò di tempo per il forum, adesso mi vedo il tuo tutorial e poi ti farò sapere,

comunque non c'è proprio nessuno sul forum che usi spesso la displace di zbrush?

Share this post


Link to post
Share on other sites

Ciao kenji87. Premesso che non uso max e non sono molto pratico nell'esportare le mappe da zbrush, volevo chiederti:

perchè il primo tentativo ti sembra di scarsa qualità?

A parte qualche artefatto in corrispondenza delle "seams" (i bordi dei vari pezzi nelle uvs), mi sembra ok. Quello che salta all'occhio è che hai scolpito dettagli troppo sporgenti rispetto al livello di dettaglio poligonale del low poly.

Penso che per avere un risultato decente (problemi tecnici di esportazione a parte) dovresti ad esempio avere gli "spuntoni" ai lati del viso modellati già sul low poly. Altrimenti la discrepanza tra il modello hi-poly in zbrush e quello low-poly sarà evidente. La normal non sarà mai in grado di riprodurre in maniera decente dettagli cosi sporgenti che modificano sensibilmente le grandi forme del modello.

In parole povere guardando il modello da una certa angolazione ti aspetteresti di vedere il contorno di quegli spuntoni, che però non c'è.

Quindi o modelli quei dettagli direttamente in max oppure usi la displacement per i dettagli grandi e significativi e la normal per i più piccoli.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...