Jump to content
torben

Domino Con Reactor

Recommended Posts

Salve a tutti!

Dopo essermi dilettato nella caduta di monete che formano una scritta ho deciso di provare a creare una sequenza di domino...

Ho creato tutto ma ho dei problemi con dei tasselli che letteralmente si trapassano o altri che dopo aver colpito il tassello che li segue attraversano il piano e cadono giu verso l'infinito...vi posto alcuni esempi presi dalla simulazione che fa reactor...

Come potete vedere dall'immagine certi effetti sono moooooolto antipatici e vorrei eliminarli...

In alcuni casi ho risolto aumentando la definizione poligonale dei piani ma a quanto pare non basta...potete darmi qualche consiglio????

http://img11.imageshack.us/img11/4725/forum3d.jpg

Grazie a tutti in anticipo!!!!

Share this post


Link to post
Share on other sites
usa havok3 come solver al posto dell'havol1.

Supporta solo i rigid bodies ma è molto migliore.

ciao

Cioè?Scusa l'ignoranza ma non ho la benchè minima idea di cosa si tratti!!!

Share this post


Link to post
Share on other sites

Vai in Utilities del Command Pannel e li trovi le impostazioni principali di reactor.

Cmq ho fatto una piccola prova anch'io, e pur portando il Collision Tolerance a zero non riesco ad evitare che i pezzi mi cadino verso l'infinito. Mi spieghi come hai fatto tu a tenerli appoggiati sopra ai vari piani?

Share this post


Link to post
Share on other sites
Vai in Utilities del Command Pannel e li trovi le impostazioni principali di reactor.

Cmq ho fatto una piccola prova anch'io, e pur portando il Collision Tolerance a zero non riesco ad evitare che i pezzi mi cadino verso l'infinito. Mi spieghi come hai fatto tu a tenerli appoggiati sopra ai vari piani?

Io la tolleranza l'ho impostata a 0,5 e poi ho aumentato a dismisura i poligoni dei piani su cui appoggiano...ad esempio gli scalini sono dei semplici box a cui ho portato i segmenti da 1 a 6 sia per la lunghezza,che per la larghezza che per l'altezza.

E un altra cosa...i pezzi non li ho appoggiati sul piano ma sono leggermente alzati...

Almeno questo problema l'ho risolto....ma non riesco ad evitare che i blocchi si intersechino...neanche aumentandone la definizione poligonale come ho fatto prima!!!!


Edited by torben

Share this post


Link to post
Share on other sites

Bhè ora te ne conto una di bella.

Ieri mattina provavo quì da lavoro con un Core2duo, xp 32bit, Firegl V3400, 4gb, max2009 e non mi riusciva. Poi ho provato ex novo su un Q9550, xp 64bit, Fx 1700, 8gb, max 2009 ... e mi riesce! Bha, dico, avrò impostato qualcosa di diverso ... salvo il file e lo provo sul 32 bit. Adesso provo il file, e l'Havok3 mi da tutt'altro risultato, ovvero sembra che a diminuzione di dotazione hardware tutte le forze impostate in reactor diminuiscano di conseguenza. Mah?!!!

Cmq, penso che l'assoluta impenetrabilità non riuscirai ad averla perchè il Col. Tolerance non accetta un valore 0.

ciaos.jpg


Edited by ruezzana

Share this post


Link to post
Share on other sites
Bhè ora te ne conto una di bella.

Ieri mattina provavo quì da lavoro con un Core2duo, xp 32bit, Firegl V3400, 4gb, max2009 e non mi riusciva. Poi ho provato ex novo su un Q9550, xp 64bit, Fx 1700, 8gb, max 2009 ... e mi riesce! Bha, dico, avrò impostato qualcosa di diverso ... salvo il file e lo provo sul 32 bit. Adesso provo il file, e l'Havok3 mi da tutt'altro risultato, ovvero sembra che a diminuzione di dotazione hardware tutte le forze impostate in reactor diminuiscano di conseguenza. Mah?!!!

Cmq, penso che l'assoluta impenetrabilità non riuscirai ad averla perchè il Col. Tolerance non accetta un valore 0.

A ecco qst cosa mi fa molto piacere...non sono riuscito a capire come modificare l'havok...

Per le prestazioni hardware io ho un Intel Pentium M 1.86 GHZ,xp 32 bit,nvidia geforce go 7300,2 giga di ram e max 2007...probabilmente sarà questoo il motivo...

Anche se non sarà possibile eliminarle del tutto vorrei riuscire almeno a limitarle per poi cercare di sistemare la camera per il filmato furbescamente in modo che non si vedano qst trapassamenti....

Share this post


Link to post
Share on other sites
A ecco qst cosa mi fa molto piacere...non sono riuscito a capire come modificare l'havok...

Per le prestazioni hardware io ho un Intel Pentium M 1.86 GHZ,xp 32 bit,nvidia geforce go 7300,2 giga di ram e max 2007...probabilmente sarà questoo il motivo...

Anche se non sarà possibile eliminarle del tutto vorrei riuscire almeno a limitarle per poi cercare di sistemare la camera per il filmato furbescamente in modo che non si vedano qst trapassamenti....

Vai in Utilities del Command Pannel e li trovi le impostazioni principali di reactor.

Share this post


Link to post
Share on other sites
Ok, ma permettimi la frecciatina :P

i6289_ciao.jpg

La frecciatine me la prendo tutta....ma ora si è svelato l'arcano motivo per cui nn riesco a trovare sta cosa di havok3....io ho 3d studio max 7 e reactor è la versione 2.1.0.6 mentre vedo dal tuo screen che la tua è la versione 3 e passa!!!

C'è un modo per aggiornare Reactor?Sto cercando in rete ma non riesco a trovare niente!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...