Jump to content
aledreams

Errore In Mental Ray

Recommended Posts

Ciao a tutti, vorrei chiedervi se qualcuno sa come posso risolvere questo errore in mental ray:

RCGI 0.4 error 361001: photon emission shader returned miFALSE: aborting photon tracing

nella scenna c'è il sun and sky

GI con fotoni emessi dalla directional e dalla portal light

FG

se qualcuno sa dirmi per favore cosa posso fare

mille grazie

Share this post


Link to post
Share on other sites

Ciao Dagon, io avrei volentieri postato uno screenshot, è che non viene fuori.

Ti spiego per benino cosa succede, ho fatto un render con un mia_material grigio senza riflessioni o trasparenze e mi ha fatto il render in circa 2 minuti.

Quindi ho iniziato ad applicare i vari materiali che sono tutti mia_material con la maggior parte dei preset; lancio il render e dopo mezzora sta ancora lanciando i fotoni, al che ho premuto ESC per interrompere il render e nell'output window mi compare quell'errore scrito una ventina di volte.

Ho provato a rimettere il mia material iniziale e fa il render in circa 2minuti senza nessun problema.

La cosa strana è che se attivo solo il FG renderizza, con la GI no, tra l'altro mi dice che devo porre area light su visible... ho provato a metterla ma a quel punto il render non viene...

premetto che il numero di fotoni non l'ho cambiato e nemmeno toccato nessun parametro tra un render e l'altro.

Share this post


Link to post
Share on other sites

La direct emette fotoni con il BBox; l'area light è collegata alla portal light ed emette fotoni, ho provato a fare una prova disabilitando l'area light ma niente

Share this post


Link to post
Share on other sites

Probabilmente dipende dal bbox del sun che certe volte fa casini non ho mai capito il perchè; infatti sono in molti a dire che non sempre funziona bene.

Prova a resettare i due slot bbox min e max e vedi se continua il problema.

Share this post


Link to post
Share on other sites

Guarda ho fatto anche questa cosa, perchè mi è successo che i fotoni del sun non entravano così l'ho cacellato e il render funzionava benissimo... non capisco proprio cos'abbia :wallbash:

Share this post


Link to post
Share on other sites
Guarda ho fatto anche questa cosa, perchè mi è successo che i fotoni del sun non entravano così l'ho cacellato e il render funzionava benissimo... non capisco proprio cos'abbia :wallbash:

quindi cancellando la direct il render funziona?

allora è abbastanza chiaro che il problema sia dei fotoni del sun, probabilmente il bbox come ha già detto faber

Share this post


Link to post
Share on other sites

no no scusatemi mi sono espresso male il render ha funzionato fino a che non sono andato ad applicare i mia_material; con il mia_material base cioè diffusione color grigio reflectivity e trasparency zero funziona tutto.

La condizione è questa:

- Directional emette fotoni ed inizialmente è stato impostato il Bbox, poi è stato cancellato; la directional è scalata per questioni di comodità.

- Area lighr posta sulla finestra con collegato una Portal light che emette fotoni

Se metto mia_material base o qualsiasi altro materiale di Maya fa il render in 2 minuti

Se applico un'altro mia_material con texture collegate o quant'altro iniziano i problemi e mi da l'errore nell'output window

scusatemi se non sono stato chiaro

Share this post


Link to post
Share on other sites

Mi sa che è così, io comunque per emettere i fotoni del sole, ho creato una spot disattivato intensity e specular e ho fatto emettere i fotoni alla spot...

Share this post


Link to post
Share on other sites

Ciao, riprendo questo post in quanto ho chiesto allo staff se il post render d'interno può essere postato all'interno di questo o altrimenti cancellato, su giusta osservazione di Ytsejam ho voluto riprendere in mano il discorso del Bbox per capire dove possa essere il problema.

Allora ho provato a ricollegare il Bbox alla directional light e mi ha preso questi valori:

Bbox min: 29; 29; 25.2

Bbox max: 29; 29; 25.2

ho selezionato Automatic Photon energy

disattivato la portal light ed il FG

questo è il risultato

il problema nasce se spunto sulla directional Emit photons...

Share this post


Link to post
Share on other sites

mi sono dimenticato, questo render lo fa in 27 secondi, se spunto Emit Photons nella directional dopo 15 minutti sta ancora emettendo fotoni che in tutto sono 10000

Share this post


Link to post
Share on other sites

Ho cancellato l'enviroment e ricreato il nodo dun and Sky, quindi guardando anche ciò che mi avete detto, ho evitato di scalare la directional, mi sono creato un cubo delle dimensioni della stanza collegato con il Bbox ottenendo le stesse dimensioni di prima e poi l'ho cancellato.

Quindi sulla directional:

-ho disattivato automatic Photon Energy

-Ho attivato Emit Photons; impostato Photon intensity 55000000000.000, Exponent 2, Global Illum Photons 100000

Sull'area light ho attivato i fotoni con i seguenti settaggi:

Photon intensity 8000.000, Exponent 2, Global Illum Photons 100000

la Portal light l'ho lasciata con i valori di default.

Alla fine attivato il FG con Accuracy 120; Point density 1; Point interpolate 10

La GI settata su accuracy 500; Radius 8; Merge distance 0.2

Nella camera ho collegato un mia_expouse_photographics

con ISO 100; Camera Shutter 8; F number 16.

Il Sun and Sky ho settato RGB unit conversion a 0.318.

Ho ottenuto questo risultato.

Probabilmente c'era qualche errore nel nodo che non ho capito anche perchè come tempo di render a 1200x720 con AA 2-0 Raytracing 8-8-16 così come per il trace depth del FG e GI ha impiegato 1 ora e 5 minuti.

post-1927-1237418881_thumb.jpg

Share this post


Link to post
Share on other sites

solo fotoni con boundingBox corretta e sun position corretta.

Te la reinvio in e-mail.

P.S. glossy sample a 200, da suicidio tanto per dirne uno e i 200 o 300 dei samples dell'arealight? Te li ho impostati diversamente ed ho ritoccato anche la tenda. Cambia i colori e riassegna le textures.

Bye bye


Edited by ytsejam

Share this post


Link to post
Share on other sites

Ciao a tutti, allora ho fatto una prova sulla base della scena Ytsejam, (che ringrazio tantissimo) ora il Bbox sembra che funzioni, in più erano sbagliati alcuni settaggi.

Ho ottenuto questa immagine dove c'è solo la GI proponendo gli stessi parametri (tranne per il Bbox che l'ho costruito prendendo spunto dalla scena e questa volta mi da valori più credibili).

Ci sono 2 cose che vorrei chiedere:

1 l'Area light è spuntata si Visible per quanto riguarda la sezione light shape però questo non mi permette di vedere lo sfondo, quindi c'è un modo per ovviare a questo problema?

2 La stanza mi dà l'idea di essere scuretta, ora per schiarirla agisco sul mia_expouse_photographic... giusto?

mille grazie ancora

post-1927-1237485121_thumb.jpg

Share this post


Link to post
Share on other sites

L'arealight, dev'essere spuntata su visible nello shape e l'ho tolta sul tuo shaderportal, per vedere lo sfondo, agisci sul transparency della portal.

Share this post


Link to post
Share on other sites

Ho fatto un'ulteriore prova e ho portato il camera shutter a 3 per rendere più luminosa la stanza, in questa immagine ho attivato anche il FG.

Vorrei chiedervi una cosa nel muro di fronte a destra e nell'ombra delle mensole a sinistra ci sono degli artefatti causati presumo dalla GI... in questo caso per eliminarli devo aumentare il numero di fotoni (Portal light 500.000 - sun light 30000) oppure aumentare i valori del Photon tracing (5 - 5 - 5)

post-1927-1237498917_thumb.jpg

Share this post


Link to post
Share on other sites

usa il merge distance dei phtons, che trovi appunto sotto radius se non ricordo male. Siccome la tua scena è molto piccola e non in scala il tuo merge puoi provare a settarlo a 0.200 o 0.300, questo ti permette di eliminare e distribuire meglio i tuoi fotoni e le zone di sovra esposizione. Potresti usare anche gli importons, ma una cosa per volta.

Per il sun è "TOPSECRET"

Ah dimenticavo, il numero dei photoni della portal light, per quella stanza e dimensioni è esagerato, stai intorno ai 50000. Secondo me non hai bisogno di aumentarli


Edited by ytsejam

Share this post


Link to post
Share on other sites

Ok allora provo così aumento i fotoni di circa un 25% dei valori che mi hai dato, uso il merge e aumento di 1 punto i valori dei trace.

Peccato per il sun perchè probabilmente è la chiave di volta :) , ti ringrazio per la tua disponibilità e pazienza.

Ok dai provo a lanciare un'altro render e vediamo che succede

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...