Jump to content
saudade

Clamoroso Bug Vray 1.5 Sp3!

Recommended Posts

Salve a tutti

vi espongo di seguito un bruttissimo bug riscontrato con la versione Sp3 di Vray 1.5

In pratica realizzo notte e giorno animazioni con Vray, con la versione Sp2 nessun problema, ma passando la settimana scorsa alla Sp3 dopo ore ed ore di rendering mi sono accorto del seguente bug:

Avevo realizzato un'animazione con Max2008, un percorso di telecamera con alcune pause, sulle pause ho clonato la telecamera (copia) e realizzato delle panoramiche a 180 gradi.

Parte dell'animazione è stata realizzata con Vray 1.5 Sp2, appena ho calcolato la restante parte con Vray 1.5 Sp3 mi sono accorto che le telecamere non coincidevano.

pensavo di avere mosso la telecamera o addirittura la scena, di avere messo chiavi di animazioni per errore sui parametri di focale...ma nulla, i vecchi fotogrammi non si agganciavano ai nuovi.

Vi allego delle immagini per farvi capire di cosa sto parlando.

Ovviamente non ho provato a creare una telecamera (physical camera) ex novo direttamente con la Sp3...anche perché mi serviva usare la precedente physical camera frutto di giorni e giorni di lavoro.

Insomma, ho buttato circa 2000 fotogrammi....

Sottolineo anche che se guardo in Opengl la scena e provo a renderizzare non c'è corrispondenza tra quello che vedo su Max e quello che viene calcolato.

Vi prego di far presente questo bug alla Chaos in quanto io non ho veramente tempo, se c'è qualcuno che ha riscontrato lo stesso problema ne sono felice...

Gli esempi allegati mostrano un mix tra la scena max ed il render, quella che coincide è realizzata con la SP2

L'altro esempio mostra due fotogrammi apparentemente simili, uno renderizzato con la Sp2 e l'altro con la Sp3

Miscelando con photoshop i due fotogrammi ci accorgiamo del problema.

Ripeto che la scena l'ho renderizzata non toccando nulla ma installando una volta la Sp2 e l'altra la Sp3

Share this post


Link to post
Share on other sites

a parte il fatto del "bug" in se, che non ho modo di verificare a parte guardare l etue immagini, quindi lascio a chi lo sta provando.

ma una cosa mi sorge spontanea, e non ti offendere per carità, ma quello che hai scritto qui, non potevi scriverlo alla Chaos direttamente, cosa vuol dire "Vi prego di far presente questo bug alla Chaos in quanto io non ho veramente tempo, se c'è qualcuno che ha riscontrato lo stesso problema ne sono felice..."

bah

Share this post


Link to post
Share on other sites
a parte il fatto del "bug" in se, che non ho modo di verificare a parte guardare l etue immagini, quindi lascio a chi lo sta provando.

ma una cosa mi sorge spontanea, e non ti offendere per carità, ma quello che hai scritto qui, non potevi scriverlo alla Chaos direttamente, cosa vuol dire "Vi prego di far presente questo bug alla Chaos in quanto io non ho veramente tempo, se c'è qualcuno che ha riscontrato lo stesso problema ne sono felice..."

bah

ne sarei felice in quanto non sarei l'unico ad impazzire su questo problema

già fatto...ho scritto alla Chaos e grazie per il tuo preziosissimo commento...

chi fa da se fa per TRE!!!...;)


Edited by saudade

Share this post


Link to post
Share on other sites
Guest

molte grazie della segnalazione, aspetterò ad installarlo. Qui tra Max e Vray, non si finisce di installare hotfix e service pack vari e trovare un po' di stabilità, che è ora di aggiornare i software, per ricominciare daccapo la via crucis :o !

Scusa se mi permetto, ma non sarà una questione di attivazione del Show safe frame?


Edited by Giane

Share this post


Link to post
Share on other sites

i bugs possono sempre esserci, poi sta alla serietá della Chaos di risolverli nel piú breve tempo possibile, ovviamente se gli vengono segnalati attraverso il bug report.

Io personalmente, quando ho qualche lavoro o scadenza importante, preferisco sempre aspettare prima di installare qualcosa di nuovo, se ho lavorato un anno con un programma, posso continuare senza problemi altre 2-3 settimane a lavorarci, dando per scontato che ogni nuova release ha sempre i suoi problemi di gioventú.

Share this post


Link to post
Share on other sites
Io personalmente, quando ho qualche lavoro o scadenza importante, preferisco sempre aspettare prima di installare qualcosa di nuovo, se ho lavorato un anno con un programma, posso continuare senza problemi altre 2-3 settimane a lavorarci, dando per scontato che ogni nuova release ha sempre i suoi problemi di gioventú.

quoto in pieno!

io ho l'SP3 installato, ma avevo la fortuna/sfortuna di non avere lavori in corso d'opera al momento dell'installazione!

Per il bug, spero che impostando direttamente la scena con tutto aggiornato, il problema non mi si presenti!

Share this post


Link to post
Share on other sites

a me pare che l'immagine presente in vieport e l'immagine renderizzata non siano riprese dalla stessa camera, bensì una dalla telecamera che segue il percorso, e l'altra da una clonata che non ha compiuto completamente la panoramica. infatti l'unica discrepanza che posso vedere è un semplice shift del "target" lungo un percorso circolare.

quali sarebbero i bugfix e service pack di vray?

Share this post


Link to post
Share on other sites
Guest
quali sarebbero i bugfix e service pack di vray?

Come non lo sai? E non sono pochi... Forse non hai letto questo, questo, o questo.

Per Max, ti rimando al sito di Autodesk.

Ciao.


Edited by Giane

Share this post


Link to post
Share on other sites
Come non lo sai? Forse non hai letto questo.

Per Max, ti rimando al sito di Autodesk.

Ciao.

mentre per max eseguo periodicamente gli aggiornamenti attraverso Help-> 3dsmax on the web ->updates, per quanto concerne vray la 1.5SP3 non è un bugfix ma una versione che introduce nuovi tools. all'interno di questa versione sono anche stati corretti dei bug minori, ma di certo è molto più di una semplice patch.

comunque si, l'avevo letta e avevo già aggiornato alla nuova versione.

edit: dicasi stessa cosa del sp1 e 2.


Edited by Mercy

Share this post


Link to post
Share on other sites
Guest
per quanto concerne vray la 1.5SP3 non è un bugfix ma una versione che introduce nuovi tools.

Ti sbagli, basta che dai un'occhiata ai link che ti ho messo. I bug fixes non sono pochi. Ad ogni conto, chiudo qui, non mi presto a sottilizzare sul significato di bug minore o maggiore.

Bug fixes:

(*) Le textures salvate dal RTT sono nere;

(*) Risolto un errore nei materiali di tipo Raytrace nello script di conversione per i VRay material;

(*) Il parametro Camera transformation sampling per il moblur ora corrisponde a quello presente per i silgoli oggetti;

(*) Camera motion blur ora funziona quando i frames sono esterni al range di animazione;

(*) Il materiale VRayFastSSS2 non era visibile nel VRayMtlSelect render element;

(*) Risolto un problema quando si usa una seconda licenza server;

(*) Il VRay2SidedMtl non mostra nel track View la mappa translucency;

(*) Il VRayLightMtl non renderizza correttamente il la mappatura di colore e trasparenza quando l'opzione "Direct illumination" era abilitata;

(*) Il VRayLightMtl non renderizza correttamente l'opzione "Emit on backside" quando l'opzione "Direct illumination" era abilitata;

(*) La mappa VRayEdgexTex non mantiene il suo nome quando salvate in una libreria personale;

(*) Errore avviando lo script di conversione dei materiali in una scena contenente shaders Arch&Design.

(*) Crash usando override material con interpolated reflections/refractions;

(*) La vista ortografica renderizza linee diritte al posto che curve quando si utilizza PowerNurbs;

(*) Risolto crash con il displacement;

(*) Il VRayFur density map non funziona correttamente con la mappa Falloff nella modalità Distance blend/Object;

(*) Lo slider exposure nel VRay VFB si potrebbe muovere al di fuori della finestra color corrections;

(*) La correzione dell'esposizione nel VFB non è applicata quando il file .max è caricato;

(*) Una nuova thumb potrebbe essere aggiunta allo slider della correzione dell'esposizione;

(*) VRay genera un canale z-depth nel GBuffer che non corrisponde a quello dello scanline;

(*) Il canale Velocity non è calcolato correttamente per telecamere in movimento se il parametro motion blur di VRay non è impostato come da default (anche quando il VRay moblur è disattivato)

(*) Risolto problema di crash quando si svuotano dalla memoria geometrie dinamiche;

(*) VRayCompTex non mostra nella lista le sue texture come sub-anim di 3ds max;

(*) Navigando con la finestra di dialogo per le VRayIES, ora di default il filtro sarà impostato su *.ies;

(*) VRayToon non supporta il metodo di accesso ai gizmi atmosferici di 3ds max;

(*) Crash di 3ds max con VRayHDRI mentre di renderizza con il Material Editor aperto;

(*) Coordinate W di mappatura non corrette per il VRayFur;

(*) Modificando il color mode delle VRayIES in "Temperature" non abilita il relativo spinner se non quando si riseleziona la luce;

(*) Il VRayFastSSS non mostra nella lista le sue texture come sub-anim di 3ds max;

(*) VRay valuta tutti gli oggetti "at time 0" prima di iniziare un rendering. Ora questo è vero solo quando si utilizza la IM in modalità animazione;

(*) I file VRayProxy .vrmesh non si archiviano quando si utilizza l'opzione File > Archive is 3ds Max 9 e precedenti;

(*) Le mappa VRayHDRI non si archiviano quando si utilizza l'opzione File > Archive is 3ds Max 9 e precedenti;

(*) I profili VRayIES non si archiviano quando si utilizza l'opzione File > Archive is 3ds Max 9 e precedenti;

(*) Problema esportando in formato .vrmesh con i caratteri '#' nel nome del file. Ora saranno sostituiti con '_' ;

(*) Le proprietà degli oggetti non sono preservate quando gli oggetti sono automaticamente convertiti in VRayProxy durante l'esportazione .vrmesh;

(*) Problema di animazione del vertical shift utilizzando il pulsante "Guess vertical shift";

(*) Il DR potrebbe bloccarsi in uno stato indefinito durante il rendering;

(*) I DR slaves renderizzano buckets neri se il rendering era cancellato mentre si riceveva un file .max del render precedente;

(*) Incorretto sampling rate con AA di tipo Adaptive subdivision e "Don't affect final colors" attivo;

Share this post


Link to post
Share on other sites
Ti sbagli, basta che dai un'occhiata ai link che ti ho messo. I bug fixes non sono pochi. Ad ogni conto, chiudo qui, non mi presto a sottilizzare sul significato di bug minore o maggiore.

d'accordo mi sbaglio. sono bugfix che introducono gratuitamente nuovi strumenti :w00t:

Share this post


Link to post
Share on other sites

la cosa che mi fa inc...are come una bestia è che rimettendo la Sp2 tutto torna come prima....nel senso che il match delle telecamere è perfetto...quindi non è un mio errore bensì un bug..

Se qualcuno ha fatto un'animazione con la Sp2 e la integra con la Sp3 dovrebbe riscontrare il problema...

Potrebbe essere un bug dello shift orizzontale...anche se era impostato a zero (sulla sp2 non c'era)

Vedremo...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...