Jump to content

Recommended Posts

Salve a tutti,

In Softimage XSI con l'introduzione del nuovo algoritmo di binary spece partitioning aka BSP2 il processo di ottimizzazione è stato completamente automatizzato... in pratica l'utente non ha più controlli per ottimizzare il BSP2 tree (almeno apparentemente), se ne occupa il software, almeno questo è ciò che la guida softimage riporta.

La mia domanda è: ma con l'introduzione del BSP2 il BSP l'hanno mandato a casa?

è possibile decidere se usare il BSP (con relativi controlli) o il BSP2?... se si in che modo?

esiste un modo per attivare i controlli del BSP2?

thanx more guys ;)


Edited by 3Dynamik

Share this post


Link to post
Share on other sites

Questa è la procedura per utilizzare il BSP vecchio.

Start -> Tutti Programmi -> Softimage Products -> Softimage XSI 7.01 (dipende da che versione hai) -> User Tools

Clicca su "Setenv.bat" (environment script) -> Edit file -> ti si apre una schermata con delle scritte

devi inserire dopo @echo off -> MI_FORCE_OLD_BSP=1

Tanto per essere chiari dovrai poi avere il tuo file così:

@echo off

MI_FORCE_OLD_BSP=1 <------------------

rem XSI Installation path

set SI_HOME=C:\Softimage\XSI_7.01_x64

set XSI_HOME=%SI_HOME%

set XSI_BINDIR=%XSI_HOME%\Application\bin

Poi clicca su "Save and close" e riavvia XSI.

Per ritornare al BSP2, ritorna in questo script ed elimina MI_FORCE_OLD_BSP=1, ovviamente :D

Share this post


Link to post
Share on other sites
Questa è la procedura per utilizzare il BSP vecchio.

Start -> Tutti Programmi -> Softimage Products -> Softimage XSI 7.01 (dipende da che versione hai) -> User Tools

Clicca su "Setenv.bat" (environment script) -> Edit file -> ti si apre una schermata con delle scritte

devi inserire dopo @echo off -> MI_FORCE_OLD_BSP=1

Tanto per essere chiari dovrai poi avere il tuo file così:

@echo off

MI_FORCE_OLD_BSP=1 <------------------

rem XSI Installation path

set SI_HOME=C:\Softimage\XSI_7.01_x64

set XSI_HOME=%SI_HOME%

set XSI_BINDIR=%XSI_HOME%\Application\bin

Poi clicca su "Save and close" e riavvia XSI.

Per ritornare al BSP2, ritorna in questo script ed elimina MI_FORCE_OLD_BSP=1, ovviamente :D

grande maximus ;)

non potevi essere più esauriente

ma mica sai se è possibile attivare in qualche modo (via script o tramite comando batch) il parametro photon emitted invece del photon density per l'IP?

ah poi già che mi trovo ;)...

sto facendo dei test sul FG con le diverse modalità ora sono sulla modalità expert con i seguenti param:

min radius 1

max radius 10

presample density 0,1

essendo la expert una modalità che offre una compatibilità con versioni precedenti di MR è possibile che per ottenere risultati puliti debba spingere i rays almeno a 800?... i tempi non sono male per una scena di media complessità... 11 minuti (con AA basso -2-1), ma siccome nella nuova modalità automatic mi bastano 100 rays e 100 points per ottenere un buon risultato qualche dubbio mi è venuto... è vero che una usa l'interpolazione dei punti e l'altra no ma è normale una differenza di rays così forte?


Edited by 3Dynamik

Share this post


Link to post
Share on other sites

Ciao, non so come si attiva tramite script o altro il photon emitted, ma da quel che so sono la stessa cosa, ovvero il Photon Emitted è identico al Photon Density, il Photon Density delle IP va calcolato in base alla dimensione di output del tuo render, Density = 1 è altissima parti sempre da 0.02 e sali.

FG in modalità expert non la uso mai e non sono ferrato in materia meglio se senti Dagon o qualcun'altro :D

Cmq da quel che so 800 raYs sono una follia omicida ! Io uso automatic e non supero i 150 se proprio va male, oppure Exact se ho la notte da buttare per il rendering.

Share this post


Link to post
Share on other sites

Hey maximus, probabilmente sbaglio ma non si attiva il BSP con questa soluzione, non cambia nulla.

Corregimi se sbaglio, ma il bsp non dovrebbe permettere di controllare tramite il density la creazione del BSP tree?

dovrei trovare i relativi parametri nel tab diagnostic del Mental ray renderer nelle render option ma nulla... tutto resta immutato.

commetto qualche errore?... dove dovrei trovare i parametri per controllare il BSP se non lì?

illuminami per favore.

Questo non c'èntra con il BSP ma in un'altro thread riguardante il FG mi dicesti che come modalità utilizzavi la automatic e quando avevi la notte da investire in calcoli lunghi usavi la modalità exact, io ho fatto dei test con questa modalità e vorrei segnalarti una discussione che ho aperto sull'argomento. Mi farebbe piacere ricevere un tuo commento e conoscere la tua esperienza in merito, te la linko ;)

http://www.treddi.com/forum/index.php?showtopic=67486

Grazie mille Max


Edited by 3Dynamik

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...