Vai al contenuto
cecofuli

- Test - Fps

Recommended Posts

Vediamo se vi piace questo semplice test. Può essere effettuato con qualsiasi macchina e software. Ho allegato il file in vari formati, max, 3ds e obj. Si tratta di un semplice modello in low poly con una animazione di una camera che ruota attorno all'oggetto (Orbit)

cecofuli%20test.jpg

Lo scopo è quello di verificare, con varie impostazioni delle suddivisioni, i FPS (Frame Per Second ) che il nostro sistema e softare riescono a gestire

Per leggere i FPS in 3ds max aprire con il notepade il file "3dsmax.ini" e aggiungere appena sotto la scritta [PERFORMANCE] (usare la funzione cerca) la stringa ShowFPS=1. Avviare 3ds max

1. Importare il modello

2. Creare un cerchio di raggio 100 ad un'altezza di 30

3. Impostare l'animazione a 200 FRAME

4. Creare una camera e con un Path Constraint linkarla al cerchio.

5. Impostare k'altezza del targhet a 25

Bene , la scena è pronta. Attivare l'animazione usando una sola schermata e leggere i valori dei FPS:

Questi sono i miei risultati : AMD 3200 + 1,5 GB Ram e Ge Forse Quadro 4 780 XGL

--------------------------------------------------

TURBOSMOOTH = 5 ( 2.375.680 Triangoli )

-------------------------------------------------

Shade ... : 14.50

wire ... : 1.85

wire+shade : 1.70

-------------------------------------------------

TURBOSMOOTH = 4 ( 593.920 Triangoli )

-------------------------------------------------

Shade ... : 53

wire ... : 6.8

wire+shade : 6.5

------------------------------------------------

TURBOSMOOTH = 3 ( 148.480 Triangoli )

------------------------------------------------

Shade ... : 85

wire ... : 21

wire+shade : 20

-------------------------------------

TURBOSMOOTH = 5 + Conversione a Mesh

-------------------------------------

Shade ... : 16.10

wire ... : 1.88

wire+shade : 1.72

-------------------------------------

TURBOSMOOTH = 4 + Conversione a Mesh

-------------------------------------

Shade ... : 48

wire ... : 6.6

wire+shade : 6.5

-------------------------------------

TURBOSMOOTH = 3 + Conversione a Mesh

-------------------------------------

Shade ... : 86

wire ... : 22

wire+shade : 21

<<< FORMATO MAX 7 >>>

<<< FORMATO 3DS >>>

<<< FORMATO OBJ >>>

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

io sono "fan"

quando torno a casa vi faro sappere (ma prima devo reistallare winboz:) perche la mogle mia quando si mette nel mio WS e non sa lavorae con windows mi fa entrare un sacco di farfarlle.. ieri ho vietato a toccare questa machina.. lei ha abbastanza forte machina con linux.. cosi sono tranquilo)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Non so se è colpa dei MAXtreme , ma penso che sia molto più complicato per una scheda gestire moltissime linee che una superficie colorata


Modificato da cecofuli

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

è normale, non è colpa dei maxtreme.

usando i driver directX la cosa di solito migliora leggermente.


Modificato da Polakow

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Un paio di prove al volo qui sul G5.

Alias Maya

Subdivision level = 2

Shade = Shaded

Triangles = 55680

fps = 100.1

-----------------------

Subdivision level = 2

Shade = Wireframe on Shaded

Triangles = 55680

fps = 66.4

-----------------------

Subdivision level = 2

Shade = Wireframe

Triangles = 55680

fps = 100.7

appena posso scrivo altri dati

la macchina è questa:

Apple Macintosh Dual 2GHz G5

RAM: 1.5 GB

Video card: GeForce FX 5200 64MB VRAM @ 1280x1024 85Hz

a presto

Mauro

P.S. lo so che è una prova insulsa come pesantezza ma per ora, al lavoro, posso fare solo questo :)

...di straforo e a breve il resto ;)


Modificato da MannaTheBerserk

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sto effettuando il test. Una sola curiosità: l'indicatore dei FPS non restituisce un valore fisso, ma è continuamente in movimento. Come faccio a capire il valore effettivo ?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Sto effettuando il test. Una sola curiosità: l'indicatore dei FPS non restituisce un valore fisso, ma è continuamente in movimento. Come faccio a capire il valore effettivo ?

fai caso a quale ricorre più spesso nell'arco di un minuto e mettici quello ;)

Mauro

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

dimenticavo che sul macintosh non gira 3dsmax e altri soft, quindi mi ritiro dai test effettuati dal lavoro...

...giusto per curiosità scrivo qualcos'altro, sempre Maya e sempre il G5:

Division level = 4

Triangles = 890880

Shaded = 7.2 fps

Shaded + Wire = 5 fps

Wire = 13 fps

---------------------------

8 divisioni di smooth non me le fa e provando a cancellare l'history e a riapplicare lo smooth il computer mi manda a stracagare...

...la scheda video è proprio pessima comunque. Poi dice che non bisogna comprare quelle professionali, bah.

See yah

Mauro

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Athlon 64 3000+, RAM 1GB DDR 333Mhz, scheda video GeForce 6800GT @ Quadro FX4000.

Ecco i miei risultati:

Turbosmooth 5

Wire: 1.78

Shade: 25.01

Wire + Shade: 1.82

Turbosmooth 4

Wire: 5.86

Shade: 61.38

Wire + Shade: 6.78

Turbosmooth 3

Wire: 17.08

Shade: 131.27

Wire + Shade: 22.67

Turbosmooth 5 + conversione mesh

Wire: 1.73

Shade: 33.42

Wire + Shade: 1.83

Turbosmooth 4 + conversione mesh

Wire: 6.01

Shade: 100.28

Wire + Shade: 6.02

Turbosmooth 3 + conversione mesh

Wire: 18.86

Shade: valore oscillante tra 2000 e 3000

Wire + Shade: 18.34


Modificato da Yoshiki

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Cavoli Yoshiki, abbiamo il processore e ram più o meno simili, quello che fa differenza è la Skeda, la tua è notevolmente migliore della mia, ma in Wire abbiamo gli stessi risultati!

:eek::eek::eek:

In shade hai più FPS , ma non c'è questo grande GAP. Usi i MAXTreme? Se fosse così la 6800 è veramente un flop con 3ds ! Io la mia l'ho pagata 75 euro!

Tengo a precisare che è una GF4 4200 @ quadro 780 !!!


Modificato da cecofuli

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Avevo notato anche io che l'unica differenza è nella visualizzazione in shade. Uso i MAXtreme 7.

Ho rifatto il test a 2 e 4 cavalli, giustoper curiosità e pubblico qualche risultato.

A 2 cavalli

TS 3

Wire: 9.33

Shade: 68.15

W+S: 9.93

TS 4

Shade: 26.50

TS 5 - 4.751.360 poligoni

Shade: 9.05

A 4 cavalli

TS 3

Shade: 25.92

TS 4

Shade: 8.25

TS 5 - 9.502.720 poligoni (ma il computer è quasi del tutto ingestibile, con circa 1.36 GB di memoria utilizzata)

Shade: 1.80

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Ehhmmm.. è una giraffa! :D Comunque non so se dire che son soddisfatto della mia scheda o son triste perchè avevo in mente di cambiarla :mellow:

Comunque sono ancora stupito dei nostri valori. sono praticamente uguali! Mi piacerebbe vedere dei test con una Quadro non moddada.


Modificato da cecofuli

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Secondo me è una zebra! :D

Comunque ho fatto i test con il mio computer: trattasi di un Athlon64 3500, 2gb di ram e ATTENZIONE: la scheda PCI express più caccosa del mercato: Sapphire Radeon X300SE (una scheda temporanea aspettando che la 6600gt difettosa mi ritorni funzionante, poi magari rifaccio il test).

Prima di postare i miei risultati volevo dire un paio di cose: una è che la suddetta scheda caccosa non mi permette di visualizzare gli oggetti con il backface culling attivato (in pratica non ha nessun effetto in viewport), quindi ho deciso di fare una prova disattivandolo anche in 3ds max, per essere alla pari.

L'altra cosa è che credo che in XSI il wireframe sopra lo shade possa essere visualizzato solo in modalità isoline, perciò, sempre per fare un test alla pari, ho messo in modalità isoline anche il turbosmooth di 3ds max.

Ecco i risultati:

3DS MAX TURBOSMOOTH = 5 (XSI SUBDIVISION = 5)

3dsMax shade = 3.17

XSI shade = 3.1

3dsMax wire (con backface cull) = 0.60

3dsMax wire (senza backface cull) = 0.57

XSI wire (senza backface cull) = 4.1

3dsMax wire + shade = 0.50

3dsMax wire + shade(isoline) = 1.22

XSI wire + shade(isoline) = 2.9

3DS MAX TURBOSMOOTH = 4 (XSI SUBDIVISION = 4)

3dsMax shade = 10.54

XSI shade = 11.3

3dsMax wire (con backface cull) = 2.40

3dsMax wire (senza backface cull) = 2.24

XSI wire (senza backface cull) = 15.4

3dsMax wire + shade = 1.98

3dsMax wire + shade(isoline) = 4.1

XSI wire + shade(isoline) = 10.7

3DS MAX TURBOSMOOTH = 3 (XSI SUBDIVISION = 3)

3dsMax shade = 28

XSI shade = 37.5

3dsMax wire (con backface cull) = 9.44

3dsMax wire (senza backface cull) = 8.10

XSI wire (senza backface cull) = 47.6

3dsMax wire + shade = 7.37

3dsMax wire(isoline) + shade = 12.77

XSI wire(isoline) + shade = 33.4

Da tutto ciò mi sembra di capire una cosa fondamentale: a 3ds Max non piace il wireframe (peccato che io lavori il 90% del tempo in modalità wire+shade).

Posto anche il file per XSI... azz, 121 kb non me li fa allegare. Ora provo con rapidshare...


Modificato da kawallo

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

ceco ma che ci hai messo la benzina dentro il pc prima di fare i test :D ...

a me ragazzi qua i conti non tornano, ho una dignitosissima ati fire GL da 128mb, e ho dei risultati troppo inferiori, soprattutto rispetto a quelli di ceco...

ai 148.000 triangoli, quella quota lì...senza turbosmooth+max6.0 mi fa 1.24wire+shade, e poco più del doppio negli altri due sistemi che sono un po' più veloci...un decimo rispetto a te ceco :eek: ...

...sec me alla fine è meglio prendersi una scheda video che costa poco e fargli le peggio cose invece che una buona e lasciarla com'è...o sbaglio?...

MAH...mi consolo con il processore che nei test che abbiamo fatto qua ha dato ottimi risultati...ma su questa cosa qua voglio vederci un po' più chiaro...


Modificato da florenceale

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

ho provato su un altro file e le cose invece vanno meglio a 1.800.000 triangoli mi fa ancora 3,80...questo era un albero pesante che avevo senza smussi...

poi ho riprovato con delle palle alla "pillus" :D ...con gli smooth...e va di nuovo male...mi sa che è questo smooth di max6.0 che o lo conteggia male e dice che ci sono meno facce di quelle che ci sono realmente o non funziona gran che sotto questo punto di vista...allora un fondo di verità in tutta questa questione c'è per davvero...

comunque nei tuoi risultati ceco c'è qualcosa di strano...come fa lo shade ad andarti in certi casi dieci volte più forte degli altri, a me va sempre di paripasso con il wire, il più lento è sempre wire+shade...

...in alcuni testi il wire+shade ti va identico al wire praticamente anche questo mi sembra un po' strano...

...non metto in discussione l'affidabilità dei test mi strafido di te, però sono risultati un po' strani...


Modificato da florenceale

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Floreanceale, in due , io e Yoshi, abbiamo gli setessi risultati, lui ha una 6800 e io una 4200. Anche a me sembra strano, ma ti giuro che i miei valori non sono taroccati. Ho appena prerso una 6600 da 256 MB. Stasera rifaccio i l test e poi ti dico

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

ma non sto mica dubitando ceco...figurati!...mi stai simpaticissimo :D ...

comunque ho capito che max6.0 è una chiatta veramente, o quantomeno non è minimamente compatibile con la mia scheda video...ieri sera mi son messo a sguinzagliare con maya per capire dove stava il problema era la prima che lo toccavo e sono venuti fuori questi risultati:

qua non si parla di smooth per max perchè c'è sempre la conversione in poligoni, sono dei cubi smussati e poi convertiti nuovamente...

MAYA6.0 PLE

100.000 facce (200.000 triangoli)

wire 26-32fps flatshade 11,6-12,8fps flatshade+wire 9,6-10.4fps

500.000 facce (1.000.000 triangoli)

wire 7-7.8fps flatshade 2,8fps flatshade+wire 2,2-2,3fps

(confronto con mauro che ha provato con 445.000facce)

wire 13fps fshade 7,2fps shade+wire 5fps

sono valori che si aggirano a quasi il doppio rispetto alle mie performance, considerando anche che ha qualche poligono in meno rispetto a me, ma ci può stare tra la mia scheda video e la sua...questo dato lo vedo inquadrato bene...

MAX6.0 driver openGL istallato correttamente

100.000 facce (200.000 triangoli)

wire 2,78fps shade 1,6fps shade+wire 1,09fps

500.000 facce (1.000.000 triangoli)

wire 0,55fps shade 0,42fps shade+wire 0,14fps

e questo scherzo me lo fa sia se converto i poligoni, sia se prendo un parallelepipedo e lo copio centinaia di volte fino a raggiungere il numero di poligoni voluto, anzi in questo caso a 100.000 facce è già in bambola.

eccezione è questo albero che avevo fatto con x-frog e che su max gira velocissimo, ormai è un file di max a tutti gli effetti. con questo ho risultati anche più veloci di maya

100.000 facce (200.000 triangoli)

wire 15fps shade 12fps shade+wire 12fps

500.000 facce (1.000.000 triangoli)

wire 3,8fps shade 1,6fps shade+wire 2,3fps

mi dispiace non aver potuto provare max7.0 ma mi è scaduta la trial e non me lo fanno più istallare, su max comunque vedo troppo divario rispetto ad altri risultati effettuati con max7.0

@mayani...ma chi l'ha detto che è difficile maya :D ?....le nurbs ho dato un'occhiata rispetto a studiotools mi sembrano parecchio "annacquate" :D ... :P:P:P ...


Modificato da florenceale

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

boh vabbeh comunque non c'è problema, max a me piace per tantissime altre cose, se capitano cose toste so comunque come gestirle, però ormai lo sfizio di capire me lo volevo togliere ^_^ ...un tantino inc----to sono...


Modificato da florenceale

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×