Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Ander

Problemi Displacement

Recommended Posts

Salve ragazzi,

avrei bisogno nuovamente del vostro aiuto e della vostra esperienza!!! Grazie anticipatamente per chiunque voglia rispondermi!!! :D

Dunque, sto modellando una delle magnifiche case di Wright per la mia tesi e devo affrontare il tema dell' uso del displacement per la realizzazione delle murature che sono tipo quelle della "falling water".

Premetto che ho il libro guida di mental ray che si sponsorizzava qualche tempo fa.

Purtroppo però non riesco a capire il motivo del perchè non mi visualizzi in fase di rendering il displacement quando applicato a queste murature.

dunque le mie domande sono:

1-Quando si parla della suddivisione dell' oggetto in mesh molto fitte per fare in modo che il displacement venga corretto, si intende che dovevo esportare la muratura da rhino in 3dmax ad una suddivisione molto alta?(premesso che la muratura in pianta è stata fatta con curve e poche linee rette è quindi da considerarsi non semplice)

2-dato che avevo una texture delle pietre(presa dal forum) che aveva una risoluzione di 72dpi 640x480 allora l ho modificata a 300dpi in photoshop. Da li per creare la mappa del displacement ho cliccato su scala di grigi ed ho dato l' ok alla richiesta di perdita delle informazioni dei colori. Nel fare ciò ho sbagliato qualcosa che mi serve al mio Obbiettivo?Come si ricava la mappa del displace?

3-Provando a creare un box ed ad applicare il displace noto che anche su un oggetto semplice non funziona la cosa...Avendo settato sia nel materiale che nel mental ray che nel shadow and displace del pannello render in modo corretto e nel pannello delle proprietà dell' oggetto, esiste per caso qualche altra casella nascosta da qualche parte che lo disattiva motivo per cui non me lo fa vedere?

4-per selezionare l' area dove voglio il displacement faccio questi passaggi: seleziono l oggetto, vado sul modificatore edit mesh e seleziono le region che mi interessano, poi assegno il materiale, successivamente uso il modficiatore uvw map do il box e cambio i valori. Faccio tutto in modo giusto?

Grazie mille :rolleyes:

Share this post


Link to post
Share on other sites

Non uso mentalray, ma ho fatto una prova veloce applicando un materiale standard ad un cubo, mettendo nello slot "displacement" una mappa noise, e nel rendering si vedeva il displace.

Adesso non ho ben capito se il tuo problema è questo.

Digitando in rete" mentalray displace" la prima voce che ho trovato è stata questa, non so se può esserti utile:

http://bettovagabondo.blogspot.com/2008/06...splacement.html

:hello:

Share this post


Link to post
Share on other sites

Grazie mille per le informazioni, purtroppo però non mi sono utili dato che uso una mappa e non un "noise"...ora proverò a vedere se col noise mi fa qualcosa..

altri pareri? :lol:

Share this post


Link to post
Share on other sites

Allora ricapitolando, devi caricare una mappa fatta da te (in bianco e nero) nello slot "displacement".

Io ho inserito, per fare la prova, una mappa noise, ma potevo inserire qualunque altra mappa in bianco e nero e sicuramente mi avrebbe dato l'effetto "displace" sul render.

Prova intanto a mettere qualsiasi altra mappa in bianco e nero sullo slot "displace" e vedi se funge. :hello:

Share this post


Link to post
Share on other sites
Guest

3-Provando a creare un box ed ad applicare il displace noto che anche su un oggetto semplice non funziona la cosa...Avendo settato sia nel materiale che nel mental ray che nel shadow and displace del pannello render in modo corretto e nel pannello delle proprietà dell' oggetto, esiste per caso qualche altra casella nascosta da qualche parte che lo disattiva motivo per cui non me lo fa vedere?

in ogni oggetto nelle propietà puoi controllare il displace, quindi attivarlo o disattivarlo, magari per sbaglio lo hai disattivato li.

cosa intendi per applicare il displace ? il displace si applica tramite un materiale assegnato all'oggetto in questione ( nel tuo caso il box )

in mr con il materiale arch e design hai lo slot dove inserire la texture in bn del displace,

Come lo vedi il tuo materiale nello slot ?, prova ad applicare la tua texture anche al canale diffuso per vedere se è visibile nel rendering.

Che versione usi di 3dsmax :blink2:

:hello:

Share this post


Link to post
Share on other sites

dunque, ho scoperto chq avevo una casella nel pannello common parameters nel riquadro option non era attiva la flag displacement.

tutto speranzoso che fosse per quello ho provato ad attivarla... ma ancora nulla...

io comunque ho provato ad inserire la mappa nello slot del displacement, ho la stessa mappa anche nello slot del bump.

Ma il displacement si deve vedere anche nello slot dell' anteprima del materiale?

Comunque nelle proprietà dell oggetto non cè un modo per disattivare il displacement, cè solo il modo per attivare le opzioni globali o locali, ed io ho provato entrambi....

Poi ho provato anche a mettere un noise ma ora che ormai ho selezionato la mappa mi fa scegliere automaticamente unaltra mappa da ricercare sul mio HD...proverò a fare un nuovo materiale

iutoooooo

la mia versione è il 2009 design


Edited by Ander

Share this post


Link to post
Share on other sites

ok mi sono ricordato come selezionare il noise.... quello sembra farmelo... ora provo con altre texture una col desaturate, una col gray scale e una con il black and white... vediamo

Share this post


Link to post
Share on other sites

Ok ho provato ad usare la mappa del displace recuperata dalla diffuse ma modificata in photoshop con aggiustamenti-->bianco e nero

prima cercavo di calcolare il displace con una mappa fatta in scala di grigio... evidentemente non funziona così!!!

Ora devo solo cercare di far combaciare gli spigoli regolando l' edge lengh e il min, max height... si dovrebbe far cosi penso... anche se non sono molto convinto che mi farà degli spigoli realisticamente corretti...

consigli su come farli?

grazias

Share this post


Link to post
Share on other sites

Dunque, ho un nuovo problema con il displacement penso... poichè quando renderizzo ora mental ray mi crasha con il fatal error dicendomi "cant allocate 12313...bytes"

Penso che sia dovuto al fatto che ho applicato a tutta la superficie perimetrale e interna della casa il displacement

E così nelle inquadrature ravvicinate mi crasha... poi sopratutto ora che ho messo un pò di prato con l hair and fur(anche se non so perchè ma non lo applica ad un "plane" pur selezionandolo con edit mesh).

Qualcuno sa consigliarmi su come gestire i file ed il displacement? cioè... per inquadrature ravvicinate devo creare altri file dove disattivare in alcuni punti "relativamente lontani" l' effetto del displacement?

Pensate possa risolvere i problemi di crash con l uso del "deep of field"?

:o grazie!!!

Share this post


Link to post
Share on other sites
Guest
Dunque, ho un nuovo problema con il displacement penso... poichè quando renderizzo ora mental ray mi crasha con il fatal error dicendomi "cant allocate 12313...bytes"

Penso che sia dovuto al fatto che ho applicato a tutta la superficie perimetrale e interna della casa il displacement

E così nelle inquadrature ravvicinate mi crasha... poi sopratutto ora che ho messo un pò di prato con l hair and fur(anche se non so perchè ma non lo applica ad un "plane" pur selezionandolo con edit mesh).

Qualcuno sa consigliarmi su come gestire i file ed il displacement? cioè... per inquadrature ravvicinate devo creare altri file dove disattivare in alcuni punti "relativamente lontani" l' effetto del displacement?

Pensate possa risolvere i problemi di crash con l uso del "deep of field"?

:o grazie!!!

magari si, puoi disattivare il displace per gli oggetti lontani e usare un bump oppure niente.

cant allocate 12313...bytes" non hai più memoria disponibile, se lavori su un sistema a 32 bit avrai

dei continui avvisi si questo tipo, con il displace o con hair and fur etc.

Share this post


Link to post
Share on other sites

quindi mi consigli di passare ad un sistema a 64 bit?... io uso vista home basic sul mio portatile ed essendo un XPS 1530 dell non posso tornare all' xp senza lasciare le funzionalità proprie del portatile progettato per vista.... però se mi dici che mettendo vista 64 bit si risolvono dei problemi...

se no cosa posso fare d' altro? perchè ogni volta cambiare e disattivare il displace e tornare ogni volta a selezionare le facce più distanti per ogni diversa inquadratura diventa un lavoro lento..

bho

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x

Ti piacerebbe rimanere sempre aggiornato sulle ultime novità nel campo della computer grafica?

Iscrivendoti alla Newsletter riceverai subito una mail con le indicazioni per scaricare gratuitamente:

  1. Le immagini HDRI presenti su HDRI pro
  2. Una sequenza di 300 immagini HDRI generata da Luca Deriu tramite il programma Real HDR