Vai al contenuto
bear75

Revit 2008 Opengl Crash

Recommended Posts

ciao a tutti,

uso revit 2008 per progettare/modellare edifici da importare in max 2009.

quando attivo l'accelerazione opengl per gestire modelli grandi e ombre, la vista va in crash e devo disattivare opengl.

ah, pc con vista 64 e 8800gt, nessun problema in max.

aiuto!

:blink2:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Probasbilmente il problema è il driver openGL che in vista è molto basilare... se non è stato implementato in revit fatica a funzionare. Non conosco revit per cui non so darti indicazioni specifiche.

Ma se lo usi in openGL anziché directx cambia molto? Perché magari anche lui funziona meglio con directx, come max d'altra parte! In tal caso ti sconsiglio a priori di usare openGL

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Probasbilmente il problema è il driver openGL che in vista è molto basilare... se non è stato implementato in revit fatica a funzionare. Non conosco revit per cui non so darti indicazioni specifiche.

Ma se lo usi in openGL anziché directx cambia molto? Perché magari anche lui funziona meglio con directx, come max d'altra parte! In tal caso ti sconsiglio a priori di usare openGL

non esiste ancora il supporto a directx in revit...

comunque in un altro pc con vista funziona perfettamente (vista 32 e scheda ati)

sul mio no (vista 64 e scheda nvidia)

boh

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Potrebbero essere i driver... dalla generazione hd2000 e geffo 8 le ATI supportano meglio le openGL

(Alla faccia di tutti quelli che dicono che le ATI dan sempre problemi coi driver... a me sembra di sentirne almeno altrettanti con Nvidia di sti problemi!)

Se ne hai la possibilità e se sei interessato, prova a fare alcune prove: letti la ati su sto pc e relativi driver e vedi se parte revit e/o viceversa.

Però i problemi potrebbero venire anche da chissà quali settaggi..


Modificato da papafoxtrot

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

I problemi nascono con le schede non professionali. Punto. Altrimenti nVidia ed ATI non sarebbero sceme a proporre al pubblico roba che costa il triplo se offrisse gli stessi vantaggi.

Revit è un programma che gira su OGL, usarlo su Vista con schede gaming è un po' una pazzia, un controsenso (sia OS che hardware hanno scarso supporto nativo per questa tecnologia). Tanto è vero che la stessa medesima scheda, utilizzata in D3D, va come deve...

Cmq quoto papax quando dice che i problemi potrebbero benissimo essere un errato settaggio delle performance del programma. Può capitare ogni tanto di avere attivo qualcosa che dovrebbe invece essere spento... È vero anche che programmi basati su CAD generalmente si autosettano, cmq un controllo è sempre buona cosa...

La butto lì: può darsi che il problema derivi dall'usare Revit 32 su Vista 64? Può essere una cretinata, però la dico lo stesso... :lol:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Se revit è scritto per openGL è ovviamente una qustione delicata e la cosa migliore sarebbe usare una scheda professionale. Ma se uno non ne possiede una non lo si può definire un pazzo... Ha quella e basta e probabilmente ha anche i suoi motivi per possedere quella e non un'altra (altri usi, costi...mille altri).

Vediamo dunque di capire come far funzionare sto revit con quello che abbiamo.

1) Su vista 32 bit con ATI funziona.

2) Su vista 64 bit con NVIDIA non va.

Si deve dire che le geforce hanno un supporto schifoso alle openGL e probabilmente i driver per vista 64 inseriscono ancora più problemi.

Comunque: io direi di fare un test incrociato, proviamo a scambiare le due schede video (eventualmente potresti forse anche tenerle così se funzionassero). Proviamo a cambiare versione di revit se esiste sia il 32 che il 64 bit.

E poi ne riparliamo...

Cia Bear!


Modificato da papafoxtrot

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Se revit è scritto per openGL è ovviamente una qustione delicata e la cosa migliore sarebbe usare una scheda professionale. Ma se uno non ne possiede una non lo si può definire un pazzo... Ha quella e basta e probabilmente ha anche i suoi motivi per possedere quella e non un'altra (altri usi, costi...mille altri).

Vediamo dunque di capire come far funzionare sto revit con quello che abbiamo.

1) Su vista 32 bit con ATI funziona.

2) Su vista 64 bit con NVIDIA non va.

Si deve dire che le geforce hanno un supporto schifoso alle openGL e probabilmente i driver per vista 64 inseriscono ancora più problemi.

Comunque: io direi di fare un test incrociato, proviamo a scambiare le due schede video (eventualmente potresti forse anche tenerle così se funzionassero). Proviamo a cambiare versione di revit se esiste sia il 32 che il 64 bit.

E poi ne riparliamo...

Cia Bear!

molto costruttivo e disponibile, grazie.

intanto ho cambiato driver, poi potrei passare a revit 2009 64bit.

vediamo!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×