Jump to content

Recommended Posts

In che modo il numero complessivo dei poligoni influisce sulla velocità del rendering? Lo chiedo perchè ho una scena che è arrivata a pesare 200 mb circa, con 4,5 milioni di poligoni e se prima ci metteva un'ora per renderizzare la scena ad una risoluzione piuttosto alta (FG preset High raddoppiato nei valori), adesso cene mette 4 con impostazioni ridotte (Medium)...e la scena non l'ho stravolta!

Ok potrebbe sembrare una domanda idiota, però lo chiedo perchè la lentezza si manifesta fin dall'inizio anche in quelle zone dove di poligoni ce ne sono pochissimi!

In che modo lavora? Fa un conto complessivo all'inizio dei poligoni e poi renderizza? O è il peso del file che influisce così negativamente?

Sto iniziando a preoccuparmi, anche perchè il pc è nuovo, piuttosto potente e vorrei sapere se sto sbagliando io qualcosa o è lui che si sta fondendo :(

Share this post


Link to post
Share on other sites

cosa intendi con "non l'ho stravolta"...? basta cambiare un materiale, magari dielettrico per aumentare i tempi in modo esponenziale. poi 4 ore di render con GI e FG su 4,5 milioni di poligoni non mi sembra male. dipende anche dal tipo di macchina che usi. che modifiche hai fatto alla scena per far aumentare i tempi?

Share this post


Link to post
Share on other sites

Ho aggiunto solo un paio di elementi, questi però sono il grosso dei poligoni...

La scena che prima renderizzavo in un'ora:

soggiornovistamare-13.jpg

La stessa com'è adesso:

soggiornovistamare-16.jpg

Il divano son 1,5 milioni di poligoni circa, ma non dava problemi...il termosifone sono oltre 3 (non riesco ad importarlo da Rhino con meno poligoni, diventa troppo "seghettato"), la pianta non son neanche 500 mila, ma è con quella che son iniziati i problemi! I materiali son tutti di tipo A&D e Promaterials, non ne uso altri per ora.

Con FG a medium, caustiche con 1000 fotoni e photon map a 8000 fotoni ci ha messo oltre 4 ore!

Lavoro su un dual quadcore con 8 gb di ram...non vorrei che lo stia fiaccando troppo :(

Share this post


Link to post
Share on other sites

Quanto è settato il limite di memoria di mental ray? Pannello processing della render scene.

Se è basso, e di default è basso, mr va in swap e il render diventa lentissimo.

A parte questo, 500mila poligoni basterebbero per tutta la scena.

Potresti anche provare a ottimizzare gli oggetti con optimize, multires o poligon cruncher.

Certo che se avessi modellato direttamente con i poligoni in max...

Ciao

Share this post


Link to post
Share on other sites

Se togli dalla scena il termosifone, i tempi si riducono?

Se si, allora è il termosifone. Non tanto per i poligoni, ma forse per qualche triangolo che tu non vedi ma che magari non è perfetto. Io lo rifarei e con molti ma molti meno poligoni. Evitaq di smootharlo tanto e prova con l'aproximation di mental ray.

Share this post


Link to post
Share on other sites

Ho modellato in Rhino per esercitarmi, e sempre per esercitarmi volevo creare una stanza semplice e un pò spoglia....poi aggiungi qui, aggiungi là..... :)

In 3dsmax ho fatto solo i muri, il divano e il bambù. Il limite di memoria l'ho lasciato di default a 650 mb, a quanto dovrei alzarlo?

Se togli dalla scena il termosifone, i tempi si riducono?

Ancora no, ma è nei miei piani! Aspetto che finisca l'ultimo render

Io lo rifarei e con molti ma molti meno poligoni

Rifare il modello in Rhino o l'importazione? Ho provato a reimportarlo a più basso dettaglio e ho guadagnato un milione e mezzo circa di poligoni, ma è ancora lenterrimo! :(


Edited by Grinder

Share this post


Link to post
Share on other sites
Ho modellato in Rhino per esercitarmi, e sempre per esercitarmi volevo creare una stanza semplice e un pò spoglia....poi aggiungi qui, aggiungi là..... :)

In 3dsmax ho fatto solo i muri, il divano e il bambù. Il limite di memoria l'ho lasciato di default a 650 mb, a quanto dovrei alzarlo?

Con 8gb ti direi di metterlo a 4500, massimo 6500.

Share this post


Link to post
Share on other sites
sfruttamento delle cpu

A riposo intendi giusto? Sembra normale, intorno al 0-1% di media. Ce n'è una che lavora più delle altre, credo sia normale, ma non ho mai avuto un multiprocessore prima d'ora.

I settaggi:

Settaggi.jpg

Risoluzione a 1280x800 (16:10)

Gli shader non hanno mai dato problemi, quelli più impegnativi erano per il bambù e per le foglie della piantina, prima anche con tutte quelle riflessioni non era un problema, nemmeno l'hdri del lampadario!

Share this post


Link to post
Share on other sites
A riposo intendi giusto? Sembra normale, intorno al 0-1% di media. Ce n'è una che lavora più delle altre, credo sia normale, ma non ho mai avuto un multiprocessore prima d'ora.

I settaggi:

Risoluzione a 1280x800 (16:10)

Gli shader non hanno mai dato problemi, quelli più impegnativi erano per il bambù e per le foglie della piantina, prima anche con tutte quelle riflessioni non era un problema, nemmeno l'hdri del lampadario!

No, intendo durante il render, tutte le cpu dovrebbero stare al 100%.... se come temi c'è un problema a livello dello sfruttamento delle risorse, te ne puoi accorgere da li

Le impostazioni sono tutte ottimizzabili di sicuro, a partire dal FG, ma non mi sembrano settagggi così estremi da metterci 4 ore a quella risoluzione....

Però, "Prima" di cosa? non hai un salvataggio della scena che renderizza a velocità normale? e soprattutto, dovresti ricordarti di preciso cosa hai cambiato.....

In ogni caso potresti mergiare la scena in un file nuovo e vedere se va a posto reimpostando i settaggi di render da zero.

Ciao


Edited by nicolce

Share this post


Link to post
Share on other sites
Le impostazioni sono tutte ottimizzabili di sicuro, a partire dal FG, ma non mi sembrano settagggi così estremi da metterci 4 ore a quella risoluzione....

Infatti erano settaggi per le prove :)

Ho renderizzato a preset "High" e ci aveva messo 45 minuti circa, sempre alla stessa risoluzione....è possibile che più sistemi daylight insieme (per errore ovviamente) siano la causa?

Purtroppo non ho fatto dei backup di com'era prima :(

Share this post


Link to post
Share on other sites
Infatti erano settaggi per le prove :)

Ho renderizzato a preset "High" e ci aveva messo 45 minuti circa, sempre alla stessa risoluzione....è possibile che più sistemi daylight insieme (per errore ovviamente) siano la causa?

Purtroppo non ho fatto dei backup di com'era prima :(

Ottimizzabili nel senso che si potrebbero abbassare non di certo alzare.... quelli non sono assolutamente settaggi di prova per me.

Comunque per la questione di 2 daylight non saprei.

Share this post


Link to post
Share on other sites

Si non sono molto bassi come prove, mi son lasciato prendere dall'euforia del pc nuovo :P

Comunque credo di aver capito...c'erano due daylight system in più! E sai perchè? Le piantine che son nel vaso (tranne il bambù) sono quelle scaricabili proprio da qui su Treddi...e alcune di quelle avevano un sistema proprio, solo che non lo sapevo, erano molto distanti dall'oggetto sul quale stavo lavorando e non me ne ero :angry: accorto!!!!


Edited by Grinder

Share this post


Link to post
Share on other sites

Eppure c'erano...già che ci siamo, ho un problema di bagliori strani che non riesco a risolvere. Se guardi attentamente la finestra si notano dei bagliori, come un alone più chiaro! Non riesco a toglierlo!!! A cosa potrebbe esser dovuto? Se metto un materiale poco riflettente o addirittura un promateriale wallpaint si attenua molto...eppure l'area light è dietro :blink2:

Anche la tapparella fa un effetto strano dietro al vetro...


Edited by Grinder

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...