Jump to content
avalu81

Problema Vraydisplacementmod

Recommended Posts

Un quesito:

per realizzare l'erba su un oggetto poligonale in cui ne è stato sottratto un altro, uso il vraydisplacementMod. Il problema è che i filamenti si dispongono in maniera tale che se l'oggetto, avendo una forma strana, ha delle facce triangolari, queste risultano visibili in fase di render.

In parole povere, la mesh, presenta delle facce, queste saranno visibili anche in fase di render con il displacement sotto forma di parti piu scure. è possibile risolvere questo problema che ho sempre avuto????

Uso il displace3d, possibile che con il displace2d non riesco ad ottenere alcun displace?

se non si riesce a capire, eventualmente posto una immagine appena possibile

Share this post


Link to post
Share on other sites

non so mi sa che altre volte ci avevo provato e non dava risultati. ho provato a costruire la geometria direttamente in 3dsmax senza importare da autocad, ma nulla, il problema è sempre uguale.

Share this post


Link to post
Share on other sites

Mah, io ho creato l'erba del mio wip con un piano (edit poly) con un modif uvw map e vraydisplacementmod (2d mapping) e applicanto una mappa grass bump come texture del displacement e il risultato è molto buono.

Com'è che ti esce a te?

Share this post


Link to post
Share on other sites

a me col displace2d non viene fuopri assolutamente nulla, il piano resta liscio così come l'ho creato

cmq adesso renderizzo solo l'oggetto e posto l'immagine così ci spieghiamo meglio

Share this post


Link to post
Share on other sites

th_15904_er1_122_986lo.jpg

th_15921_er2_122_738lo.jpg

ecco cosa ottengo io...se guardate bene nella prima si vedono proprio i triangoli dagli spigoli delle bucature interne, nella seconda si vedono sia i triangoli, sia una sorta di scacchiera....

non so è un problema che incontro il 95% delle volte che uso il displace....3d, perchè col 2d non vedo proprio il displace.....

in questo esempio ho usato una mappa noise....

Share this post


Link to post
Share on other sites

Per il displace 2d ti consiglio questa mappa, l' erba viene discreta, chiaramente non come con il displace 3d ma in questo caso è leggero il calcolo...

Come impostazioni prova a dare l' amount a 10 cm, al 2d mapping dai 2048 come resolution e 20 come precision che sono parametri che ho usato quando ho l'erba in primo piano, altrimenti li puoi anche diminuire, insomma vedi te...

Per quell'altro discorso di solito uso un plane per il displace e non un solido altrimenti il displace te lo calcola per tutte le facce,spero di essere stato utile a qualcosa...ciao

Share this post


Link to post
Share on other sites

alla fine ho provato il displace2d e non so per quale motivo, il problema del non vedere nulla era dovuto alla mappa noise che utilizzavo. Non so per quale motivo, ma con il 2d la mappa noise non mi da alcun effetto.

Con altre mappe ottengo un risultato buono, non sono visibili, scacchiere, triangoli ecc...anche se in alcuni punti si hanno zone più scure come se vi fosse una sovrapposizione di piani...che non c'è...va beh gia abbiamo fatto un passo avanti.

GeometraOrsini, grazie per la mappa la salvo e provo ad utilizzarla ^_^

Share this post


Link to post
Share on other sites

Guardando l'immagine mi sembra un problemi di mappa oppure di scala del uvw mapping che deve essere setta meglio. Nell'immagine anche le ripetizioni della texture, problemi di zone più scure posso essere date anche dalla mappa di noise.

Ciao by Dgrafica

Share this post


Link to post
Share on other sites

questa è una prova veloce fatta su un semplice cubo creato in 3dsmax.

con il displace 3d si vede ancora la famosa scacchiera

th_69870_cubo_displace_122_557lo.jpg

con il 2d l'immagine sembra pulita

th_69885_cubo_displace2_122_568lo.jpg

ora se qualcuno riesce a dare una spiegazione del perchè questo avvenga anche su un solido regolare e un piano regolare, me lo faccia sapere...

Share this post


Link to post
Share on other sites

Guarda a me sembra un problema di uvw mapping se vuoi salva il file lo posti cosi ci do un occhiata vediamo se capisco al causa. Facendo File --> archieve di questo cubo . Di più non so dirti .

Ciao by Dgrafica

Share this post


Link to post
Share on other sites

La uvw map è impostata perfettamente sulla dimensione del cubo 4x4x4mt.

cmq ora sono al lavoro, appena torno a casa stasera posto la prova e vediamo, magari sono convinto di fare bene e in realtà sto facendo qualche cavolata immane...

ciao

Share this post


Link to post
Share on other sites

Le facce che si vedono nell'immagine che hai postato sono veramente esistenti (cioè è un cubo da 10x10x10 segmenti per esempio) o è un semplice cubo da 1x1x1?

Il mio sospetto è che il displacement si riproponga ogni volta per ogni poligono.

In questo caso ti consiglio di provare a ricreare il terreno utilizzando il comando extrude da una Spline ricalcando il lavoro già fatto e poi aggiungere il displacement...

Ne approfitto per chiedere una cosa: il displace del materiale so che è una cosa, mentre il vraydisplacementmod è un'altra, cioè un modificatore. I modificatori uvw non dovrebbero avere effetto SOLO sui materiali, e NON sui modificatori?


Edited by flatland

Share this post


Link to post
Share on other sites

La domanda che hai fatto non l'ho capita....cmq il cubo è 1x1x1 e ho provato anche a importarmi da cad la spline, renderla mesh e poi estruderla, il problema è sempre lo stesso e si ripropone ogni volta che uso il displace3d

Share this post


Link to post
Share on other sites

oh, la domanda era in generale, (curiosità mia) per chi mi sa rispondere...

Il mio sospetto è che comunque usando modificatori uvw non cambi niente.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...