Jump to content
lecorbudar

Albero E Persone Con La Tecnica Dei Piani

Recommended Posts

Ciao a tutti.

Vorrei inserire nella mia scena delle persone e degli alberi utilizzando la comunissima tecnica che consiste nel realizzare dei piani a cui assegno un materiale costituito da due immagini: una con l'immagine dell'albero e l'altra con la sagoma bianca su fondo nero per la mappatura delle trasparenze.

Renderizzando con mental ray (precisamente utilizzando il physical sky and sun) ho un problema:

l'ombra generata non è quella dell'albero, ma quella rettangolare del piano. Ma il fatto più strano è che mentre renderizza, dapprima sembra che vada tutto bene, cioè l'ombra dell'albero è corretta; poi, di colpo, quando il motore render pasa i dettagli, questa scompare ed appare quella del piano e in un angolino si vede una sagoma più scura dell'albero. Vi allego un'immagine tanto per rendere l'idea

Qualcuno sa come aiutarmi?

P.S. se renderizzo con maya software non si verifica questo problema.post-19611-1221674461_thumb.jpg

grazie.

Share this post


Link to post
Share on other sites

haiprovato ad apllicare la tua mappa trasparenza nella finestra cut otu invece che nell'opacity?

ops...

però tu usi maya, non so se hai sti valori....

fai una prova, sennò passo... :P

Share this post


Link to post
Share on other sites
Se usi un mia_material, vai su advanced\cutout opacity. Poi mi sorge un dubbio, hai mappato il piano, hai assegnato un planar map?

Grazie per le risposte.

Ho provato con il mia material, ma nn ho risolto. Il risultato lo vedi in figura. Anche in questo caso mentre renderizza va tutto ok, l'ombra la fa bene; ma poi quando fa i dettagli, ne taglia via un pezzo.

Scusa l'ignoranza, ma cosa intendi quando dici assegnare un planar map?

grazie ancora

post-19611-1221726723_thumb.jpg

Share this post


Link to post
Share on other sites

io non uso da un bel pò maya ma vedendo l'ultima immagine mi sembra che la texture in diffuse ha una mappatura,invece la texture in opacity non ha nessuna mappatura.devi mappare tutte e due le texture x avere l'effetto desiderato.per ombre prova a vedere se sulle ombre generate dalla luce c'è l'opzione opacity shadow,forse è questo.in caso contrario prova a cambiare luce.

Share this post


Link to post
Share on other sites

Ascolta, io ho fatto una prova veloce per togliermi il dubbio, ma non ho riscontrato nulla di strano, neanche non assegnando una planar map che trovi nel modulo polygons di maya, in alto a sinistra sotto file.

Quello che mi sembra è che le due textures siano diverse e che abbiano delle proprietà diverse. Potresti postare uno screenshot dei collegamenti nell hypershade?

Stai usando la stessa immagine? puoi anche postare l'immagine o se vuoi il file così vedo direttamente. E' veramente una cosa strana.

Share this post


Link to post
Share on other sites
Ascolta, io ho fatto una prova veloce per togliermi il dubbio, ma non ho riscontrato nulla di strano, neanche non assegnando una planar map che trovi nel modulo polygons di maya, in alto a sinistra sotto file.

Quello che mi sembra è che le due textures siano diverse e che abbiano delle proprietà diverse. Potresti postare uno screenshot dei collegamenti nell hypershade?

Stai usando la stessa immagine? puoi anche postare l'immagine o se vuoi il file così vedo direttamente. E' veramente una cosa strana.

grazie per l'interessamento

eccoti lo screenshot e l'immagine dell'albero

post-19611-1221733710_thumb.jpg

post-19611-1221734030_thumb.jpg


Edited by lecorbudar

Share this post


Link to post
Share on other sites

allora, per il discorso dell'ombra che ti viene fuori mappatura, non so che dirti, onestamente. A me non sta capitando.

E senza file non so che dirti, se vuoi puoi spedirmelo sulla mia e-mail

Share this post


Link to post
Share on other sites

vedo che è collegato ilmale e molto probabilmente ti può dare un aiuto.

:) ti ho infilato dentro la discussione.


Edited by ytsejam

Share this post


Link to post
Share on other sites

o.O

Mi dispiace deludere le vostre aspettative ma anche a me il suo problema non viene, l'unica accortezza che ho dovuto prendere è che per collegare quella immagine al "Cutout opacity" è stato di convertirle l'immagine alpha in luminosità con il nodo utilities luminance, altrimenti colleghi l'alpha dell'immagine e le jpg non hanno alpha.

Altra cosa, se vuoi avere dei colori buoni con il daylight system devi gamma correggere l'immagine.

cotoutwv9.jpg

Share this post


Link to post
Share on other sites

apprfitto della discussione per chiedere un chiarimento!è possibile collegare la rotazione degli alberi alla camera in modo da averli sempre di fronte al piano visivo, come avviene usando plugin tipo forest pack per 3dmax?

grazie in anticipo,intanto per la spiegazione dettagliata dello shader per gli alberi

Share this post


Link to post
Share on other sites

Credo che sia un problema escusivo del mia physical sky and sun, perché ho fatto una in un altro file con solo l'albero e un piano su cui proiettare l'ombra e si verificava la stesso problema.

Mentre utilizzando una semplice luce direzionale e renderizzando sempre in mental ray tutto ok.

sarà un problema della mia versione di maya 2008? effettivamnete qualcosa di strano ce l'ha, ad esempio non c'è il motore maya vector neanche a caricarlo tra i plug-in...

grazie cmq!

Altre strategie su come inserire gli alberi nella mia scena?

Share this post


Link to post
Share on other sites

@roberto: puoi usare il constrain "aim" per girare gli alberi sempre verso la camera.. certo che quando sono tanti inizia ad essere una rottura di scatole collegarli tutti..., al massimo ti fai un semplice script. :-\

@Lecorbudar: ci puoi passare il file che da il problema? Quello semplice dico, dovrebbe occupare poco.


Edited by ilmale

Share this post


Link to post
Share on other sites

hey, a me non da nessun problema il tuo file, Tu usi maya 2008 x64. Anche io uso la stessa più il service pack one, ma non ho sentito e non mi era mai capitato qualcosa del genere. però a me il tuo file, non da problemi.

L'ho aperto così come lo hai inviato tu, gli ho dato il percorso delle textures che avevo e renderizza tutto ok.

Hai provato a ricreare il tuo sky phisical?

Fai un delete dal render setting, pulisci la scena, optimize scene files e riprova a crearlo di nuovo, il phisical sky, ovviamente.

Share this post


Link to post
Share on other sites

Mi piacerebbe risolverti il problema, ma ripeto, il file che mi hai mandato, problemi no ne da. E' strano, perchè sembrerebbe un bug, ma non mi è mai capitato e ne ho sentito in giro un problema sulla versione 2008(non service pack). E comunque questo problema ti capita anche se fai un file nuovo? da zero?

Misterioso......................

E pensavo................... reinstallare Maya?

eliminando le preference,


Edited by ytsejam

Share this post


Link to post
Share on other sites

anch'io penso sia un bug, perché anche partendo da zero me lo fa...

reinstallare maya... non me la sento...non vorrei fare qualche caz..ta, dato che non sono un mago informatico.. E' per la mia tesi di laurea (ottobre) e ci sto lavorando da oltre un anno.

se non riesco trovare altri espedienti (tipo paint effect, che nn conosco per nulla) mi sà che aggiungerò alberi e persone in photoshop, anche se non ho idea di come simulare la presenza di oggetti dietro ad un vetro. vedremo!

Share this post


Link to post
Share on other sites

Allora, da quel che ho visto stai usando un semplice lambert... ora non so se il service pack abbia risolto quel bug (se vogliamo intenderlo tale), Se vuoi risolvere il problema, vai nei settaggi del Lambert apri la tendina "Raytrace Options" e li metti a "0" il valore di "Shadow Attenuation"....

Il problema si ripresenta anche usando normalmente il Mia_Material... ma viene passato dall'uso del "cutout opacity".

Spero di esserti stato utile ;)

Share this post


Link to post
Share on other sites

NON CI POSSOOO CREDEREEEEEEEEE!!!!!

grazie ragazzi per i vostri consigli, comunque molto ultili sotto diversi aspetti, ma la questione era un'altra:

non so come mai, ma nel file attributes (sia dell'immagine dell'albero che della sagome in bianco e nero) per default c'era quadratic; quindi mi è "bastato" mettere su off per risolvere il problema. Non capisco come mai non ci fosse off come default, infatti le altre volte che ho fatto qualcosa del genere, ma parlo di un paio di anni fa con maya 7, non ho avuto questo problema.

tra lambert e mia material ottengo risultati migliori con lambert (anche perché per ora nn ho tempo di esplorare le caratteristiche del mia material). Ovviamente correggendo la texture col gamma correct!

vabbé, problema risolto in un modo o nell'altro, grazie ancora! :Clap03:


Edited by lecorbudar

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...