Vai al contenuto
Arch Streppone

Multisubobject Per Falde Tetto

Recommended Posts

L'oggetto tetto ha 2 falde inclinate alle quali ho dato rispettivamente id1 e id2

- Nel material editor scelgo un materiale multisub nel canale id1 metto la mappa dei coppi che di defalt ha map channel 1.

analogamente faccio per il canale id2, metto la stessa mappa ma gli cambio il mapchannel in 2.

- aggiungo due modif. uvw map planar con i rispettivi map channel 1 e 2.

problema :wallbash:

per la falda con id1 tutto ok riesco a mappare vedendo interattivamente la mappa che si muove quando la scalo o la riposiziono, per la falda 2 invece la bitmap risulta fissa ed impassibile alle mie modifiche che si palesano solo in fase di rendering.

questa cosa a volte mi succede e a volte no, vorrei capire se trattasi di magia o di imperizia.

Ciao e grazie.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

segui quseto schema

obj id 1

uvmap chan 1

texture chan 1

obj id 2

uvmap chan 2

texture chan 2

il tuo errore consiste nel fatto che hai messo al posto di texture chan 2 la texture chan 1

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
segui quseto schema

obj id 1

uvmap chan 1

texture chan 1

obj id 2

uvmap chan 2

texture chan 2

il tuo errore consiste nel fatto che hai messo al posto di texture chan 2 la texture chan 1

forse sono io che non mi sono spiegato bene, ma mi sembra di aver seguito lo schema che dici tu infatti ho 2 modificatori uvw map con mapch. rispettivamente 1 e 2 dai quali dovrei controllare rispettivam. i texture channel che pure sono 1 e 2 che a loro volta sono collegati agli id dei poligoni mappati che pure sono 1 e 2.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Se non ti funziona fatti due materiali separati così non stai a perdere tempo con l'ID channel

si alla fine ho risolto cosi' pero' rosico quando le cose non seguono regole ben precise, inoltre se voglio usare il displacement mod ho bisogno di continuità geometrica delle falde per usare il keep continuiti.

Ciao e grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×