Vai al contenuto
Frjariello

[max] Inserire Nuovi Oggetti In Animazione

Recommended Posts

Ciao,

dovrei inserire delle auto su una strada (utilizzo degli RPC), pero' non vorrei farle visualizzare sempre, ma solo quando sono inquadrati dalla Camera, sia per un fatto di velocizzazione, sia perche' mi dovrei disegnare tutto la traiettoria della strada.

In pratica vorrei che la mia auto comparisse dal frame 200 e si movesse fino al 300 (ad esempio), ma se li inserisco (anche creando delle key) mi partono sempre dal frame 0 e quando arrivo a 200 si sono già fermate!! :(

Penso bisogni agire sull'editor curve, ma dove?!?!?

TNX

bye bye

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Premettendo che io utilizzo max 5... ti posso dire che per fare prima io faccio così:

seleziono l'oggetto animato, sotto nella timeline quindi si visualizzano anche i keyframe, esempio : partenza:frame 0, arrivo frame 100...

premendo sulla timeline è possibile muovere le chiavi portandole avanti esempio partenza:frame 30, arrivo:50...

piccolo metodo senza metterre mano a video post o editor curve...

spero di essere stato chiaro... alle volte è più facile farlo che spiegarlo...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ti ringrazio per la veloce risposta ;)

Premetto che ora sto iniziando ad animare degli oggetti :(

Ho provato con un cubetto, e seppure lo inserisco al frame 100, questo e' visibile gia' dal frame 0, mentre correttamente l'animazione (una rotazione) parte dal 100 e termina al 200, e queste due key (100 e 200) le posso, come dicevi tu, spostare dove mi pare.

Il mio problema e' pero' che io non voglio vedere il cubetto gia' dal frame 0, ma mi deve comparire solo dal frame 100 in poi!

Poi la cosa, nel caso auto RPC, si aggrava perche in realta' oltre la visibilita' l'oggetto e' associato ad una traiettoria e quindi anche questa dovrebbe iniziare solo da un determinato frame.

Mi hanno detto che in Maya c'e' la possibilita, tra le proprieta' degli oggetti, di attivare o disattivare la 'visibility', ma in max c'e'??

Ancora GRAZIE! :)

bye bye

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
cerrrtooo che c'è... selezioni il tuo oggetto, tasto destro>proprietà e deselezioni il flag "visibile in cinepresa" e se ti serve anche "ricevi ombre" e "proietta ombre"

VADO SUBITO A PROVARE!! :)

TNX

bye bye

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

in 10 minuti ho fatto una prova, che ti puoi scaricare in allegato... è in max 5 , credo possa andar bene,ho assegnato all'oggetto un controller bezier di visibilità..

fammi sapere


Modificato da ruzzichino

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
non mi allega il file... se mi dai la tua mail te lo spedisco...

ciauzz

Sei troppo gentile :) frjariello@libero.it

Cmq ho provato la visibilita' e ovviamente... FUNZIONA!! :w00t:

Ora devo vedere le traiettorie...

TNX

bye bye

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Inviata (modificato)

Ok, ho risolto il problema visibilita... l'esempio di ruzzichino mi ha chiarito gli ultimi dubbi... GRAZIE!! :D

Ora pero' non riesco a far muovere le auto solo a partire da un determinato fotogramma, in quanto queste, seppur non visibili, iniziano il movimento dal frame 0 :(

Il problema e' il movimento lungo una traiettoria spline, in quanto se mi posiziono manualmente l'auto in un determinato punto al frame 100 poi a 150 in un altro e a 200 in un altro ancora, ovviamente funziona, mentre se la vincolo ad un percorso (alcuni rpc lo fanno in automatico) l'auto inizia il movimento al frame 0 :(

Diciamo che potrei anche optare per la soluzione manuale, la strada e' abbastanza regolare, ma mi piacerebbe approfondire l'argomento anche per il futuro :)

GRAZIE!

bye bye


Modificato da Frjariello

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Sempre io... anche in questo caso è valevole la spiegazione di prima...

crei la spline percorso, l'oggetto... poi vai sulla scheda movimento> assegni all'oggetto un vincolo di posizione percorso...

ovviamente parte dal frame 0 fino al 100 (o il valore finale della tua animazione)

vai sempre sulla time line e sposti il keyframe iniziale (esempio dal frame 0 al 35) et voilà...l'oggetto iniziera a spostarsi proprio da quel frame

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Sempre io... anche in questo caso è valevole la spiegazione di prima...

vai sempre sulla time line e sposti il keyframe iniziale (esempio dal frame 0 al 35) et voilà...l'oggetto iniziera a spostarsi proprio da quel frame

Vabbe' per oggi ti debbo una pizza!! :D Se passi per Napoli fammi sapere :D

Ho provato col solito cubetto ed e' tutto ok, con gli RPC un po' meno, ma penso che sbaglio qualcosa, ora ci riprovo!

Ancora GRAZIE!! :w00t:

bye bye

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
P.S. sono a napoli quest'estate...esattamente il 12 agosto per il trofeo birra moretti.... se ti va la pizza me la puoi spedire con SDA... :D  :D  :P  :D  :P

Effettivamente una bella birra ci sta' una favola sulla pizza!! :D

bye bye

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×