Vai al contenuto
uncle pritt

[mental Ray] - Errore Ombre Su Materiale Composite

Recommended Posts

ciao a tutti

ho deciso utilizzare mental ray per fare i render e i filmati del castello della mia tesi. oggi mi sono imbattuto nel primo problema

test_1.jpg

questa è una porzione della torre del castello.

ho fatto un materiale composite;

-di base c'è uno standard material con la texture dei mattoni

-ho aggiunto un altro materiale standard per aggiungere i blocchi sopra e sotto la finestra

-il materiale dei blocchi ha il diffuse, un bump e un opacity messi con lo stesso channel, mappati correttamente e

togliendo la possibilità di ripetizioni così da posizionare esattamente in quel punto i blocchi

il composite è impostato con additive a 100

ho mappato la finestra con un suo uvwmap channel e la torre in generale con un proprio channel

sistema mr sun e mr sky con final gather e con mr photographic exposure

c'è una parte in alto vicino alle mensole triangolari che è trasparente, proprio nella zona in ombra e succede solo quando attivo l'opacity dei blocchi, cosa di cui non posso farne a meno.

succede anche senza final gather

non so che fare :crying:


Modificato da uncle pritt

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Non sapreo come risolverti questo, uso molto raramente composite e mix vari... prova ad usare materiali A&D al posto degli standard,e al posto di opacity usa cutout.

Se non sono indiscreto ti vorrei chiedere una cosa, perchè hai deciso di usare mr?

Hai un buono skill in vray e avevi trovato un setup efficace.

Ciao


Modificato da nicolce

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ho provato anche con ad&d, uguale: col cutout mi lascia una patina bianca su tutto quello che non è il blocco di pietra, ovvero mi va ad addizionare alle text che sono sotto in gerarchia nel composite

sono passato a mr visto che è un progetto scolastico di studio, quindi ho possibilità di approfondire questo renderer.

se pero' non riesco a passare questo ostacolo mi sa che si ritorna indietro. poi mental mi ha sempre affascinato

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Hai provato a utilizzare blend al posto di composite?

In extremis potresti fare gli architravi con modellati, alla fine sono pochissimi poly.

So che sei già abbastanza alto con il polycount, ma non penso sarebbe la goccia che fa traboccare il vaso :D

PS:Anch'io sono passato da vray a mr, per motivi di lavoro, e anche se continuo a stimare il vraggio come un'ottimo renderer, devo dire che personalmente mi piace più mr.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

col blend non ho nessun problema, ma il composite mi da' parecchi grattacapi

anche a me vray piace in fondo in fondo, anche se per l'occlusion trovo sia piu' veloce mr.

non voglio fare un paragone tra i due se no ci riempiamo di flame

tornando al problema: non so che fare.

cmq il composite mi lascia una velatura e l'opacity del materiale che metto sopra la base influisce anche quello che sta sotto invece di creare una specie di "etichetta"


Modificato da uncle pritt

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

C'è qualche motivo per cui non puoi usare blend?

Ho fatto una ricerchina, e ho trovato questo------->link

Per vedere le immagini mi sa che ti devi iscrivere, il problema è lo stesso ed è legato al metodo di calcolo delle ombre pare.

Ciao

ps: le comparazioni mi annoiano, soprattutto se si parla di sue renderer così simili, e poi li uso entrambi quindi non vedo possibilità di flame :D ero solo curioso dei tuoi motivi, comunque credo che tu faccia bene a diversificare le tue conoscenze.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

tranqui, non dicevo a te flame, ma a possibili flammatori... ;)

ora ho alto errore

questo è il materiale standard di base con il 2-sided attivato e disattivato. da mani nei capelli

test_2.jpg

test_3.jpg

cos'è quella riga nera in mezzo!!!

non è problema di mapping visto che è una superficie bend

dentro i buchi delle finestre teoricamente ci sono poligoni dati da un extrude negativo, ma vengono fuori degli abomini

il blend non lo posso usare qui perchè visto che voglio evitare di aggiungere altra geometria e ho piu' di una finestra da aggiungere, e con blend sarebbe troppo complicato da gestire; già la mappa base è di 2000 di lato e è ripetuta un paio di volte, se ci disegnassi sopra una mappa per gli architravi farei una mappa da almeno 4000 di lato. faccio un materiale base per le torri, poi con uvwmap planari distribuisco le mie architravi per le varie finestre, tanto non ne ho piu' di 8 per torre

grazie del link, l'avevo trovato pure io oggi, ma purtroppo le ombre erano già settate di default come suggeriva jeff.

cmq sembra che si sia sistemato quello....

mah...troppi problemi...

grazie dell'attenzione nicolce ;)

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
ciao a tutti

ho deciso utilizzare mental ray per fare i render e i filmati del castello della mia tesi. oggi mi sono imbattuto nel primo problema

Ciao Uncle Pritt, purtroppo non uso Mental Ray e non saprei come risolvere i problemi che poni, ma sarei curioso di sapere il motivo che ti spinge ad usare Mental per la resa finale del tuo castello (bellissimo!) piuttosto che vray col quale avevi iniziato...

Grazie e buon lavoro.

:hello:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ieri notte ho fatto altre prove e ho visto che quelle righe compaiono solo quando attivo le ombre del mr sun del daylight system. se cambio la luce in una standard col multiplier alto, per simulare il sole e lasciando attivato il mr sky, le righe spariscono :blink:

stessa cosa se disattivo le ombre generali dal pannello di mental ray

sequel: sono momentaneamente passato a mental ray fondamentalmente perchè non avevo lo mai provato per un lavoro serio che mi costringa ad impararlo e usarlo, era terra sconosciuta, e prima di dire uso "vray e basta" volevo vedere come ragiona e che risultati da'. per ora a parte questo contrattempo si sta comportando egregiamente. l'ambient occlusion la facevo già in mental ray che è piu' veloce che in vray. avendo poi un "delay" per questo immenso progetto, ho pensato di avere abbastanza tempo per poter capire come funziona e usarlo. un altro motivo è che molto probabilmente passero' ad un altro software di modellazione...xsi

spero di averti risposto,

ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ciao uncle,

probabilmente ci hai gia' pensato ma creare un mtl multisub/object e poi dare un id diverso agli architravi?

Forse la mesh andra' un po risistemata ma risparmi tempo in fase di render e probabilmente ,anche se aggiungi qualche poligono, anche ram perche' non dovra' calcolare le opacity delle mappe del blend. Nel wip non ho trovato il wire per vedere quanto lavoro c'e' da fare...

:hello:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
sequel: sono momentaneamente passato a mental ray fondamentalmente perchè non avevo lo mai provato per un lavoro serio che mi costringa ad impararlo e usarlo, era terra sconosciuta, e prima di dire uso "vray e basta" volevo vedere come ragiona e che risultati da'. per ora a parte questo contrattempo si sta comportando egregiamente. l'ambient occlusion la facevo già in mental ray che è piu' veloce che in vray. avendo poi un "delay" per questo immenso progetto, ho pensato di avere abbastanza tempo per poter capire come funziona e usarlo. un altro motivo è che molto probabilmente passero' ad un altro software di modellazione...xsi

spero di averti risposto,

ciao

Grazie, più che egregiamente, e ti dico anche che fai bene a provare strade alternative oltre a Vray! Più cose si sanno meglio è ;)

Buon lavoro :hello:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

nop, nessun tile attivato.

il problema delle linee è dovuto al sole mr_sun: infatti in base al posizionamento della luce mr_sun le linee cambiano posizione individuando una specie "linea d'ombra"...mah

(vorrei inoltre festeggiare il mio upgrade a gold. hiepppyyyyyyyyyyyyy!! :lol: :lol: :lol: :lol: )


Modificato da uncle pritt

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

u cribbiu, dimenticai, provo subito...

....

....

translating

....

....

final gather

....

....

intanto che renderizza: ma mental ray ha una specie di cache che tiene dentro informazioni o qualcosa? perchè il primo render appena aperto è una scheggia, il secondo è piu' lento...la stessa scena renderizzava a 2:16 alla prima apertura e con il light_shader_infinite 2:36

....

il problema rimane, provo a cambiare angolazione del sole

...

persiste, variato, ma persiste

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

col light infinite pero non avrai la sfumatura delle ombre

fai un paio di prove, una modificando il threshold delle ombre del mrsun, se non risolvi prova a modificare il softness (magari portalo a 0 per capire se e quello che da problemi)

che versione di max usi?

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ciao dagon, grazie dell'attenzione.

sì, mettendo il softness a 0 il problema sparisce, ma appunto le ombre diventano nette. a 0,1 il difetto è lieve, trascurabile, ma a 0,3 comincia ad essere evidente e a 0,5 è distinguibilissimo. probabilmente a questo punto mi tocca usare un blend material adottando una texture da almeno 4000 pixel di lato...anche perchè il composite material mi mostra nel render elements diffuse il valore di diffusione dell'ultimo materiale in ordine gerarchico

softnessù.jpg

già che ci sono: per la sola global illumination in render separato? con illuminance e luminance hdri ho il contributo delle ombre addizionato, che non voglio; le ombre le voglio compositare dopo. salvo in hdr a 32 bit e dico al renderer di renderizzare a 32 bit, così modifico l'esposizione dopo; solo che rimangono delle tracce degli oggetti sulle immagini dei vari canali; ad esempio se renderizzo il background, vedo ovviamente lo sfondo senza oggetti ma rimane una strana e fastiosa "ombra" o "traccia" degli oggetti; lo stesso nel diffuse dove su un materiale grigio vedo delle ombre corrispondenti ai bordi degli oggetti

test_1_Background.jpg

uso max 2008

grazie ciaooo :hello: :hello:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

è possibile che il mental ray materil sia piu' pesante degli arch&design material nel material editor? è da un paio di giorni che il material editor è lentissimo.

in piu' gli arch&design mi danno problemi di visualizzazione delle normali in viewport :(

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Crea un account o accedi per commentare

Devi essere un utente per poter lasciare un commento

Crea un account

Registrati per un nuovo account nella nostra comunità. è facile!

Registra un nuovo account

Accedi

Hai già un account? Accedi qui.

Accedi ora

  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×