Vai al contenuto
pasqua

Strane Chiazze Colorate In Vray

Recommended Posts

Scusate ho uno strano problema in Vray,

in un interno a volte appaiono strane chiazze colorate,

ma solo in alcune viste, se sposto anche di pochissimo la camera magari

non appaiono.

Il problema è che sto facendo un'animazione e ogni tanto danno

un effetto tipo lampi colorati!

secondo voi ci sono problemi con le luci?

(ho una direct per il sole ed una vray light su ogni vetro, in una stanza mi è

capitato anche con due omni)

grazie

post-30366-1193584348_thumb.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

si ho materiali self illum. come il vetro

gli rpc sono congelati

no camera correction, normale camera 24mm

ho materiali standard tranne il pavimento che è vray e i muri che è architettonico

ma... ho rifatto adesso una prova senza cambiare nulla e le macchie non ci sono più...

stanotte rimando la sequenza degli ultimi fotogrammi (negli ultimi 50 le macchie erano su 5 o 6...)

e ti faccio sapere

intanto grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Rieccomi,

stanotte ho rilanciato la sequenza video

(la salvo in tanti singoli jpg)

e le macchie sono di nuovo negli stessi fotogrammi di prima e

dello stesso colore e forma,

appaiono su diversi materiali,

i fotogrammi sono tutti quasi vicini (317,323,327,329)

mi è successo anche un'altra volta in un esterno dello stesso modello.

aiutooooo.................

eccovi un esempio, ho solo aggiunto una luce omni oltre la porta.

post-30366-1193643221_thumb.jpg

post-30366-1193643233_thumb.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

con vray è preferibile usare sempre i materiali di vray appunto.

i self illuminated mai usarli, c'è il vraylightmtl

fai prove togliendo alcuni materiali o oggetti degli stessi fotogrammi per capire dov'è il problema, è lungo ma sicuramente ti risolve il problema

ciaoooo

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

E' una cosa che è successa anche a me e mi ricordo che io usavo tutti materiali vray, non so se è come il tuo caso ma non l' ho mai risolta questa cosa...mi ricordo anche che il vray andava fuori di testa e non mi caricava più le mappe di IM

e LC, penso a dei bachi(Questo era il vray 1.47) Se lo usi anche te prova a passare all' 1.5

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Niente da fare:

togliendo sel illum ai vetri non cambia niente,

inoltre vi mando le scritte verdi che appaiono nel Vray messages,

penso che si riferiscano all'errore di colore che genera le macchie,

qualcuno ne capisce qualcosa?

comunque anch'io ritengo probabile che sia un difetto della mia vecchia versione di vray e max6.0

(per motivi tecnici... ancora aspetto ad aggiornarmi)

grazie

Pa

post-30366-1193653598_thumb.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti
Ciao

Prova così:

Prendi tutti gli rpc, nei loro settaggi "mass edit" seleziona tutta la loro componente di self illum (di solito è a 60%) e mettila a 0, in aggiunta puoi anche evitare che generino GI.

Facci sapere...

ho fatto la prova in tutti e due i modi e non c'è niente da fare,

inoltre tutti gli RPC sono all'esterno ed erano congelati.

qualche altra idea?

comunque grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

In un progetto mi è capitata la stessa cosa solo che le macchie erano più piccole e più diffuse ma degli stessi colori...ho resettato tutti i materiali e riaggiunti uno ad uno, poi lanciavo il render....ho scoperto che mi dava quel problema una pelle che avevo utilizzato per alcuni divani, ho rigirato sotto sopra il materiale ma non ho mai trovato il perchè....

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

TROVATO!

almeno il materiale incriminato, era un acciaio corten fatto con una miscela di due materiali,

ma il problema non è perchè è miscelato, succede anche se ne lascio solo uno.

In conclusione l'unico modo è

(non volendo cambiare il materiale approvato dal mio cliente

dopo svariati tentativi...)

escludere gli oggetti con tale materiale applicato dal generare la G.I.

(dentro Vray System - Objects settings)

di prove ne ho fatte tante, togliendo alcuni oggetti di legno le macchie ad esempio

cambiavano di colore, ma finchè nella casella dei Vray messaggi appaiono quelle scritte verdi

che si riferiscono infatti ai colori fondamentale RGB non c'è niente da fere, prima o poi sbucano fuori.

rimando l'immagine delle scritte di Warning

ti dicono l'oggetto sul quale si formano le macchie ma non l'origine mi pare.

Siccome il mio lavoro richiede un gran numero di viste non posso sempre sempre correggere l'angolazione della camera,

tantomeno nell'animazione.

comunque se qualcuno risolve in altro modo fatemelo sapere

grazie a tutti

Pasqua

post-30366-1193695093_thumb.jpg

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Ciao

Non mi è molto chiaro il motivo per cui accada ciò con un materiale miscela di 2 (hai usato qualche tipologia non standard / non vray in uno o entrambi dei due?)

Ad ogni modo potresti tentare così: fai calcolare la mappa di luce sostituendo al materiale incriminato un vray mat semplice che abbia una tinta simile a quella del tuo corten oppure grigia (anche solo 1 semplice texture arrugginita)

Poi per il rendering rimetti il tuo materiale ma carichi la mappa di luce salvata prima.

Ciao

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Ospite
Rispondi

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×
×
  • Crea nuovo...