Vai al contenuto
zoc

Disposizione Piu' Texture Su Stesso Modello

Recommended Posts

Ciao a tutti.

Stavo cercando di capire questa cosa.

Ho un modello, un corpo umano. Mi faccio tutta la mia bella mappatura e ho tutti i pezzettini nelllo spazio 1,0 del texture editor.

Pero' se dovessi fare dei primissimi piani per esempio alla faccia mi servirebbe una risoluzione molto alta. Non ce' un modo per mettere per esempio gli Uv della faccia nello spazio 1,0?

grazie mille!!!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Certo che si. In Maya è possibile creare più uv set. Fai caso a quando crei una nuova proiezione. Nel box di dialogo c'è l'opzione per inserire la nuova proiezione in un nuovo uv set. Poi per connettere la texture all'uv set appropriato devi usare uv-linking

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ma quindi a livello di nodi cosa avro'... vediamo se ho capito...

Una superfice (il nostro modello) > un materiale > con piu' UV texture map con relative texture

giusto?


Modificato da zoc

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ci sono quasi. Ora nella mia tendina uv set ho due mappe.

Mi avanzano anche queste due perplessità.....

- Mi manca solo di sapere come fare l'uv linking.

- Bisogna collegare le due texture a due materiali differenti?

grazie

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

1. Windows->Relationship editor->UV linking-> texture centric (associa ad una texture un UV) oppure UV centric (Associa un uv alla texture).

2. Puoi usare una layered texture.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

perdonami!!!! ma ho ancora dei problemi!!!

Nell' UV centric ho nella colonna degli UV Sets, associato al mio modello, le mie due mappe. Nell'altra colonna, quella delle Texture, ho il mio materiale con la attributo collegato, in questo caso Color > nome texture.

Il mio obbiettivo era quello di aggiungere un altra texture sotto Color. Quindi come hai detto tu ho fatto una layered texture con dentro le mie due texture e l'ho collegata al Color dal mio materiale. A livello del Relationship Editor sembra tutto ok, ma in render non viene una renderizzata una texture... e anche in visualizzazione la texture checker sembra a tratti trasparente :(

grazie ancora!

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Immagine please.

Può essere che la prima texture si sovrappone alle altre. Controlla che hai fatto i seguenti passaggi:

a - Disabilitato il wrap U e V nel nodo place2DTexture

b - Impostato a nero (0, 0, 0) il colore di default della texture

c - Impostato a Over il bend mode nella layered texture

d - Collegato l'alpha dell'immagine all'alpha del layer corrispondente.

A quel punto ti apparirà Fonzie:

layertexturede3.jpg:lol:

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ho fatto come hai detto, ma ciccia :) Mi renderizza solo gli scacchi...

ti allego l'immagine che ho sullo stage:

2mapUV.jpg

:(:(

grazie mille!


Modificato da zoc

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

ehm... sarebbe stato meglio un render. Il viewport non visualizza bene texture complesse come le layered. :-\

Non ho più idee, prova a rifare il procedimento da capo.

Prendi la mesh, ci metti due UVset, crei un materiale, a color ci metti una layered texture. crei quanti layer ti pare il più basso (quello a destra) lo metti come sfondo. Agli altri ci colleghi anche il canale alpha e disabiliti il wrap U e V. Metti il blend mode su over.

Il colore di default della texture su nero è per non avere il grigio che si somma ovunque..

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

nn capisco quando dici di collegare il canale alpha... :(

il colore della texture su nero intendi nel color balance il default color? a tutte le texture?

poi non ti rompo piu' lo giuro!!!

grazie ancora...

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

È la mia ultima chance per risolvere il problema allora. O_O

Nella layered texture sotto color c'è alpha. Se non lo colleghi la texture avrà un alpha uniforme ovunque. Se lo colleghi (ci trascini la texture con il tasto centrale) avrai 1 dove è presente l'immagine e zero dove non c'è niente, in questa maniera puoi visualizzare le texture sottostanti.

Comunque non ti fidare del viewport, metti qualità bassa e fai vari rendering, il viewport visualizza male le texture complicate.

il colore della texture su nero intendi nel color balance il default color? a tutte le texture?

Yep, lo devi impostare alle texture sopra la principale. Il default color è il colore presente dove non c'è la texture e influenza anche l'alpha channel.

Condividi questo messaggio


Link al messaggio
Condividi su altri siti

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Ospite
Rispondi

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Navigazione recente   0 utenti

    Non ci sono utenti registrati da visualizzare in questa pagina.

×
×
  • Crea nuovo...