Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Jack84

Problema Con L'hdri

Recommended Posts

Salve a tutti

sto facendo qualche prova per imparare ad utilizzare questo splendido motore di render (anche se come vedete non mi viene molto bene :wallbash: ).

Comunque... stavo seguendo il bellissimo tutorial di Pantich78 (che ringrazio :Clap03: ), il problema è che non riesco assolutamente a regolare la scena.

miorender1bc1.jpg

Vi pongo allora un pò di domande:

1)perchè la luce è così intensa??posso regolarla??

2)perchè gli oggetti non vengono riflessi??

3)perchè il vetro della tazzina non è trasparente???

Grazie mille in anticipo!

Share this post


Link to post
Share on other sites

Ciao,

questo è un messaggio generato automaticamente.

Se hai ricevuto questo messaggio è perché la tua discussione è stata spostata e messa nella sezione più appropriata.

Quando crei una discussione ti preghiamo di far attenzione ad inserirla nella sezione corretta in modo che sia più facile per tutti consultare il forum.

grazie per la collaborazione

lo staff di Treddi.com


"La potenza è nulla senza controllo" del mouse.

Share this post


Link to post
Share on other sites

Come hai settato il raytracing? Hai messo almeno 4-4-8-4? A prima vista sembra un problema di riflessioni e rifrazioni insufficienti.

Nell'IBL hai attivato Emit Light? Se sì, prova ad abbassare i primi due valori (che non ricordo mai come si chiamano, U e V qualcosa...) da 256 a 96 ad esempio.

Se non c'è emit light attivato, hai disabilitato le luci di default dal pannello Common dei rendersettings?

Il vetro ha le normali rivolte verso l'esterno?

Altro non mi viene in mente.

Share this post


Link to post
Share on other sites

Ti rispondo subito:

Nell'IBL hai attivato Emit Light? Se sì, prova ad abbassare i primi due valori (che non ricordo mai come si chiamano, U e V qualcosa...) da 256 a 96 ad esempio.

Se non c'è emit light attivato, hai disabilitato le luci di default dal pannello Common dei rendersettings?

L'emit light è disattivato e ho pure disabilitato le luci di default.

Come hai settato il raytracing? Hai messo almeno 4-4-8-4? A prima vista sembra un problema di riflessioni e rifrazioni insufficienti.

ti posto uno screen:

123456gd5.jpg

Se non c'è emit light attivato, hai disabilitato le luci di default dal pannello Common dei rendersettings?

Il vetro ha le normali rivolte verso l'esterno?

Saresti così gentile da dirmi dove posso controllare questo parametro?

Share this post


Link to post
Share on other sites

Il raytracing è sparatissimo però ha un basso numero di shadows; prova ad abbassare a 4-4-8-4 o al massimo 5-5-10-5 credo che sia più che sufficiente.

E' possibile che tu stia usando sia lambert (o altri materiali di Maya) che DGS? Usa solo DGS o ancora meglio il mia_material se usi Maya 8.5 o 2008, perchè il DGS è più vecchio del cucco ;) Il mia_material è semplicissimo da usare e trovi migliaia di informazioni nell'help e quì sul forum.

Per le normali, non ho il programma davanti e a memoria non ricordo perchè mi sono fatto un bottoncino nella shelf...

cerca "normals" nell'help e troverai di sicuro il menu da cui puoi controllarle. E sempre nell'help troverai il menu per cambiare l'oriento delle normali. Perdonami ma non posso controllare maya perchè sto renderizzando.

Share this post


Link to post
Share on other sites

Per le normali, dipende dalla versione di maya che usi, da quando è passata in mano autodesk, sono cambiate parecchie cosette, comunque resta in uno dei menu relativi ai poligoni (in maya 2008 hai un menu relativo alle normali... e forse anche nella 8.5 ma non ricordo). Sempre che si tratti di poligoni, altrimeni se è una nurbs per controllarle: display/nurbs/custom metti la spunta su Normal e le potrai visualizzare utilizzando lo shaded mode. Occhio che se entri nel pannello appena citato, devi controllare lo scope (il primo parametro). Se non selezioni nulla e come valore di scope hai "active objects" non vedrai nulla di nuovo in quanto le impostazioni verranno applicate solo agli oggetti selezionati!

Prima di aggiungere altro, dacci qualche info su che versione usi, altrimenti non è facile capirsi e darti dei consigli ;)

Share this post


Link to post
Share on other sites

Rieccomi qui!!! Vi ringrazio per le ottime risposte.

Prima di tutto dico che uso la versione 8.5...

...poi vi mostro le schifezze che ho prodotto!

miorender2eo9.jpg

Il render ha richiesto più di mezz'ora (confronto ai 20 secondi di prima).

Vi posto uno screen dei setteggi delle raytrace:

123456up7.jpg

Ho "risolto" il problema delle luci, e stava nella mappatura della sfera Hdri che avevo impostato Angular, riportandola su spherical la luce cala parecchio.Nel render che vedete sopra ho attivato la voce "emit light" sull'hdri e spuntando solo la voce "use back light" in quanto risulta la più blanda.

Ho risolto anche il problema del vetro, seguendo i vostri preziosi consigli (per ora non ho ancora verificato le normali) ho assegnato direttamente un dieletric sulla tazzina, impostando gli indici di rifrazione sia in entrata che in uscita a 1.571 (valora preso dalla tavola degli indici di rifrazione appunto). Il risultato che mi da però non mi soddisfa molto in quanto la tazzina sembra non essere cava, ma almeno ho fatto un passo in avanti :rolleyes: .

NON ho ancora , purtroppo, risolto il problema delle riflessioni degli oggetti.

Share this post


Link to post
Share on other sites

Sto continuando a provare, ma i tempi di calcolo raddoppiano 1 ora per quesa <_< .

miorender3vc1.jpg

Ho spuntato anche emit diffuse e l'emit specular e ho piaccato un piano in fondo alla scena per vedere gli oggetti riflessi.

Stavo notando una cosa...la sfera è l'unico oggetto che ho creato in maya, la tazzian e il cucchiaino sono stati importati come .igs... non è che questo influenza le riflessioni??

Share this post


Link to post
Share on other sites

Per ora disabilita emit light e diffuse nell'IBL perchè se non risolvi prima i problemi coi materiali non è il caso che ti incasini con le luci e con i tempi che comportano il calcolo delle emissioni dell'IBL.

Ripeto, lascia perdere Dielectric e DGS ed utilizza il mia_material: creane uno, apri l'Attribute Editor e in alto a destra c'è un bottoncino con su scritto Presets. Tienilo premuto e scegli ad esempio Physical Glass per la tazzina, Satined o Brushed Metal per il cucchiaino e così via. Col mia_material ci puoi fare di tutto a seconda di come lo imposti: dai uno sguardo nella guida e troverai tante info utili.

Per le normali, seleziona ad es. la tazzina, vai nella sezione Polygons, menu Display>Polygons>Face Normals e così vedi la direzione delle normali; ti conviene usare la modalità X-ray per vedere meglio ;)

Se le normali dovessero essere capovolte vai nel menu Normals e lì troverai Reverse Normals ed eventualmente Conform che ne uniforma l'orientamento.

Per essere più sicuro, seleziona anche le meshes importate, apri l'AE e vedi se nei Render Stats sono selezionate le voci visible in reflections/refractions, non si sa mai ;)

Una volta sistemate meshes e materiali, dedicati all'IBL con Emit Light (se proprio ci tieni :) ) partendo con valori bassi tipo 96-96 / 20-4 / 5-2 e non toccare altro; puoi al limite variare il Vary blablabla (non ricordo il nome esatto) che è settato a 0.800 di default. Da quello che ho letto dovrebbe migliorare la resa ma non ho capito bene come.

Share this post


Link to post
Share on other sites

Consiglio veloce... seguendo il consiglio di faber... setta prima le luci, con un materiale TUTTO BIANCO!

Perché fare questo? Eviti di avere calcoli di raytrace e riesci a capire se la tua illuminazione funzioni o no...

In che gamma stai lavorando???? Sento odore di 1 invece che 2.2...

Per quanto riguarda gli IGS... non so se sia il caso con tutti gli oggetti importati, ma se importi un obj non verrà visto né in riflessione né in rifrazione, quindi, apri windows/general editor/Attribute Spread Sheet con gli oggetti selezionati e controlla, sotto la voce Render, che sia attivo "visible in reflection" "visible in refraction" se così non fosse, attiva entrambi!!! (è un metodo un po' più veloce di quello descritto da Faber ;)

Share this post


Link to post
Share on other sites

Grazie ragazzi!! davvero di cuore!!

Il vero problema stava nel fatto che non erano attivate ne riflessioni ne rifrazioni su tutti gli oggetti importati!

vi posto un render di 30 sec.

miorender4uc2.jpg

Sono ben lontano da un render decente ma almeno sto scremando i problemi!

I materiali che ci sono in scena sono tutti mia_materials ma non ho trovato quelli che intendevi tu fabergambis, infatti ho disponibili solo: Stone, ceramic, glass_pane, glazed_ceramic, thick_glass, wood, frosted_glass. Sono forse disponibili solo nella versione 2008?

continuo con varie sperimentazioni :devil:

Share this post


Link to post
Share on other sites

Devi installare i presets. Vai su www.mymentalray.com non ricordo in quale discussione parlano dei presets e puoi scaricare i files che ti permettono di usarli!

Ora l'immagine è decisamente meglio ma... sono sempre convinto che sia realizzata con gamma 1... ;)

Ciacia

Gabba

Share this post


Link to post
Share on other sites

Ci sono un sacco di discussioni che parlano del gamma... devi cambiare il gamma in uscita, in pratica del tuo risultato. Per fare questo ci sono diversi modi (lens shader di vario tipo, cambiare il valore del framebuffer).

Visto che non mi sembra tu abbia dei colori (o delle textures applicate ai materiali), vai nel render global, sotto framebuffer setta il gamma a 0.454

Renderizza, e probablimente vedrai tutto "molto più chiaro" se non addirittura bruciato. Imposta di nuovo i valori relativi alla luce e vedrai che il risultato sarà sicuramente migliore di quanto non hai ora ;)

In questo periodo non ho tantissimo tempo... domani vedo di riuscire a convertire in PDF la traduzione di MasterZap sul gamma...

Share this post


Link to post
Share on other sites
Ci sono un sacco di discussioni che parlano del gamma... devi cambiare il gamma in uscita, in pratica del tuo risultato. Per fare questo ci sono diversi modi (lens shader di vario tipo, cambiare il valore del framebuffer).

Visto che non mi sembra tu abbia dei colori (o delle textures applicate ai materiali), vai nel render global, sotto framebuffer setta il gamma a 0.454

Renderizza, e probablimente vedrai tutto "molto più chiaro" se non addirittura bruciato. Imposta di nuovo i valori relativi alla luce e vedrai che il risultato sarà sicuramente migliore di quanto non hai ora ;)

Ecco un esempio pratico di suggerimento costruttivo :Clap03:

In questo periodo non ho tantissimo tempo... domani vedo di riuscire a convertire in PDF la traduzione di MasterZap sul gamma...

Ecco un altro esempio di buona volontà nel divulgare SAPERE a ki nn ne ha :lol::)

Grande Gabba nn vedo l'ora d leggerlo!

Share this post


Link to post
Share on other sites

Non l'hai trovata perché è sotto la sezione relativa a max... ;)

Questo è l'indirizzo: http://mymentalray.com/forum/showthread.php?t=767

Ti do un consiglio, leggiti le discussioni sul gamma qui sul forum e su cgtalk. Se cerchi in cgtalk devi cercare qualcosa tipo "sun&sky rendering bad" o qualcosa di simile. Questo perché se non sai quello che fai, con il gamma, il rischio è quello di dire "che schifo, è tutto slavato!" e smettere di usare il procedimento giusto... Non c'è niente da fare, devo vedere se riesco a fare un tutorial su questa cosa... spero di avere un po' di tempo sto week-end (sempre che non piova =P

(a quanto hai il filter del FG???)

Share this post


Link to post
Share on other sites

Se per FG intendi final gather, allora il filtro è a 0 :TeapotBlinkRed:

Sono riuscito ad aggiungere i preset!! figata, forse ora posso cominciare a fare qualcosa.

Le discussioni ora me le leggo per bene che ne ho parecchio bisogno :rolleyes:

grazie ancora infinitamente

Aspetto il tutorial :devil::rolleyes:

Share this post


Link to post
Share on other sites

Se è a zero, prova ad alzarlo a1 oppure 2, non di più, probabilmente dovrebbe migliorare (se non sparire) il problema di macchie che hai nella vicinanza della sfera.

Per il tutorial vedo se riesco a fare qualcosa, ma non sarà facile (anche perché l'argomento non è di per se semplice).

Tra un attimo metto online la traduzione del testo di MasterZap, che già questa non è poco (in quanto a informazioni).

Per i preset, alcuni sono piuttosto buoni, altri un po' meno. Alcuni funzionano meglio di altri in determinate situazioni, sperimenta tu con altri paramentri!

Share this post


Link to post
Share on other sites

Sto continuando a testare!

fgfilter1sl6.jpg

FG filter = 1

fgfilter2vk1.jpg

FG filter = 2

fgfilter3kc8.jpg

FG filter = 3

:rolleyes:

ora i cimento con l'anti-aliasign

Una domanda:

Ho provato a toccacciare i valori di un Mia_material in particolare il bump, ma qualunque cosa metta il materiale non si altera...


Edited by Jack84

Share this post


Link to post
Share on other sites

Suppongo tu abbia collegato un nodo di bump direttamente nello slot, sbaglio?

Se così fosse, devi cambiare strada.

Andiamo per passaggi. Creati il mia_material. Crei un nodo "miss_set_normal". Nello slot bumo trascina il nodo miss_set normal. Crea il tuo nodo di bump e collegalo con l'attributo normal_vector del miss_set_normal. Fa quello che devi fare con il nodo di bump. Una volta fatto questo entra nello shadging group del materiale e sotto il tab relativo a mray metti la spunta su "export with shading engine". In questo modo potrai utilizzare tutti i possibili parametri per i filtri delle textures cosa che altrimenti non si poteva fare.

Alternativa è utilizzare uno shader esterno come quello che ha realizzato il ctrl_studio (il bump_combiner che trovi al solito sito "mymentalray.com").

Se hai altre domande...

Share this post


Link to post
Share on other sites
Crea il tuo nodo di bump e collegalo con l'attributo normal_vector del miss_set_normal. Fa quello che devi fare con il nodo di bump

scusa la mia infinita ignoranza ma questo non l'ho proprio capito :crying:

Share this post


Link to post
Share on other sites

Cosa non hai capito precisamente??? il "fa quello che devi fare con il nodo di bump"???? Era inteso come setta i parametri come meglio credi (quindi collega la texture e imposta il range del bump).

Se invece non capisci il primo passo, apri l'hypershade, crea i vari nodi poi apri l'AE del miss_set_normal, clicca e trascina il nodo di bump sullo slot relativo al "normal vector" e il gioco è fatto ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x