Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
sethi78

Rendering Distribuito..

Recommended Posts

Salve gente, mi succede una cosa proprio strana.. Guardate le due immagini in allegato.

La prima è stata fatta calcolando l'irradiance map in single frame e salvandola su file con due pc in rete.

La seconda è stata fatta subito dopo senza cambiare alcun parametro, l'unica differenza è che l'irradiance map creata per il render precedente è stato caricato da file.

La prova denota la netta diversità di velocità di render dei due pc, infatti il pc che fa da "server" è quello su cui è stata salvata la mappa ed è quello che ha correttamente renderizzato quei "cubetti chiari", l'altro è invece il pc client che aiuta il rendering...

Sembra che l'irradiance map non sia stata correttamente passata all'altro pc.. che ha fatto così tutto quel rendering scuro scuro..

Che si può fare?

post-33486-1190887392_thumb.jpg

post-33486-1190887431_thumb.png

Share this post


Link to post
Share on other sites

sei sicuro che il pc in slave trovi la mappa?

quando renderizzi in rete con lo spawner, se si verificano problemi, hai sulla stessa immagine i buket del pc server renderizzati correttamente e quelli dello slave più scuri o mal renderizzati a causa di n motivi, tra i quali anche e soprattutto l'impossibilità di raggiungere determinati files (anche texture) attraverso i percorsi.

Share this post


Link to post
Share on other sites
sei sicuro che il pc in slave trovi la mappa?

quando renderizzi in rete con lo spawner, se si verificano problemi, hai sulla stessa immagine i buket del pc server renderizzati correttamente e quelli dello slave più scuri o mal renderizzati a causa di n motivi, tra i quali anche e soprattutto l'impossibilità di raggiungere determinati files (anche texture) attraverso i percorsi.

Uhm... La mappa è salvata in C:\bla bla bla in locale sul pc server, nel pc client c'è la stessa dir duplicata. Ci sono dentro tutti i materiali ecc.. ma l'irradiance map no, da quello che si legge nella finestra di log pensavo che si occupasse lui di trasferirla all'altro pc.. Non scrive mica "transfered xxx bytes of irradiance map to nome_pc_slave"??

Share this post


Link to post
Share on other sites
No non l'ho fatto, pensavo se ne occupasse lui.. devo farlo?

ma assolutamente no...non toccare niente.

lui deve ricercare tutti i percorsi.

prova, nel caso, a spostare la mappa di luce nella stessa directory del .max

immagino che tutte le impostazioni dei 2 3dstudio siano identiche

Share this post


Link to post
Share on other sites
ma assolutamente no...non toccare niente.

lui deve ricercare tutti i percorsi.

prova, nel caso, a spostare la mappa di luce nella stessa directory del .max

immagino che tutte le impostazioni dei 2 3dstudio siano identiche

Problema risolto.. sul pc master la mappa è salvata in C:\temp\mansarda\Irradiance Map, ho copiato nell'identico percorso del pc slave il file e ora funziona.. Mi sarei aspettato però che lo facesse automaticamente :-(

Il .max è invece salvato in C:\temp\mansarda

Share this post


Link to post
Share on other sites
Problema risolto.. sul pc master la mappa è salvata in C:\temp\mansarda\Irradiance Map, ho copiato nell'identico percorso del pc slave il file e ora funziona.. Mi sarei aspettato però che lo facesse automaticamente :-(

Il .max è invece salvato in C:\temp\mansarda

ok l'importante è il risultato ma c'è ovviamente un difetto di procedura

se hai una mappa che deve essere a disposizione di 200 nodi che fai? 200 copie? devi essere sicuro che tutti i max siano configurati con c:/temp ecc ecc nei percorsi.

ah... alle volte, se hai una rete, i percorsi variano da assoluti a relativi e succedono disastri

io qui ho alcuni percorsi C:\ , altro \\server ... e spesso sono dolori, ma non sono io il sistemista di rete.... :wallbash:

Share this post


Link to post
Share on other sites
ok l'importante è il risultato ma c'è ovviamente un difetto di procedura

se hai una mappa che deve essere a disposizione di 200 nodi che fai? 200 copie? devi essere sicuro che tutti i max siano configurati con c:/temp ecc ecc nei percorsi.

Già.. è veramente una cosa scomoda :-(

Vabbè dai l'importante è come dici tu il risultato... e per fortuna il rendering lo faccio solo su due pc :-P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x