Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
vaka85

Problema Uvmap E Meshsmooth

Recommended Posts

ciao a tutti, forse dovevo postare in principianti boh...

comunque, ho un problema: ho letto diverse guide sull'uv mapping e le sto mettendo in pratica con un divanetto che ho modellato...

vi dico come ho fatto così mi dite dove sbaglio:

per ogni gruppo di poligoni ho usato il modificatore edit poly e uno uwv map, selezonando il gruppo di poligoni interessati e dango loro un id, e poi aggiustato tipo di mapping (box, planar, ecc...) in modo da non avere distorsioni o errori vari con la texture...

fino qui penso sia tutto ok, anke perchè usando un materiale checker tutto i quadratini sono ok :)

poi però se applico un meshsmooth si sballa tutto... il lavoro fatto...

quindi, la mia domanda è: tutto il procedimento lo devo fare DOPO aver applicato il meshsmooth?

grazie ;)

Share this post


Link to post
Share on other sites

allora, posto gli screen...

ho fatto una prova usando il meshsmooth con 1 iterazione e ho sistemato tutto quindi fino qui tutto a posto (non guardate il lato del divano che non l'ho fatto perchè avevo fretta di provare:

01cu6.jpg

se aumento le iterazioni ecco cosa succede:

02fw4.jpg

:blink2:

tra l'altro, se dovessi risistemare tutto per 3 iterazioni, sarebbe impossibile perchè i wire diventano molto fitti e non si vede la mappa sotto! c'è un modo x risolvere anche questo problema?

grazie mille

Share this post


Link to post
Share on other sites

le poly posseggono già il tool nurms subdivision senza dover aggiungere modificatori(anche se credo che il turbosmooth sia più performante)

senza essere in alcun sub livello scorri i rollout della poly e ne troverai uno in cui puoi settare le iterazioni e abilitare o disabilitare il nurms subdivision.

Share this post


Link to post
Share on other sites

capito. comunque non cambia niente... anzi, rispetto al meshsmooth classico è ancora peggio perchè viene fuori una gabbia di wire molto strana

01ut0.jpg

quindi l'unico modo suppongo sia sistemare la mappa dopo aver applicato il meshsmooth giusto?

Share this post


Link to post
Share on other sites

Dai, non prenderla così male... La soluzione che prospetti è sbagliata.

Hai idea cosa vorrebbe dire fare l'unwrap di un oggetto complesso con lo smooth a 2? Un delirio.

Se posti l'oggetto problematico vedo se riesco a capirci qualcosa di più.

Ciao


Edited by nicolce

Share this post


Link to post
Share on other sites
Hai idea cosa vorrebbe dire fare l'unwrap di un oggetto complesso con lo smooth a 2? Un delirio.

ecco infatti è quello il problema :unsure:

in allegato metto il modello base, senza nessun modificatore ancora applicato...

ripeto il problema: creo la mesh base, setto i vari id, e poi quando applico il meshsmooth i poligoni selezionati dai vari id sono diversi...

grazie mille per la disponibilità

divanetto.rar

Share this post


Link to post
Share on other sites

Il file con chamfer ha un po' di triangoli e poly con più di 4 vertici, la mesh si stira per quello.

Partendo dal file senza chamfer ho tirato fuori due soluzioni, quella a sinistra con i chamfer e qualche slice strategico, l'altra senza chamfer con crease sugli edge.

Entrambe reggono piuttosto bene lo smoothing, e le uv non si distorcono più di tanto.

smoothingkq7.jpg

Allego anche il file:

divanetto_unwrap_smoothed.rar

Ciao

Share this post


Link to post
Share on other sites

ti ringrazio davvero molto nicolce, dopo ci dò un occhiata ;)

alcuni dubbi:

in quello con i chamfer come hai fatto a risolvere il problema? hai riconvertito le facce col numero di vertici sbagliati?

in quello senza chamfer cosa sarebbe il "crease sugli edge"?

grazie ancora, molto gentile!

Share this post


Link to post
Share on other sites

@cisconet: è quello che ho fatto ma si presenta il problema come ho scritto...

@nicolce: ho capito, però non riesco ad aprire il tuo file, mi da errore... :huh:

comunque mi spieghi come hai fatto a fare il chamfer senza fare i triangoli? non ci riesco proprio...

Share this post


Link to post
Share on other sites

Ora non ricordo alla perfezione come ho fatto, invece che fare tutti i chamfer insieme li ho fatti in due fasi.

Adesso riguardando il file vedo che ho lasciato ancora due poly con 5 vertici, quelli li pulirei a mano, cancellando e weldando.

Ciao

Share this post


Link to post
Share on other sites

allora, sarò scemo ma sono giorni che sono dietro a cercare di capire come cavolo sistemare sto smooth...

almeno,dopo mille tentativi sono riuscito a fare i chamfer senza triangoli (grazie a nicolce), ecco la prova:

01pa7.jpg

ma :eek::wallbash: ecco il disastro una volta applicato il meshsmooth:

02lh3.jpg

non capisco il perchè!!!!!!! sto impazzendo...

Share this post


Link to post
Share on other sites
allora, sarò scemo ma sono giorni che sono dietro a cercare di capire come cavolo sistemare sto smooth...

almeno,dopo mille tentativi sono riuscito a fare i chamfer senza triangoli (grazie a nicolce), ecco la prova:

ma :eek::wallbash: ecco il disastro una volta applicato il meshsmooth:

non capisco il perchè!!!!!!! sto impazzendo...

Devi anche evitare con più di 4 vertici, il tuo problema deriva da un poligono a 6 vertici, proprio quelli che hai cerchiato :D

01pa72wn8.jpg

Io li l'ho risolta così come puoi vedere quà sopra.

Per farlo, come ti ho detto ho usato anche cut e slice, oltre che il chamfer....

ti allego il .Obj, così puoi vedere direttemente sul modello.

poltroncinaobj.rar

Ciao


Edited by nicolce

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...
Aspetta! x