Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
penny

Fg Si Mangia Le Ombre

Recommended Posts

scena d'interni(il test con le sfere di maxwell)... 1spot o directional o provato con entrambe. con il fg si crea una luce diffusa perfetta ma le ombre sparicono rimangono solo "quelle" del fg.

mi rendo conto di essermi spiegato da cani ma non capisco neanche io dove sta e quale può essere il problema. di fatto ho la luce, tutto è attivato per avere le ombre......... ma non ho le ombre! :wacko:

da cosa può dipendere?

c'è un modo per creare un pass separato delle ombre che non sia con l'use background?

ps:@mat(dagon): le ombre che tu hai dal tavolino dai vasi dalla colonna dello stereo...

http://www.treddi.com/forum/index.php?showtopic=2608&st=220

io non le ho

:crying:

Share this post


Link to post
Share on other sites

:wacko::wacko::wacko:

ok ho rifatto una scena simile velocemente e il fg non si mangia proprio niente stavolta.

unica differenza che c'è è che sulla nuova stanza ho fatto delle prove solo con mr 3.4 sulla precedente prima ci avevo lavorato pure con mr 3.3...

quindi... sembrerebbe che si sia come registrato dei dati che con le nuove impostazioni vanno in conflitto!

ovviamente sono solo supposizioni ma vorrei capire cosa è successo?

Share this post


Link to post
Share on other sites
se hai attivata la global illumination controlla che nel render globalsia spuntata la voce direct illumination shadow effects o qualcosa di simile

avevo provato questa soluzione ma non è quello, ne ho provate tante e comincia a diventare un po' frustrante. mi son scaricato di nuovo la scena e intanto r_inizio da capo. anche perchè ho visto che anche il ctrl_irradiance di francesca luce si comporta in maniera diversa dalla versione 6 alla 6.5... la qualità dello shader è indiscutibile ma si ottiene con settaggi diversi

Share this post


Link to post
Share on other sites

ciao penny, anche su cg talk un tipo mi ha scritto chiedendomi la tua stessa identica cosa qualche giorno fà

questo è il suo rendering

http://img136.exs.cx/my.php?loc=img136T...roomcopy1ud.jpg

mi ha mandato la scena, io pensavo dipendesse dalle spunte su "visible in reflection" e "visible in refraction" (che se fai l'import da 3ds o obj sono disabilitate), ma non era neanche quello (cmq dai una controllata, non si sa mai)

trafficando un po' ho capito che il suo problema era il raytrace depth shadows (o qualcosa del genere non ricordo esattamente)

avendo delle area light fuori dalla finestra e impostando 1 come depth delle ombre raytrace, perdi completamente l'effetto delle ombre di contatto, aumentando il raytrace depth shadows le ombre non vengono più mangiate

ricordati che l'impostazione è presente sia nelle opzioni dela luce, sia nel render global

spero ti possa essere d'aiuto ;)

p.s.

leggendo meglio vedo che sulla 3.3 ti capita questo problema e sulla 3.4 no

probabile allora che il problema sia proprio "visible in reflection" e "visible in refraction" che sulla 3.3 controllano il fg, sulla 3.4 invece credo abbiano minore effetto... vado per supposizioni ovviamente...


Edited by dagon

Share this post


Link to post
Share on other sites

il problema in effetti è strano!!!

cmq sulla 3.3 andava tutto bene

stessa scena sulla 3.4... ombre adios

mi sa che ci faccio una prova ancora seguendo i tuoi consigli, poi lascio stare e ricomincio da capo perchè comincia a diventare frustrante(peccato per i due giorni di lavoro)

grazie mat

Share this post


Link to post
Share on other sites

aspetta ora son riuscito a vedere l'immagine...

non ho un problema con le ombre di contatto, non ci sono proprio le ombre.

di quelle che ci sono nell'immagine non ne ho neanche una!

cmq ora provo subito

Share this post


Link to post
Share on other sites
aspetta ora son riuscito a vedere l'immagine...

non ho un problema  con le ombre di contatto, non ci sono proprio le ombre.

di quelle che ci sono nell'immagine non ne ho neanche una!

cmq ora provo subito

cioé non hai ombre per niente?

fammi un riassunto delle impostazioni che usi

gi+fg? solo fg?

quanti bounces? che luci stai usando? che impazioni per il raytrace e per le ombre?

sembra molto strano che addirittura non ci siano ombre...

Share this post


Link to post
Share on other sites

<_<-_-:D

non ho parole...

ora sembra funzionare tutto alla grande.

unica differenza rispetto alla scena precedente ho iniziato tutto da capo importando il file 3ds e iniziando a fare le prove direttamente con mr 3.4, forse il problema stava nel fatto che prima avessi usato anche il 3.3 di maya 6... anche se onestamente non ne capisco il perchè!

ma?!?!?!?!?!

Share this post


Link to post
Share on other sites
<_<  -_-  :D

non ho parole...

ora sembra funzionare tutto alla grande.

unica differenza rispetto alla scena precedente ho iniziato tutto da capo importando il file 3ds e iniziando a fare le prove direttamente con mr 3.4, forse il problema stava nel fatto che prima avessi usato anche il 3.3 di maya 6... anche se onestamente non ne capisco il perchè!

ma?!?!?!?!?!

mmm non ho idea... sai che l'informatica non è mai una scienza esatta :P;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...