Jump to content
arcaik

Render "sporchi"

Recommended Posts

Allora... ho un piccolo problemino... con V-ray...

I render vengono precisi ecc ecc, ma nelle zone dove c'è un po' d'ombra è come se fosse "sporco", cioè si creano dei puntini "pixellosi" e brutti da vedere.

Ora il problema quale può essere?? il numero scarso dei samples delle luci? Quello dei materiali? Oppure un errato settaggio dell'antialiasing?? Ah, premetto che ho già controllato le varie discussioni su gli argomenti sopra citati (soprattutto riguardanti l'AA) ma nn ho trovato nulla che potesse tornarmi utile.

Appena posso posto qualche immagine x mostrare meglio il problema. :wallbash::wallbash::wallbash:

Share this post


Link to post
Share on other sites

Non conosco V-ray però in attesa che qualcuno ti risponda, azzardo che è il un basso numero di samples!

Te lo sporca perchè i blocchi nn sono compatti!

Se ho azzeccato sono meglio di Nostradamus! :w00t:

Paul Maslie B)

Share this post


Link to post
Share on other sites

Beh ho toccato i valori Vray rQMC sampler mettendo 0.0 ad "adaptive amount", 0.0 a "noise threshold", "min. samples" 24, global subd. multi. a 2.0

Ora credo si inchiodi tutto visto che i tempi di render sembrano decuplicati... e dato che originariamente impiegavo 4 ore, credo che ora ce ne vogliono almeno 40!!!! :TeapotBlinkRed::TeapotBlinkRed:

Pare che "l'effetto sporcizia" sparisce, ma i tempi sn esagerati!!!! :crying::crying::crying:

C'è qualche altro sistema??? :wallbash::wallbash::wallbash::wallbash:

Share this post


Link to post
Share on other sites

Ma il tutto può dipendere dal fatto che prima faccio calcolare la mappa di radianza, la salvo, la carico e poi faccio partire il render con i materiali? Può essere che così facendo mi si inficia la qualità del render finale???

Ah, cmq i samples delle vray light li ho lasciati nel valore standard... devo aumentarli???

Ho allegato un'mmagine x far capire il problema. dietro i libri, sul muro si vede l'ombra "sporca".

post-3677-1175786113_thumb.jpg

Share this post


Link to post
Share on other sites
Ma il tutto può dipendere dal fatto che prima faccio calcolare la mappa di radianza, la salvo, la carico e poi faccio partire il render con i materiali? Può essere che così facendo mi si inficia la qualità del render finale???

Ah, cmq i samples delle vray light li ho lasciati nel valore standard... devo aumentarli???

Ho allegato un'mmagine x far capire il problema. dietro i libri, sul muro si vede l'ombra "sporca".

sicuramente si dovresti calcolarti la IrrMap con i materiali la riflessione della luce cambia con i materiali applicati!!

Share this post


Link to post
Share on other sites
Beh ho toccato i valori Vray rQMC sampler mettendo 0.0 ad "adaptive amount", 0.0 a "noise threshold", "min. samples" 24, global subd. multi. a 2.0

Ora credo si inchiodi tutto visto che i tempi di render sembrano decuplicati... e dato che originariamente impiegavo 4 ore, credo che ora ce ne vogliono almeno 40!!!! :TeapotBlinkRed::TeapotBlinkRed:

Pare che "l'effetto sporcizia" sparisce, ma i tempi sn esagerati!!!! :crying::crying::crying:

C'è qualche altro sistema??? :wallbash::wallbash::wallbash::wallbash:

Ma i valori li hai "toccati" a caso o con un criterio :blink2:

Prova ad impostare questi: Adaptive Amount 1, Noise Threshold 0.01, Min. Samples 8, Subdv. multiplier 1: a me non danno problemi (IM+LC con Enviroment e GI by HDRI)

Il noise è dovuto spesso alle subdivision basse: che usi come Primary e Secondary Engine? IM+QMC? LC+QMC? LC+IM? IM+LC? ogni associazione ha una soluzione differente... ^_^

Inoltre, quoto quanto scritto da altri: l'IM, se dovessi cambiare materiale (o solo una impostazione di esso) o se dovessi spostarti con la camera, la devi ricalcolare!

Share this post


Link to post
Share on other sites
Ah, cmq i samples delle vray light li ho lasciati nel valore standard... devo aumentarli???

Certo che li devi aumentare: le subdvision rappresentano la qualità in termini di grana (noise e non "sporcizia") associata ad una emissione luminosa...e non solo :rolleyes:

Share this post


Link to post
Share on other sites

Se puoi invia delle immagini più grandi perchè così si vede veramente poco e magari fai prima a postare anche i parametri dei render di v-ray così si capisce subito dove sbagli.

Share this post


Link to post
Share on other sites

Ciao, provo a spiegarmi! il valore del subdivision multiplier agisce su tutto quello che può essere regolato attraverso subdivision, quindi luci, irradiance map ecc.

Quindi prova ad alzare min sample e subdivision, ad abbassare il noise threshold a .002 (di solito funziona bene così) ma non dimenticarti di abbassare considerevolmente Hsph subdivision sennò ti ritovi con dei tempi di resa allucinanti.

Ora ho il diavolo alle calcagna, faccio un salto qui dopo a vedere come prosegue.

Ciao,

n.

Share this post


Link to post
Share on other sites

Allora... i parametri nn li ho toccati a caso, ma seguendo un criterio logico... poi dato che i risultati nn erano soddisfacenti, sn impazzito :devil::devil: e ho messo tutto al massimo... ora dopo 17 ore il render sta venendo molto + pulito, ma il tempo impiegato è decisamente inaccettabile...

L'immagine la faccio calcolare prima solamente con un materiale unico su tutto (per salvare la irr. map), dato che altrimenti se mettessi tutti i materiali andrebbe a fuoco il pc...

Purtroppo nn posso postare immagini complete dato che è per un lavoro e nn sono il proprietario delle strutture e degli interni, quindi posso solo postare dei "ritagli"..

Cmq farò altre prove x trovare una soluzione migliore! :wallbash::wallbash::wallbash:

Ah, uso Irr Map+QMC

Share this post


Link to post
Share on other sites
Ah, uso Irr Map+QMC

non conosco lo scopo finale dell'immagine, ma ti consiglio light cache come motore per i secondary bounces...

i tempi alti vengono dal QMC...

la LC con sample a 1000 è velocissima e rende un immagine quasi sempre molto pulita...

provare per credere!!!

Share this post


Link to post
Share on other sites

Lascia tutti i parametri di default. Non toccare i vari rQMC se non sai bene a cosa servono, rischi di incasinare il setup e basta. Per il 99% delle volta vanno bene già come sono.

Il problema, osservando il tuo "francobollo". sembra dipendere dalle basse subdivs delle VRayLight. Portale da 8, valore di default, a 24/32.

_cecofuli

Share this post


Link to post
Share on other sites
Guest

Che release usi di V-Ray? Non ho letto tutto accuratamente, ma ad occhio hai alzato il dark multiplier.

Ti lego quello che ho scritto ad altri.

link 1

link 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...