Jump to content

Recommended Posts

Ciao....innanzitutto spero di aver postato nella sezione giusta,non sapevo dove chiederla questa cosa,nel caso avessi sbagliato chiedo scusa al moderatore che dovrà spostare la discussione. :blush:

Dunque,vediamo se riesco a spiegarmi nel miglior modo possibile,la faccenda è un pò complicata(almeno per me :P )....ho renderizzato un modello in 3D Studio Max e ho salvato l'immagine in formato ".PNG" per usarla come icona sul desktop,per farlo uso l'utility(o inutility per alcuni ^_^) "Avedesk",che serve appunto per avere le icone sul desktop come quelle del Mac.

In questo modello ci sono dei materiali trasparenti,il problema è che quando uso l'icona non si vede attraverso questi materiali lo sfondo del desktop,questo perchè in fase di rendering su max mi viene renderizzato anche lo sfondo ambiente.....come posso risolvere questo problema?

Vi lascio anche uno screenshot del mio desktop per farvi vedere quello che vorrei ottenere:

deskdw9.jpg

Ciao e grazie a chiunque mi risponderà. :hello:

Share this post


Link to post
Share on other sites
bho ma hai segnato salva alpha? a me funziona se no prova tga ma se non metti l'alpha...

Si la casella salva alpha è segnata,il problema non è la trasparenza intorno al perimetro dell'oggetto,il problema è che vorrei che una parte all'interno dell'oggetto che ha il materiale trasparente applicato,mi faccia vedere il desktop dietro....come si vede anche nell'immagine che ho postato.

è problematica la faccenda da spiegare,grazie per l'interessamento che ci metti,attendo volentieri altri tuoi suggerimenti,e naturalmente di chiunque altro abbia una soluzione.

:hello:

Share this post


Link to post
Share on other sites
fai vedere come ti è venuto? Io ho fatto una prova con Vray e funziona con un materiale vetro

Ciao nduul.......questo è quello che viene a me:

immaginevk0.jpg

Piccola premessa.....non ci capisco granchè di materiali,luci e settaggi dei motori di render,è una cosa che devo ancora studiare per bene.

L'icona è un camion della lego fatto con leocad e poi importato in 3D Studio,ho usato mental ray di max 6 per il rendering......finito il render ho salvato l'immagine come png con la casella dell'alpha selezionata.......se noti bene si vede che il parabrezza del camion non mi fà vedere il desktop sotto......come posso fare per risolvere?

Nel caso dimmi se devo postare settaggi o cose simili per far intercettare meglio il problema.....grazie ancora.

:hello:

Share this post


Link to post
Share on other sites
penso sia un problema di materiale...lo sfondo di max è impostato col colore blu? Che materiale hai dato al parabrezza? Magari posta i settaggi

Lo sfondo di max è impostato con il colore nero.....questi sono i settaggi dei vetri con un render:

immagine2sw2.jpg

Settaggi illuminazione indiretta....non so se può servire nel capire la magagna ^_^ :

immagine3ph1.jpg

Settaggi luce omni zonale mentalray:

immagine4vy7.jpg

Skylight:

immagine5ty3.jpg

E infine l'impostazione della scena:

immagine6nt8.jpg

Scusa per la risposta chilometrica :P ......spero che le informazioni che volevi siano corrette.

:hello:

Share this post


Link to post
Share on other sites

ho fatto una prova veloce ed il problema sembra proprio essere nel materiale raytrace, prova con un materiale mental ray, io su 3ds 7 ho proprio il mr glass che funziona. Altrimenti puoi provare con un materiale standard

;)


Edited by nduul

Share this post


Link to post
Share on other sites
ho fatto una prova veloce ed il problema sembra proprio essere nel materiale raytrace, prova con un materiale mental ray, io su 3ds 7 ho proprio il mr glass che funziona. Altrimenti puoi provare con un materiale standard

Sei troppo un GRANDE!!! :w00t: ........guarda qui:

camionlegoda7.jpg

Il problema era il materiale come dicevi tu....ho messo un materiale mental ray e tutto funziona a meraviglia. :Clap03:

Quando sarò in grado di poterti aiutare in qualcosa sarò felice di farlo,sei stato gentilissimo.

P.S.

Se posso chiedere,a quando un nuovo up del grendizer incacchiato?

:hello:

Share this post


Link to post
Share on other sites
Il problema era il materiale come dicevi tu....ho messo un materiale mental ray e tutto funziona a meraviglia. :Clap03:

ottimo! problema risolto! :D

Se posso chiedere,a quando un nuovo up del grendizer incacchiato?

oggi :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...